Notes
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Cet article fournit une solution à un problème où le spouleur d’imprimante se bloque de façon aléatoire sur un ordinateur Windows Server sur lequel une imprimante HP est installée.
Numéro de base de connaissances d’origine : 947477
Symptômes
Sur un ordinateur Windows Server sur lequel une imprimante HP est installée, le spouleur d’imprimante peut se bloquer de façon aléatoire.
Cause
Ce problème se produit en raison de l’un des fichiers suivants :
- Hpbmmon.dll (HP Master Monitor)
- Hpzpi4wm.dll (processeur d’impression HP)
- Hpzpp4wm.dll (processeur d’impression HP)
- HPtcpMon.dll (moniteur de port TCP HP)
Résolution
Pour résoudre ce problème, contactez le fabricant tiers pour obtenir de l’aide.
Important
Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, vérifiez que vous suivez ces étapes attentivement. Pour une protection supplémentaire, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème se produit. Pour plus d’informations sur la sauvegarde et la restauration du registre, voir : Procédure de sauvegarde, de modification et de restauration du Registre dans Windows.
Solution de contournement pour le problème provoqué par Hpbmmon.dll
Pour contourner ce problème, supprimez hp Master Monitor. Pour ce faire, procédez comme suit :
Démarrez l'Éditeur du Registre.
Recherchez, puis cliquez sur la sous-clé
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Master Monitor
de Registre.Dans le menu Fichier , cliquez sur Exporter.
Dans la zone Nom de fichier, tapez HPprinter, puis cliquez sur Enregistrer.
Note
Si vous souhaitez restaurer cette sous-clé de Registre, double-cliquez sur le fichier HPprinter.reg que vous enregistrez à cette étape.
Cliquez avec le bouton droit sur l’entrée de Registre HP Master Monitor , puis cliquez sur Supprimer.
Sélectionnez Oui.
Quittez l’Éditeur du Registre, puis redémarrez l’ordinateur.
Renommez le fichier Hpbmmon.dll en Hpbmmon.old. Le fichier se trouve à l’emplacement C :\WINDOWS\system32\Hpbmmon.dll fichier.
Solution de contournement pour le problème provoqué par Hpzpi4wm.dll ou Hpzpp4wm.dll
Note
Si cette imprimante ne fonctionne pas avec WinPrint, les étapes suivantes peuvent ne pas fonctionner. Si cette situation se produit, contactez HP pour mettre à niveau le processeur d’impression HPZPP4WM vers la version la plus récente.
- Cliquez sur Démarrer, puis sur Panneau de configuration.
- Double-cliquez sur Imprimantes et télécopies.
- Cliquez avec le bouton droit sur l’imprimante que vous souhaitez utiliser, puis cliquez sur Propriétés.
- Cliquez sur l’onglet Avancé , puis sur Processeur d’impression.
- Cliquez sur WinPrint dans la zone Processeur d’impression, cliquez sur RAW dans la zone Type de données par défaut, puis sur OK deux fois.
- Renommez le fichier Hpzpi4wm.dll en Hpzpi4wm.old. Le fichier se trouve à l’emplacement suivant : C :\WINDOWS\system32\spool\drivers\w32x86\3\Hpzpi4wm.dll.
- Renommez le fichier Hpzpp4wm.dll en Hpzpp4wm.old. Le fichier se trouve à l’emplacement suivant : C :\WINDOWS\system32\spool\PRTPROCS\W32X86\Hpzpp4wm.dll.
Solution de contournement pour le problème provoqué par HPtcpMon.dll
Démarrez l'Éditeur du Registre.
Recherchez la sous-clé de Registre suivante, puis cliquez dessus :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Standard TCP/IP Port
.Dans le menu Fichier , cliquez sur Exporter.
Dans la zone Nom de fichier, tapez HPprinter, puis cliquez sur Enregistrer.
Note
Si vous souhaitez restaurer cette sous-clé de Registre, double-cliquez sur le fichier HPprinter.reg que vous enregistrez à cette étape.
Cliquez avec le bouton droit sur l’entrée de Registre du port TCP/IP HP Standard, puis cliquez sur Supprimer.
Sélectionnez Oui.
Recherchez, puis cliquez sur la sous-clé
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port
de Registre.Double-cliquez sur Pilote, puis vérifiez que la valeur de la zone de données Valeur est tcpmon.dll.
Note
Si l’entrée de Registre Driver n’existe pas ou si sa valeur n’est pas tcpmon.dll, créez l’entrée du Registre Driver , puis définissez sa valeur sur tcpmon.dll. Pour ce faire, procédez comme suit :
- Dans le menu Modifier , pointez sur Nouveau, puis cliquez sur Valeur de chaîne.
- Tapez pilote, puis appuyez sur Entrée.
- Cliquez avec le bouton droit sur Pilote, puis cliquez sur Modifier.
- Dans la zone de données Valeur, tapez tcpmon.dll, puis cliquez sur OK.
Quittez l’Éditeur du Registre, puis redémarrez l’ordinateur.
Renommez le fichier HPtcpMon.dll en HPtcpMon.old. Le fichier se trouve à l’emplacement suivant : C :\WINDOWS\system32\HPTcpMon.dll.
Plus d’informations
Les produits tiers mentionnés dans le présent article sont fabriqués par des sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.