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Liste des imprimantes vide dans la console de gestion des impression

Cet article fournit une solution à un problème indiquant que la liste des imprimantes est vide lorsque vous affichez les imprimantes sur un serveur distant via la console de gestion des impression (PMC).

Numéro de base de connaissances d’origine : 2253813

Symptômes

Lorsque vous affichez les imprimantes sur un serveur distant via la console de gestion d’impression (PMC), la liste des imprimantes est vide, mais la liste des pilotes et/ou ports peut s’afficher correctement.

Effectuer un test ping sur le nom de domaine complet du client (par exemple) client.subdomain.domain.comà partir du serveur d’impression entraîne une erreur de résolution de noms.

Cause

Le système client (le système exécutant PMC) n’a pas d’enregistrement DNS A (recherche vers l’avant) ou l’enregistrement est incorrect.

Résolution

Ajoutez un enregistrement DNS A pour le système exécutant PMC ou corrigez l’enregistrement existant.

Plus d’informations

Vous pouvez voir ce qui suit request / response dans une trace réseau. La raison pour laquelle cela peut ou ne pas se trouver dans la trace réseau est que si la résolution de noms a été tentée précédemment, la réponse est mise en cache sur le serveur. Pour effacer le cache, utilisez ipconfig /flushdns et capturez la trace.

RpcRemoteFindFirstPrinterChangeNotificationEx Request, Local Machine = \\servername.company.com, Printer Local = nnnnnn
RpcRemoteFindFirstPrinterChangeNotificationEx Response, Status = RPC_S_SERVER_UNAVAILABLE

Dans une trace réseau à partir du serveur d’impression, vous pouvez voir une requête DNS lancée, puis une réponse reçue :

DNS :QueryId = 0xB19B, QUERY (requête standard), Requête pour servername.company.com le complément hôte de type sur la classe Internet
DNS :QueryId = 0xB19B, QUERY (requête standard), Réponse - Erreur de nom

Note

La résolution de noms courte pour le nom du client peut fonctionner, via les listes de recherche de suffixes DNS (si l’enregistrement DNS se trouve dans le domaine incorrect) ou WINS. Essayez de rechercher le nom de domaine complet du client sur le serveur d’impression. En interne, le spouleur utilise le nom de domaine complet pour rappeler le client. Par conséquent, si le nom de domaine complet ne se résout pas, le rappel échoue.