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Cet article fournit de l’aide pour résoudre un problème où la query user commande n’interroge pas les informations d’un serveur distant.
Numéro de base de connaissances d’origine : 235567
Symptômes
Lorsque vous utilisez la commande utilisateur de requête pour obtenir des informations à partir d’un serveur distant, il signale que l’utilisateur n’existe pas.
Par exemple :
query user username /server:remoteserver
L’erreur suivante peut également s’afficher :
Aucun utilisateur n’existe pour le nom d’utilisateur
Cause
Ce problème se produit lorsque vous utilisez la query user commande et spécifiez un nom d’utilisateur. La commande Requête suppose qu’elle est locale et examine uniquement le serveur local pour cet utilisateur.
L’utilisation query user /SERVER:REMOTESERVER signale ces informations, mais répertorie tous les utilisateurs actuellement connectés au serveur distant.
Résolution
Pour résoudre ce problème, obtenez le dernier Service Pack pour Windows NT Server 4.0, Terminal Server Edition.
Solution de contournement
Pour contourner ce problème, utilisez l’une des méthodes suivantes :
Interrogez le serveur distant et ne tapez pas de nom d’utilisateur. Cette commande répertorie tous les utilisateurs sur ce serveur.
query user / server:remoteserverPour obtenir une liste d’utilisateurs unique, vous pouvez envoyer la sortie de la commande ci-dessus via la recherche :
query user / server:remoteserver | find "username"Créez un fichier de commandes pour rechercher un seul utilisateur.
Batch File Name: Q.bat
Tapez le texte suivant dans le fichier batch, puis enregistrez le fichier :query user / server :%1 | find "%2"
Tapez ce qui suit à l’invite de commandes :q remoteserver usernameNote
REMOTESERVER et USERNAME sont le serveur et l’utilisateur respectifs que vous essayez d’interroger.
État
Microsoft a confirmé qu’il s’agit d’un problème dans Microsoft Windows NT Server versions 4.0, 4.0 SP, Terminal Server Edition.
Ce problème a d’abord été corrigé dans Windows NT Server 4.0, Terminal Server Edition, Service Pack 5.