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Cet article traite d’un problème où vous ne pouvez pas installer Base de données interne Windows (WID) sur un ordinateur exécutant Windows Server 2012.
Numéro de base de connaissances d’origine : 2832204
Symptômes
Lorsque vous installez services de fédération Active Directory (AD FS) (AD FS) à l’aide de l’Assistant Ajout de rôles et de fonctionnalités dans Windows Server 2012, l’installation wiD échoue. Vous recevez le message d’erreur suivant :
Le service MSSQL$MICROSOFT##WID n’a pas pu se connecter en tant que service NT\MSSQL$MICROSOFT##WID avec le mot de passe actuellement configuré en raison de l’erreur suivante :
Échec d’ouverture de session : l’utilisateur n’a pas d’autorisation pour le type d’ouverture de session demandé sur cet ordinateur
Service : MSSQL$MICROSOFT##WIDDomaine et compte : NT SERVICE\MSSQL$MICROSOFT##WID
Ce compte de service n’a pas le droit d’utilisateur requis « Se connecter en tant que service ».
Action de l’utilisateur
Affectez les autorisations « Ouverture de session en tant que service » au compte de service sur cet ordinateur. Vous pouvez pour cela utiliser les Paramètres de sécurité locaux (Secpol.msc). Si cet ordinateur constitue un nœud dans un cluster, vérifiez que ce droit d’utilisateur est attribué au compte de service de cluster sur tous les nœuds du cluster. Si vous avez déjà attribué ce droit d’utilisateur au compte de service et qu’il semble avoir été supprimé, contactez votre administrateur de domaine pour savoir si un objet de stratégie de groupe associé à ce nœud supprime ce droit.
Cause
Lorsque WID est installé, le NT SERVICE\MSSQL$MICROSOFT##WID
compte virtuel local est créé. Ce compte reçoit le droit de l’utilisateur Log on as a service
par la stratégie de groupe locale. Si un objet de stratégie de groupe lié à un site, un domaine ou une unité organisationnelle remplace le paramètre de stratégie de groupe local, le compte NT SERVICE\MSSQL$MICROSOFT##WID n’a pas les droits d’utilisateur nécessaires. Par conséquent, WID ne peut pas être installé.
Solution de contournement
Pour contourner le problème, utilisez l’une des méthodes suivantes :
- Attribuez le droit de l’utilisateur
Log on as a service
à NT SERVICE\ALL SERVICES dans l’objet de stratégie de groupe qui définit le droit de l’utilisateur. - Excluez l’ordinateur de l’objet de stratégie de groupe qui définit le droit de l’utilisateur.
Plus d’informations
Vous pouvez également rencontrer d’autres symptômes dans cette situation. Par exemple, le service WID peut sembler installé, mais il ne démarre pas. En outre, l’Assistant Ajout de rôles et de fonctionnalités indique qu’un redémarrage est en attente.
Collecte de données
Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.