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La tâche planifiée peut ne pas s’exécuter lors du redémarrage si l’ordinateur est désactivé au moment de la tâche

Cet article vous aide à résoudre un problème où une tâche planifiée peut ne pas s’exécuter lors du redémarrage si l’ordinateur est désactivé au moment de la tâche.

Numéro de base de connaissances d’origine : 2437520

Symptômes

Sur un ordinateur Windows Vista, Windows 7 et Windows Server 2008 ou Windows Server 2008 R2, une tâche planifiée peut ne pas s’exécuter lors du redémarrage si l’ordinateur était désactivé au moment de la tâche planifiée.

Cause

Ce problème peut se produire si le déclencheur de tâche a été défini pour exécuter une fois créé. Il est possible de définir une tâche sur « Exécuter dès que possible une fois qu’un démarrage planifié est manqué ». Cela entraîne la réexécution de la tâche après un redémarrage si le déclencheur a été manqué. Toutefois, cela ne se produit pas si la tâche est définie pour exécuter une seule fois. Ce comportement est fait exprès.

Résolution

Vous pouvez contourner ce problème en définissant une heure et une date sous l’option Expire de la tâche. Cette option peut être atteinte en ouvrant les propriétés de la tâche, en sélectionnant l’onglet Déclencheurs , puis en cliquant sur le bouton Modifier pour le déclencheur en question. Si une date et une heure sont définies pour l’option Expire , la tâche tente de réactiver le redémarrage si son heure de déclenchement précédente a été manquée.