Une erreur se produit lors de l’installation du bureau et l’emplacement du bureau n’est pas disponible lorsque vous vous connectez à Windows pour la première fois
Cet article fournit de l’aide pour résoudre un problème où le chargement du profil échoue lorsque le fichier ntuser.dat ou usrclass.dat est défini en lecture seule, ou que l’utilisateur du profil n’a pas les autorisations appropriées pour ces deux fichiers .dat.
Numéro de la base de connaissances d’origine : 3048895
Symptômes
Une fois que vous avez installé la mise à jour dans le service De profil utilisateur Windows peut autoriser l’élévation de privilège : 13 janvier 2015 (MS15-003), vous rencontrez les problèmes suivants :
Les profils ne se chargent pas lorsque les utilisateurs se connectent à un ordinateur pour la première fois. Ou bien, vous vous connectez à un ordinateur où la stratégie supprime le profil mis en cache après un intervalle de date lorsque vous vous déconnectez.
Remarque
Les ouvertures de session qui utilisent des profils utilisateur obligatoires ou une infrastructure VDI (Virtual Desktop Infrastructure) peuvent également être affectées.
Les profils ne se chargent pas lorsque les utilisateurs se connectent à l’aide de profils utilisateur mis en cache.
Les services ne démarrent pas en raison d’échecs de chargement de profil. Les services affectés incluent, sans s’y limiter, les éléments suivants :
- Local Service
- Service réseau
- MSSQL
Lorsque ce problème se produit, les événements associés sont enregistrés. Consultez les événements enregistrés dans l’Observateur d’événements.
Le moniteur de processus peut indiquer qu’une opération CreateFile échoue avec un résultat ACCÈS REFUSÉ au chemin d’accès suivant, en fonction de la façon dont l’accès aux fichiers est limité : <drive> :\documents & settings\<username>\local settings\Application Data\Microsoft\Windows\UsrClasss.dat.
La capture d’écran de Process Monitor est visible ici :
Consultez Détails de l’échec affiché dans Process Monitor.
Cause
Update 3021674 ajoute des vérifications d’accès aux fichiers Ntuser.dat et Usrclass.dat.
Résolution
Pour résoudre ce problème, procédez comme suit :
Vérifiez si l’indicateur LECTURE SEULE est défini sur le NTUSER. DAT ou USERCLASS. Fichier DAT pour le profil qui ne parvient pas à se charger.
Les nouveaux profils utilisateur sont dérivés de C :\users\default\ lors de la première ouverture de session de compte. Si le chargement des profils échoue avec des signatures qui correspondent à celles décrites dans la section « Symptômes », vérifiez si le bit Read-Only est activé sur le NTUSER. DAT et USRCLASS. Fichiers DAT dans le répertoire de profil pour les utilisateurs ou les comptes de service en question.
NTUSER. DAT dans Windows Vista et les versions ultérieures de Windows se trouve dans C :\users\default\ntuser.dat. Les systèmes d’exploitation antérieurs ont d’autres chemins d’accès, tels que C :\Documents and Settings\<username>\ntuser.dat.
The USRCLASS. Le fichier DAT se trouve généralement le long d’un chemin d’accès comme C :\Documents and Settings<user_name>\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat ou C :\Users<user_name>\AppData\Local\Microsoft\Windows.
Dans l’Explorateur Windows, cliquez avec le bouton droit sur NTUSER. Fichier DAT ou USRCLASS pour l’utilisateur par défaut ou le profil utilisateur mis en cache approprié. La case à cocher Lecture seule doit être désactivée. Si cette case à cocher est cochée, cela entraîne des échecs de chargement du profil.
Vérifiez le paramètre d’autorisations du système de fichiers NTFS sur le NTUSER. DAT ou USERCLASS. Fichier DAT dans le répertoire de profil mis en cache qui ne parvient pas à se charger.
Dans la capture d’écran suivante, l’utilisateur de test, CONTOSO/testUser, a le contrôle total sur NTUSER. DAT (non affiché) et USRCLASS.DAT. Tout le monde n’est pas répertorié dans le groupe Éditeur de liste de contrôle d’accès.
ACLS du système de fichiers NTFS sur les fichiers DAT | Liste de contrôle d’accès avancée du système de fichiers NTFS sur les fichiers DAT |
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État
Microsoft a confirmé l’existence de ce problème dans les produits Microsoft répertoriés dans la section « Produits concernés ».
Informations supplémentaires
Événements enregistrés dans l’Observateur d’événements
Nom du journal | Expéditeur de l’événement | ID d’événement | Texte du message d’événement |
---|---|---|---|
Application | Service de profils utilisateur Microsoft-Windows | 1542 | Windows ne peut pas charger le fichier de Registre des classes. DETAIL - Erreur non spécifiée Die Klassenregistrierungsdatei kann nicht geladen werden. DETAIL - Unbekannter Fehler |
Application | Gestionnaire de contrôle des services | 7005 | L’appel LoadUserProfile a échoué avec l’erreur suivante : Le fichier spécifié est introuvable. |
Application | Gestionnaire de contrôle des services | 7024 | Le service SQL Server (MSSQLSERVER) s’est arrêté avec une erreur spécifique au service 2148081668 (0x80092004). |
Application | Userenv | 1500 | Windows ne peut pas vous connecter, car votre profil ne peut pas être chargé. Vérifiez que vous êtes connecté au réseau ou que votre réseau fonctionne correctement. Si ce problème persiste, contactez votre administrateur réseau. DETAIL : le système ne trouve pas le fichier spécifié. |
Application | Userenv | 1502 | Windows ne peut pas charger le profil stocké localement. Les causes possibles de cette erreur incluent des droits de sécurité insuffisants ou un profil local endommagé. Si ce problème persiste, contactez votre administrateur réseau. |
Détails de l’échec affichés dans process Monitor
Détails de ProMonLe message suivant s’affiche dans Process Monitor :
Accès souhaité : Lecture/écriture générique, Disposition : Ouvert, Options : Non-Alerte d’E/S synchrones, Fichier non-répertoire, Attributs : H, ShareMode : Lecture, Écriture, AllocationSize : n/a, Emprunt d’identité : <SID>
La capture d’écran suivante montre les détails du moniteur de processus :
Commentaires
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