Abonnements Visual Studio – Pourquoi les comptes personnels de mes abonnés sont-ils affichés ?

Quand les entreprises ont migré du centre de gestion des licences en volume (VLSC) vers le nouveau portail d’administration des abonnements Visual Studio, les administrateurs ont été surpris de découvrir que l’« adresse e-mail de connexion » de certains abonnés correspondait à une adresse e-mail personnelle comme Hotmail ou Outlook.

Cause

Ceci est dû à des processus de connexion qui ont été associés à l’expérience héritée pour les abonnés MSDN. Les utilisateurs ont été migrés du centre de gestion des licences en volume (VLSC) vers le portail d’administration des abonnements Visual Studio sans modifications. Les administrateurs peuvent ignorer que certains utilisateurs se servent de comptes personnels pour accéder aux avantages de leur abonnement. Avant les migrations des abonnés Visual Studio, qui se sont terminées en 2016, deux actions étaient nécessaires pour pouvoir utiliser un abonnement de Visual Studio :

  1. L’administrateur « attribuait » l’abonnement à un abonné spécifique à l’aide de son adresse e-mail professionnelle ou scolaire.
  2. L’abonné « activait » l’abonnement.

Au cours du processus d’activation de l’abonné, un compte Microsoft (MSA) était nécessaire pour se connecter. Si l’abonné ne cherchait pas à définir son compte professionnel ou scolaire (par exemple, tasha@contoso.com) en tant que compte MSA, il pouvait créer un compte MSA ou en utiliser un existant. Comme il utilisait une adresse e-mail personnelle, son « adresse e-mail de connexion » était différente de son « adresse e-mail attribuée ».

Remarque

L’expérience d’abonné moderne sur https://my.visualstudio.com prend en charge à la fois les types d’identité Compte professionnel/scolaire et Compte Microsoft.

Solution

Pour corriger le problème, sélectionnez le bouton Connecter des e-mails. Le système tente de faire correspondre les comptes avec MSA aux utilisateurs existants dans le Microsoft Entra ID de votre organisation en se basant sur la correspondance du prénom et du nom de famille. En cas d’erreur, vous pouvez supprimer une correspondance en sélectionnant le X à droite de la correspondance.

Regardez cette vidéo ou continuez à lire cet article pour savoir comment résoudre ce problème.

Bouton Connecter les e-mails

Vous pouvez également utiliser l’option Rechercher dans l’annuaire pour corriger les erreurs ou renseigner les informations manquantes à partir de votre annuaire Microsoft Entra ID. Si toutes les correspondances semblent correctes, vous pouvez choisir le bouton Identité actuelle pour sélectionner toutes les entrées correspondantes au lieu de les sélectionner une par une.

Fenêtre volante Connecter les e-mails

Sélectionnez ensuite Continuer pour accéder à une liste de changements à apporter. Si vous êtes d’accord, sélectionnez Enregistrer pour appliquer les changements. Votre abonné recevra également un message l’informant de la modification la prochaine fois qu’il se connectera à son abonnement. Notez que seuls les deux abonnés qui ont été mis en correspondance dans l’annuaire Microsoft Entra ID apparaissent dans cette liste. Dans notre exemple, dans la mesure où Frederick n’a pas d’adresse correspondante dans l’annuaire Microsoft Entra ID, son compte Microsoft (MSA) n’a pas été mis en correspondance avec un compte professionnel.

Remarque

Quand vous modifiez l’adresse e-mail de connexion, cela met à jour uniquement l’e-mail utilisé par l’abonné pour se connecter à son abonnement sur https://my.visualstudio.com. Si l’abonné a déjà activé des avantages tels qu’Azure ou Pluralsight à l’aide de l’autre adresse e-mail, il doit continuer à l’utiliser pour y accéder. Pour tous les nouveaux avantages auxquels il accède, il doit utiliser la nouvelle adresse e-mail.

Ressources de support

Pour obtenir de l’aide sur l’administration des abonnements Visual Studio, contactez le support des abonnements Visual Studio.

Voir aussi

Étapes suivantes

  • Si vous mettez à jour les adresses e-mail des abonnés, vous pouvez les informer que leurs informations de connexion ont changé. Ils recevront un e-mail contenant les informations mises à jour.
  • Il peut être utile de filtrer la liste des abonnés de votre organisation pour rechercher les adresses e-mail de connexion qui peuvent nécessiter une modification.