0x26 de vérification des bogues : CDFS_FILE_SYSTEM

Le case activée de bogue CDFS_FILE_SYSTEM a une valeur de 0x00000026. Cela indique qu’un problème s’est produit dans le système de fichiers CD.

Important

Cet article s’adresse aux programmeurs. Si vous êtes un client qui a reçu un code d’erreur d’écran bleu lors de l’utilisation de votre ordinateur, consultez Résoudre les erreurs d’écran bleu.

paramètres CDFS_FILE_SYSTEM

Paramètre Description

1

Spécifie les informations de fichier source et de numéro de ligne. Les 16 bits élevés (les quatre premiers chiffres hexadécimaux après le « 0x ») identifient le fichier source par son numéro d’identificateur. Les 16 bits faibles identifient la ligne source dans le fichier où le bogue case activée s’est produit.

2

Si CdExceptionFilter se trouve sur la pile, ce paramètre spécifie l’adresse de l’enregistrement d’exception.

3

Si CdExceptionFilter se trouve sur la pile, ce paramètre spécifie l’adresse de l’enregistrement de contexte.

4

Réservé

Cause

L’une des causes possibles de cette case activée de bogue est l’altération du disque. Une altération dans le système de fichiers ou des blocs incorrects (secteurs) sur le disque peuvent provoquer cette erreur. Les pilotes SCSI et IDE endommagés peuvent également nuire à la capacité du système à lire et à écrire sur le disque, ce qui entraîne l’erreur.

Une autre cause possible est l’épuisement de la mémoire du pool non paginé. Si la mémoire du pool non paginé est complètement épuisée, cette erreur peut arrêter le système. Toutefois, pendant le processus d’indexation, si la quantité de mémoire du pool non paginé disponible est très faible, un autre pilote en mode noyau nécessitant une mémoire de pool non paginé peut également déclencher cette erreur.

Résolution

Pour déboguer ce problème : Utilisez la commande .cxr (Display Context Record) avec le paramètre 3, puis utilisez kb (Display Stack Backtrace).

Pour résoudre un problème d’altération du disque : Vérifiez observateur d'événements les messages d’erreur SCSI et FASTFAT (journal système) ou autochk (journal des applications) qui peuvent aider à identifier le périphérique ou le pilote à l’origine de l’erreur. Essayez de désactiver les scanneurs de virus, les programmes de sauvegarde ou les outils de défragmenteur de disque qui surveillent en permanence le système. Vous devez également exécuter du matériel diagnostics fourni par le fabricant du système. Pour plus d’informations sur ces procédures, consultez le manuel du propriétaire de votre ordinateur. Exécutez Chkdsk /f /r pour détecter et résoudre toute altération structurelle du système de fichiers. Vous devez redémarrer le système avant que l’analyse de disque ne commence sur une partition système.

Pour résoudre un problème d’épuisement de mémoire de pool non paginé : Ajoutez une nouvelle mémoire physique à l’ordinateur. Cela augmente la quantité de mémoire du pool non paginé disponible pour le noyau.