Vérification de bogue égale 0x26 : CDFS_FILE_SYSTEM

Le contrôle de bogue CDFS_FILE_SYSTEM a la valeur 0x00000026. Cela indique qu’un problème s’est produit dans le système de fichiers CD.

Important

Cette rubrique s’adresse aux développeurs. Si vous êtes un client qui a reçu un code d’erreur d’écran bleu lors de l’utilisation de votre ordinateur, consultez résoudre les erreurs d’écran bleu.

Paramètres CDFS_FILE_SYSTEM

Paramètre Description

1

Spécifie les informations sur le fichier source et le numéro de ligne. Les 16 bits de poids fort (les quatre premiers chiffres hexadécimaux après « 0x ») identifient le fichier source par son numéro d’identificateur. Les 16 bits de poids faible identifient la ligne source dans le fichier où la vérification de bogue s’est produite.

2

Si CdExceptionFilter se trouve sur la pile, ce paramètre spécifie l’adresse de l’enregistrement d’exception.

3

Si CdExceptionFilter se trouve sur la pile, ce paramètre spécifie l’adresse de l’enregistrement de contexte.

4

Réservé

Cause

L’une des causes possibles de ce contrôle de bogue est l’endommagement du disque. Une altération du système de fichiers ou des blocs défectueux (secteurs) sur le disque peut provoquer cette erreur. Les pilotes SCSI et IDE endommagés peuvent également nuire à la capacité du système à lire et écrire sur le disque, provoquant ainsi l’erreur.

Une autre cause possible est l’épuisement de la mémoire de réserve non paginée. Si la mémoire de réserve non paginée est entièrement épuisée, cette erreur peut arrêter le système. Toutefois, pendant le processus d’indexation, si la quantité de mémoire de pool non paginée disponible est très faible, un autre pilote en mode noyau nécessitant une mémoire de pool non paginée peut également déclencher cette erreur.

Résolution

Pour déboguer ce problème : Utilisez la commande . CXR (afficher l’enregistrement de contexte) avec le paramètre 3, puis utilisez KB (afficher la trace de la pile).

Pour résoudre un problème d’endommagement du disque : vérifiez observateur d’événements pour les messages d’erreur de SCSI et FASTFAT (journal système) ou Autochk (journal des applications) qui peuvent vous aider à identifier l’appareil ou le pilote à l’origine de l’erreur. Essayez de désactiver les antivirus, les programmes de sauvegarde ou les outils de défragmentation de disque qui surveillent continuellement le système. Vous devez également exécuter les diagnostics matériels fournis par le fabricant du système. Pour plus d’informations sur ces procédures, consultez le manuel du propriétaire de votre ordinateur. Exécutez chkdsk/f/r pour détecter et résoudre toute altération structurelle du système de fichiers. Vous devez redémarrer le système avant le début de l’analyse du disque sur une partition système.

Pour résoudre un problème d’épuisement de la mémoire d’un pool non paginé : Ajoutez une nouvelle mémoire physique à l’ordinateur. Cela augmentera la quantité de mémoire de réserve non paginée disponible pour le noyau.