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Bug Check 0x7E : SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Le contrôle d’erreur SYSTEM_THREAD_EXCEPTION_NOT_HANDLED a une valeur de 0x0000007E. Ce contrôle d’erreur indique qu’un thread système a généré une exception que le gestionnaire d’erreurs n’a pas captée.

Important

Cet article s’adresse aux programmeurs. Si vous êtes un client et que vous avez reçu ce code d’erreur d’écran bleu en utilisant votre ordinateur, consultez Résoudre les erreurs d’écran bleu.

Paramètres de SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Paramètre Description
1 Le code d’exception qui n’a pas été intercepté.
2 L’adresse où l’exception s’est produite.
3 L’adresse de l’enregistrement de l’exception.
4 L’adresse de l’enregistrement du contexte.

Cause

Ce contrôle d’erreur indique qu’un thread système a généré une exception que le gestionnaire d’erreurs n’a pas captée. Pour l’interpréter, vous devez identifier l’exception qui a été générée.

Les codes d’exception courants incluent les suivants :

  • 0x80000002 : STATUS_DATATYPE_MISALIGNMENT indique qu’une référence de données mal alignée a été rencontrée.

  • 0x80000003 : STATUS_BREAKPOINT indique qu’un point d’arrêt ou une ASSERT a été rencontré alors qu’aucun débogueur noyau n’était attaché au système.

  • 0xC0000005 : STATUS_ACCESS_VIOLATION indique qu’une violation d’accès à la mémoire s’est produite.

Pour une liste complète des codes d’exception, veuillez consulter la section Valeurs NTSTATUS. Les codes d’exception sont définis dans ntstatus.h, un fichier d’en-tête fourni par le Kit de pilotes Windows. Pour plus d’informations, veuillez consulter la section Fichiers d’en-tête dans le Kit de pilotes Windows.

Résolution

Si vous prévoyez de déboguer ce problème, l’adresse de l’exception (paramètre 2) devrait identifier le pilote ou la fonction qui a causé ce problème.

Si un pilote est listé par son nom dans le message de contrôle d’erreur, désactivez ou supprimez ce pilote. Si le problème est limité à un seul pilote, définissez des points d’arrêt et exécutez le code pas à pas pour localiser l’erreur et comprendre les événements menant au crash.

L’extension de débogueur !analyze affiche des informations sur le contrôle d’erreur et peut être utile pour déterminer la cause racine.

Une analyse plus approfondie peut être effectuée en utilisant l’extension !thread et les commandes dds, dps et dqs (afficher des mots et des symboles). Cette technique est raisonnable lorsque WinDbg signale « Probably caused by : ntkrnlmp.exe ».

Si le code d’exception 0x80000003 se produit, un point d’arrêt ou une assertion codé en dur a été atteint, mais le système a été démarré avec l’option /NODEBUG. Ce problème ne devrait pas se produire fréquemment. S’il se produit de manière répétée, assurez-vous qu’un débogueur noyau est connecté et que le système est démarré avec l’option /DEBUG.

Si le code d’exception 0x80000002 se produit, le cadre de piégeage fournit des informations supplémentaires.

Pour plus d’informations sur WinDbg et !analyze, veuillez consulter :

Notes

Si vous n’êtes pas équipé pour utiliser le débogueur Windows pour résoudre ce problème, vous devriez utiliser quelques techniques de dépannage de base :

  • Vérifiez le journal système dans l’Observateur d’événements pour plus de messages d’erreur qui pourraient aider à identifier le périphérique ou le pilote qui cause le contrôle d’erreur 0x7E.

  • Si un pilote est identifié dans le message de bug check, désactivez le pilote ou vérifiez auprès du fabricant les mises à jour du pilote.

  • Contactez votre fournisseur de matériel pour obtenir des mises à jour de microprogrammes ou d’ACPI. Des problèmes matériels, tels que les incompatibilités système, les conflits de mémoire et les conflits d’IRQ, peuvent également générer cette erreur.

  • Désactivez la mise en cache/la capture instantanée de la mémoire du BIOS pour tenter de résoudre l’erreur. Vous pouvez également exécuter les diagnostics matériels fournis par le fabricant du système.

  • Confirmez que tout nouveau matériel installé est compatible avec la version installée de Windows. Par exemple, vous pouvez obtenir des informations sur le matériel requis sur les Spécifications de Windows 10.

Pour des informations de dépannage plus générales, veuillez consulter la section Analyser les données d’écran bleu de vérification des bogues.