0x9B de vérification des bogues : UDFS_FILE_SYSTEM

La valeur du bogue UDFS_FILE_SYSTEM case activée est 0x0000009B. Ce bogue case activée indique qu’un problème s’est produit dans le système de fichiers UDF.

Important

Cet article s’adresse aux programmeurs. Si vous êtes un client qui a reçu un code d’erreur d’écran bleu lors de l’utilisation de votre ordinateur, consultez Résoudre les erreurs d’écran bleu.

paramètres UDFS_FILE_SYSTEM

Paramètre Description

1

Informations sur le fichier source et le numéro de ligne. Les 16 bits élevés (les quatre premiers chiffres hexadécimaux après le « 0x ») identifient le fichier source par son numéro d’identificateur. Les 16 bits faibles identifient la ligne source dans le fichier où le bogue case activée s’est produit.

2

Si UdfExceptionFilter se trouve sur la pile, ce paramètre spécifie l’adresse de l’enregistrement d’exception.

3

Si UdfExceptionFilter se trouve sur la pile, ce paramètre spécifie l’adresse de l’enregistrement de contexte.

4

Réservé.

Cause

Le bogue UDFS_FILE_SYSTEM case activée peut être provoqué par une altération du disque. Une altération dans le système de fichiers ou des blocs incorrects (secteurs) sur le disque peuvent provoquer cette erreur. Les pilotes SCSI et IDE endommagés peuvent également nuire à la capacité du système à lire et écrire sur le disque et provoquer l’erreur.

Ce bogue case activée peut également se produire si la mémoire du pool non paginé est pleine. Si la mémoire du pool non paginé est pleine, cette erreur peut arrêter le système. Toutefois, pendant le processus d’indexation, si la quantité de mémoire du pool non paginé disponible est très faible, un autre pilote en mode noyau qui nécessite de la mémoire du pool non paginé peut également déclencher cette erreur.

Résolution

Pour déboguer ce problème : Utilisez la commande .cxr (Display Context Record) avec le paramètre 3, puis utilisez kb (Display Stack Backtrace).

Pour résoudre un problème d’altération du disque : Vérifiez observateur d'événements les messages d’erreur SCSI et FASTFAT (journal système) ou autochk (journal de l’application) qui peuvent aider à identifier le périphérique ou le pilote à l’origine de l’erreur. Désactivez les analyseurs de virus, les applications de sauvegarde ou les outils de défragmenteur de disque qui surveillent continuellement le système. Vous devez également exécuter du matériel diagnostics que le fabricant du système fournit. Pour plus d’informations sur ces procédures, consultez le manuel du propriétaire de votre ordinateur. Exécutez Chkdsk /f /r pour détecter et résoudre toute altération structurelle du système de fichiers. Vous devez redémarrer le système avant que l’analyse de disque ne commence sur une partition système.

Pour résoudre un problème d’épuisement de mémoire de pool non paginé : Ajoutez une nouvelle mémoire physique à l’ordinateur. Cette mémoire augmente la quantité de mémoire du pool non paginé disponible pour le noyau.