Vérification de bogue 0xC000021A : WINLOGON_FATAL_ERROR

Le contrôle de bogue WINLOGON_FATAL_ERROR a la valeur 0xC000021A. Cela signifie que le processus Winlogon s’est arrêté de manière inattendue.

Important

Cette rubrique s’adresse aux développeurs. Si vous êtes un client qui a reçu un code d’erreur d’écran bleu lors de l’utilisation de votre ordinateur, consultez résoudre les erreurs d’écran bleu.

Paramètres WINLOGON_FATAL_ERROR

Paramètre Description

1

Chaîne qui identifie le problème.

2

Le code d'erreur

3

Réservé

4

Réservé

Cause

Cette erreur se produit lorsqu’un sous-système en mode utilisateur, tel que WinLogon ou le serveur client Run-Time sous-système (CSRSS), a été corrompu et que la sécurité ne peut plus être garantie. En réponse, le système d’exploitation passe en mode noyau. Microsoft Windows ne peut pas s’exécuter sans WinLogon ou CSRSS. C’est donc l’un des rares cas où la défaillance d’un service en mode utilisateur peut arrêter le système.

Des fichiers système incompatibles peuvent également provoquer cette erreur. Cette incompatibilité peut se produire si vous avez restauré votre disque dur à partir d’une sauvegarde. Certains programmes de sauvegarde peuvent ignorer la restauration des fichiers système qu’ils déterminent en cours d’utilisation.

Résolution

L’exécution du débogueur de noyau peut ne pas être utile dans ce cas, car l’erreur réelle s’est produite dans un processus en mode utilisateur.

Résolution d’une erreur dans un pilote de périphérique en mode utilisateur, un service système ou une application tierce

Étant donné que le contrôle de bogue 0xC000021A se produit dans un processus en mode utilisateur, les causes les plus courantes sont les applications tierces. Si l’erreur s’est produite après l’installation d’un pilote de périphérique nouveau ou mis à jour, d’un service système ou d’une application tierce, le nouveau logiciel doit être supprimé ou désactivé afin d’en isoler la cause. Contactez le fabricant du logiciel pour obtenir une mise à jour possible.

Résolution d’un problème de fichier système incompatible

Si vous avez récemment restauré votre disque dur à partir d’une sauvegarde, vérifiez si une version mise à jour du programme de sauvegarde/restauration est disponible auprès du fabricant.

  • Examinez les applications installées le plus récemment. Pour ce faire, accédez à « désinstaller ou modifier un programme » dans le panneau de configuration et triez les applications installées par date d’installation.

  • recherchez dans le journal système observateur d’événements des messages d’erreur supplémentaires susceptibles de vous aider à identifier l’appareil ou le pilote à l’origine de l’erreur. pour plus d’informations, consultez Open observateur d’événements. Recherchez dans le journal système des erreurs critiques qui se sont produites dans la même fenêtre temporelle que l’écran bleu.

  • recherchez dans le journal système observateur d’événements des messages d’erreur supplémentaires susceptibles de vous aider à identifier l’appareil ou le pilote à l’origine de l’erreur. Recherchez dans le journal système des erreurs critiques qui se sont produites dans la même fenêtre temporelle que l’écran bleu.

Remarques

  • Utilisez l’outil Vérificateur des fichiers système pour réparer les fichiers système manquants ou endommagés. le vérificateur de fichiers système est un utilitaire de Windows qui permet aux utilisateurs de rechercher des altérations dans les fichiers système Windows et de restaurer les fichiers endommagés. Utilisez la commande suivante pour exécuter l’outil Vérificateur de fichiers système (SFC.exe).

    SFC /scannow
    

    Pour plus d’informations, consultez utiliser l’outil de vérification des fichiers système pour réparer les fichiers système manquants ou endommagés.

  • Exécutez un programme de détection de virus. les virus peuvent infecter tous les types de disques durs formatés pour Windows, et la corruption de disque résultante peut générer des codes de vérification de bogue système. Assurez-vous que le programme de détection de virus vérifie si l’enregistrement de démarrage principal présente des infections.

  • Vérifiez que les dernières mises à jour sont installées sur le système. Pour détecter la version installée sur votre système, sélectionnez Démarrer, sélectionnez exécuter, tapez winver, puis appuyez sur entrée. la boîte de dialogue à propos de Windows affiche le numéro de version de Windows (et le numéro de version de la Service Pack, le cas échéant).

utilisation du Mode Coffre

envisagez d’utiliser le Mode Coffre pour isoler les éléments à des fins de dépannage et, si nécessaire, pour utiliser Windows. l’utilisation du Mode Coffre charge uniquement les pilotes et les services système minimaux requis au démarrage du Windows.

pour entrer en Mode Coffre, utilisez mise à jour et sécurité dans Paramètres. Sélectionnez récupération>avancé au démarrage pour démarrer en mode maintenance. dans le menu qui en résulte, choisissez résoudre les problèmes> d'Options> avancéesdémarrage Paramètres>redémarrage. après le redémarrage de Windows et l’affichage de l’écran de démarrage Paramètres , sélectionnez l’option 4, 5 ou 6 pour démarrer en Mode Coffre.

le Mode de Coffre peut également être disponible en appuyant sur une touche de fonction au démarrage, par exemple F8. Reportez-vous aux informations du fabricant de l’ordinateur pour obtenir des options de démarrage spécifiques.