Remarque
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Utilisez ces suggestions pour résoudre les problèmes rencontrés lors de l’empaquetage, du déploiement ou de l’interrogation d’un package d’application Windows (.msix/.appx) en tant que développeur.
Note
Cet article est destiné aux développeurs. Si vous n’êtes pas développeur et que vous recherchez de l’aide sur une erreur d’installation d’application Windows, consultez Windows support.
Obtenir des informations de diagnostic
Lorsqu’une API échoue, elle retourne un code d’erreur qui décrit le problème. Si le code d’erreur ne fournit pas suffisamment d’informations, vous trouverez plus d’informations de diagnostic dans les journaux d’événements détaillés.
Pour accéder aux journaux des événements d’empaquetage et de déploiement à l’aide de observateur d'événements, procédez comme suit :
Effectuez l’une des étapes suivantes :
- Cliquez sur Démarrage dans le menu Windows, tapez observateur d'événements et pressez Entrée.
- Exécutez eventvwr.msc.
Dans le volet de gauche, développer Observateur d'événements (Local)>Journaux des applications et des services>Microsoft>Windows.
Recherchez les journaux disponibles dans les catégories suivantes :
- AppxPackagingOM>Microsoft-Windows-AppxPackaging/Operational
- AppXDeployment-Server>Microsoft-Windows-AppXDeploymentServer/Operational
Commencez par examiner les journaux sous AppXDeployment-Server. Si l’erreur a été provoquée par 0x80073CF0 ou ERROR_INSTALL_OPEN_PACKAGE_FAILED, des détails supplémentaires peuvent être présents dans les journaux AppxpackagingOM .
Vous pouvez également utiliser la commande Get-AppxLog dans PowerShell pour obtenir les premiers événements journalisés. L’exemple suivant affiche les journaux de l’opération de déploiement la plus récente.
Get-Appxlog
L’exemple suivant affiche les journaux associés à l’opération de déploiement la plus récente sous forme de table interactive dans une fenêtre distincte.
Get-Appxlog | Out-GridView
Codes d’erreur courants
Ce tableau répertorie certains des codes d’erreur les plus courants. Si vous avez besoin d’aide supplémentaire pour l’une de ces erreurs ou si vous rencontrez un code d’erreur qui ne figure pas dans cette liste, consultez des options d’aide supplémentaires.
| Code d'erreur | Valeur | Description et causes possibles |
|---|---|---|
| E_FILENOTFOUND | 0x80070002 | Le fichier ou le chemin d’accès est introuvable. Cela peut se produire lors d’une validation COM typelib nécessite que le chemin d’accès du répertoire existe réellement dans votre package MSIX. |
| ERROR_BAD_FORMAT | 0x8007000B | Le package n’est pas correctement mis en forme et doit être recréé ou ré-signé. Vous pouvez obtenir cette erreur s’il existe une incompatibilité entre le nom de l’objet du certificat de signature et le nom de l’éditeur AppxManifest.xml. Découvrez comment signer un package d’application à l’aide de SignTool. |
| E_INVALIDARG | 0x80070057 | Un ou plusieurs arguments ne sont pas valides. Si vous vérifiez le journal des événements AppXDeployment-Server et que vous voyez l’événement suivant : « Lors de l’installation du package, le système n’a pas enregistré l’extension windows.repositoryExtension en raison de l’erreur suivante : Le paramètre est incorrect ». Vous pouvez obtenir cette erreur si les éléments manifeste DisplayName ou Description contiennent des caractères interdits par Windows pare-feu tel que |, en raison duquel Windows ne parvient pas à créer le profil AppContainer pour le package. Supprimez ces caractères du manifeste et essayez d’installer le package. |
|
ERROR_INSTALL_OPEN_ PACKAGE_FAILED |
0x80073CF0 | Impossible d’ouvrir le package. Causes possibles :
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ERROR_INSTALL_PACKAGE_ NOT_FOUND |
0x80073CF1 | Impossible de trouver le package. Vous pouvez obtenir cette erreur lors de la suppression d’un package qui n’est pas installé pour l’utilisateur actuel. |
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ERROR_INSTALL_INVALID_ PAQUET |
0x80073CF2 | Les données du package ne sont pas valides. |
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ERROR_INSTALL_RESOLVE_ DÉPENDANCE_ÉCHOUÉE |
0x80073CF3 | Échec de la mise à jour, de la validation des dépendances ou des conflits du package. Causes possibles :
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ERROR_INSTALL_OUT_ OF_DISK_SPACE |
0x80073CF4 | Il n’y a pas suffisamment d’espace disque sur votre ordinateur. Libérez de l’espace et réessayez. |
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ERROR_INSTALL_NETWORK_ ÉCHEC |
0x80073CF5 | Le package ne peut pas être téléchargé. |
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ERROR_INSTALL_ REGISTRATION_FAILURE |
0x80073CF6 | Le package ne peut pas être enregistré. Pour plus d’informations, consultez le journal des événements AppXDeployment-Server . |
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ERROR_INSTALL_ DEREGISTRATION_EFAILURE |
0x80073CF7 | Le package ne peut pas être désenregistré. Vous pouvez obtenir cette erreur lors de la suppression d’un package. Pour plus d’informations, consultez le journal des événements AppXDeployment-Server . |
| ERROR_INSTALL_CANCEL | 0x80073CF8 | L’utilisateur a annulé la demande d’installation. |
| ERROR_INSTALL_FAILED | 0x80073CF9 | Échec de l’installation du package. Contactez le fournisseur de logiciels. Pour plus d’informations, consultez le journal des événements AppXDeployment-Server . |
| ERROR_REMOVE_FAILED | 0x80073CFA | Échec de la suppression du package. Vous pouvez obtenir cette erreur pour les échecs qui se produisent lors de la désinstallation du package. Pour plus d’informations, consultez RemovePackageAsync. |
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ERROR_PACKAGE_ ALREADY_EXISTS |
0x80073CFB | Le package fourni est déjà installé et la réinstallation du package est bloquée. Vous pouvez obtenir cette erreur si vous installez un package qui n’est pas identique au niveau du bit au package déjà installé. Notez que la signature numérique fait également partie du package. Par conséquent, si un package est reconstruit ou résigné, il n’est plus identique au niveau du bit au package précédemment installé. Deux options possibles pour corriger cette erreur sont les suivantes : (1) Incrémenter le numéro de version de l’application, puis recréer et régénérer le package (2) Supprimer l’ancien package pour chaque utilisateur sur le système avant d’installer le nouveau package. |
| ERREUR_A_BESOIN_DE_CORRECTION | 0x80073CFC | L’application ne peut pas être démarrée. Essayez de réinstaller l’application. |
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ERROR_INSTALL_ PREREQUISITE_FAILED |
0x80073CFD | Un prérequis d’installation spécifié n’a pas pu être satisfait. |
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ERROR_PACKAGE_ DÉPÔT_CORROMPU |
0x80073CFE | Le référentiel de packages est endommagé. Vous pouvez obtenir cette erreur si le dossier référencé par cette clé de Registre n’existe pas ou est endommagé : HKLM\Software\Microsoft\Windows</strong> CurrentVersion\Appx\PackageRepositoryRoot Pour récupérer à partir de cet état, actualisez votre PC. |
|
ERROR_INSTALL_ ÉCHEC_POLITIQUE |
0x80073CFF | Pour installer cette application, vous avez besoin d’une licence de développeur ou d’un système avec le chargement latéral activé. Vous pouvez obtenir cette erreur si le package ne répond pas à l’une des exigences suivantes :
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| ERROR_PACKAGE_UPDATING | 0x80073D00 | L’application ne peut pas être démarrée, car elle est actuellement mise à jour. |
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ERROR_DEPLOYMENT_ Bloqué par la politique |
0x80073D01 | L’opération de déploiement de paquet est bloquée par la stratégie. Contactez votre administrateur système. Causes possibles :
|
| ERROR_PACKAGES_IN_USE | 0x80073D02 | Impossible d’installer le package, car les ressources qu’elle modifie sont actuellement en cours d’utilisation. |
|
ERROR_RECOVERY_ FILE_CORRUPT |
0x80073D03 | Impossible de récupérer le package, car les données nécessaires à la récupération sont endommagées. |
|
ERROR_INVALID_ STAGED_SIGNATURE |
0x80073D04 | La signature n’est pas valide. Pour vous inscrire en mode développeur, AppxSignature.p7x et AppxBlockMap.xml doivent être valides ou ne doivent pas être présents. Si vous êtes développeur utilisant F5 avec Visual Studio, assurez-vous que votre répertoire de projet généré ne contient pas de signatures ou ne bloque pas les fichiers mappés des versions précédentes du package. |
|
ERROR_DELETING_EXISTING_ APPLICATIONDATA_STORE_FAILED |
0x80073D05 | Une erreur s’est produite lors de la suppression des données d’application existantes du package. Vous pouvez obtenir cette erreur si le simulateur est en cours d’exécution. Fermez le simulateur. Vous pouvez également obtenir cette erreur s’il existe des fichiers ouverts dans les données de l’application (par exemple, si vous avez un fichier journal ouvert dans un éditeur de texte). |
|
ERROR_INSTALL_ PACKAGE_DOWNGRADE |
0x80073D06 | Impossible d’installer le package, car une version ultérieure de ce package est déjà installée. |
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ERROR_SYSTEM_ BESOIN_DE_CORRECTION |
0x80073D07 | Une erreur dans un fichier binaire système a été détectée. Pour résoudre le problème, essayez d’actualiser le PC. |
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ERROR_APPX_INTEGRITY_ FAILURE_EXTERNAL |
0x80073D08 | Un binaire non Windows endommagé a été détecté sur le système. |
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ERROR_RESILIENCY_ FILE_CORRUPT |
0x80073D09 | L’opération n’a pas pu être reprise, car les données nécessaires à la récupération sont endommagées. |
|
ERROR_INSTALL_FIREWALL_ SERVICE_NOT_RUNNING |
0x80073D0A | Impossible d'installer le package, car le service de pare-feu Windows n'est pas en cours d'exécution. Activez le service de pare-feu Windows et réessayez. |
| ERROR_PACKAGE_MOVE_FAILED | 0x80073D0B | Échec de l’opération de déplacement de package. |
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ERROR_INSTALL_VOLUME_ NOT_EMPTY |
0x80073D0C | L’opération de déploiement a échoué, car le volume n’est pas vide. |
|
ERROR_INSTALL_VOLUME_ HORS-LIGNE |
0x80073D0D | L’opération de déploiement a échoué, car le volume est hors ligne. Pour une mise à jour de package, le volume fait référence au volume installé de toutes les versions du package. |
|
ERROR_INSTALL_VOLUME_ CORROMPU |
0x80073D0E | L’opération de déploiement a échoué, car le volume spécifié est endommagé. |
|
ERREUR_BESOIN_D'INSCRIPTION |
0x80073D0F | L’opération de déploiement a échoué, car l’application spécifiée doit d’abord être inscrite. |
|
ERROR_INSTALL_WRONG_ PROCESSOR_ARCHITECTURE |
0x80073D10 | L’opération de déploiement a échoué, car le package cible l’architecture incorrecte du processeur. |
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ERROR_DEV_SIDELOAD_ LIMIT_EXCEEDED |
0x80073D11 | Vous avez atteint le nombre maximal de packages chargés en parallèle par le développeur autorisés sur cet appareil. Désinstallez un package installé manuellement et réessayez. |
|
ERROR_INSTALL_OPTIONAL_ PACKAGE_REQUIRES_ PAQUET_PRINCIPAL |
0x80073D12 | Un package d’application principal est nécessaire pour installer ce package facultatif. Installez d’abord le package principal et réessayez. |
|
ERROR_PACKAGE_NOT_ SUPPORTÉ_SUR_SYSTÈME_DE_FICHIERS |
0x80073D13 | Ce type de package d’application n’est pas pris en charge sur ce système de fichiers. |
|
ERROR_PACKAGE_MOVE_ BLOQUÉ_PAR_STREAMING |
0x80073D14 | L’opération de déplacement de package est bloquée jusqu’à ce que l’application ait terminé la diffusion en continu. |
|
ERROR_INSTALL_OPTIONAL_ PACKAGE_APPLICATIONID_ NOT_UNIQUE |
0x80073D15 | Un package d’application principal ou un autre package d’application facultatif a le même ID d’application que ce package facultatif. Modifiez l’ID d’application du package facultatif pour éviter les conflits. |
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ERROR_PACKAGE_STAGING_ ONHOLD |
0x80073D16 | Cette session intermédiaire a été tenue pour permettre à une autre opération intermédiaire d’être hiérarchisée. |
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ERROR_INSTALL_INVALID_ RELATED_SET_UPDATE |
0x80073D17 | Un ensemble associé ne peut pas être mis à jour, car l'ensemble mis à jour n'est pas valide. Tous les packages de l’ensemble associé doivent être mis à jour en même temps. |
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ERROR_INSTALL_OPTIONAL_ PACKAGE_REQUIRES_MAIN_ PACKAGE_FULLTRUST_CAPABILITY |
0x80073D18 | Un package facultatif avec un point d’entrée FullTrust nécessite que le package principal dispose de la fonctionnalité runFullTrust . |
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ERROR_DEPLOYMENT_BLOCKED_ BY_USER_LOG_OFF |
0x80073D19 | Une erreur s’est produite parce qu’un utilisateur a été déconnecté. |
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ERROR_PROVISION_OPTIONAL_ PACKAGE_REQUIRES_MAIN_ PACKAGE_PROVISIONED |
0x80073D1A | Une provision de package facultative nécessite que le package principal de dépendance soit également provisionné. |
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ERROR_PACKAGES_REPUTATION_ CHECK_FAILED |
0x80073D1B | Les paquets ont échoué au contrôle de réputation SmartScreen. |
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ERROR_PACKAGES_REPUTATION_ CHECK_TIMEDOUT |
0x80073D1C | L’opération de vérification de la réputation SmartScreen a expiré. |
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ERROR_DEPLOYMENT_OPTION_ NOT_SUPPORTED |
0x80073D1D | L’option de déploiement actuelle n’est pas prise en charge. |
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ERROR_APPINSTALLER_ ACTIVATION_BLOQUÉE |
0x80073D1E | L’activation est bloquée en raison des paramètres de mise à jour de .appinstaller pour cette application. |
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ERROR_REGISTRATION_FROM_ REMOTE_DRIVE_NON_SUPPORTE |
0x80073D1F | Les lecteurs distants ne sont pas pris en charge. Utilisez \server\share pour inscrire un package distant. |
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ERROR_APPX_RAW_ DATA_WRITE_FAILED |
0x80073D20 | Échec du traitement et de l’écriture des données de package téléchargées sur le disque. |
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ERROR_DEPLOYMENT_BLOCKED_ PAQUET_DE_POLITIQUE_PAR_VOLUME |
0x80073D21 | L’opération de déploiement a été bloquée en raison d’une politique par paquet-famille limitant les déploiements sur un volume non système. Par stratégie, cette application doit être installée sur le lecteur système, mais elle n’est pas définie comme valeur par défaut. Dans les paramètres de stockage, faites du lecteur système l’emplacement par défaut pour enregistrer le nouveau contenu, puis réessayez l’installation. |
|
ERROR_DEPLOYMENT_BLOCKED_ BY_VOLUME_POLICY_MACHINE |
0x80073D22 | L’opération de déploiement a été bloquée en raison d’une stratégie à l’échelle de l’ordinateur limitant les déploiements sur un volume non système. Par stratégie, cette application doit être installée sur le lecteur système, mais elle n’est pas définie comme valeur par défaut. Dans les paramètres de stockage, faites du lecteur système l’emplacement par défaut pour enregistrer le nouveau contenu, puis réessayez l’installation. |
|
ERREUR_DÉPLOIEMENT_BLOQUÉ_ PAR_POLITIQUE_DE_PROFIL |
0x80073D23 | L’opération de déploiement a été bloquée, car le déploiement de profil spécial n’est pas autorisé (les profils spéciaux sont des profils utilisateur où les modifications sont ignorées après la déconnexion de l’utilisateur). Essayez de vous connecter à un compte qui n’est pas un profil spécial. Vous pouvez essayer de vous déconnecter et de vous reconnecter au compte actuel, ou essayer de vous connecter à un autre compte. |
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ERROR_DEPLOYMENT_FAILED_ CONFLICTING_MUTABLE_PACKAGE_ RÉPERTOIRE |
0x80073D24 | L’opération de déploiement a échoué en raison d’un répertoire mutable de paquet d’un paquet en conflit. Pour installer ce package, supprimez le package existant avec le répertoire de package mutable en conflit. |
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ERROR_SINGLETON_RESOURCE_ INSTALLÉ_DANS_UTILISATEUR_ACTIF |
0x80073D25 | L’installation du package a échoué, car une ressource singleton a été spécifiée et un autre utilisateur avec ce package installé est connecté. Vérifiez que tous les utilisateurs actifs avec le package installé sont déconnectés et réessayez l’installation. |
| Erreur_Version_Différente_ OF_PACKAGED_SERVICE_INSTALLED |
0x80073D26 | L’installation du package a échoué, car une autre version du service est installée. Essayez d’installer une version plus récente du package. |
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ERROR_SERVICE_EXISTS_ SERVICE_NON_EMBALLÉ |
0x80073D27 | L’installation du package a échoué, car une version du service existe en dehors d’un package .msix/.appx. Contactez votre fournisseur de logiciels. |
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ERROR_PACKAGED_SERVICE_ NÉCESSITE_DES_PRIVILÈGES_ADMINISTRATEUR |
0x80073D28 | L’installation du package a échoué, car les privilèges d’administrateur sont requis. Contactez un administrateur pour installer ce package. |
|
ERROR_REDIRECTION_TO_ COMPTE_PAR_DÉFAUT_NON_AUTORISÉ |
0x80073D29 | Le déploiement du package a échoué, car l’opération aurait été redirigée vers le compte par défaut, lorsque l’appelant a dit ne pas le faire. |
|
ERROR_PACKAGE_LACKS_ capacité à déployer sur l'hôte |
0x80073D2A | Échec du déploiement du package, car le package nécessite une fonctionnalité pour cibler cet hôte en mode natif. |
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ERROR_UNSIGNED_PACKAGE_ INVALID_CONTENT |
0x80073D2B | Échec du déploiement du package, car son contenu n’est pas valide pour un package non signé. |
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ERREUR_COLIS_NON_SIGNÉ_ INVALID_PUBLISHER_NAMESPACE |
0x80073D2C | Échec du déploiement du package, car son éditeur n’est pas dans l’espace de noms non signé. |
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ERROR_SIGNED_PACKAGE_ INVALID_PUBLISHER_NAMESPACE |
0x80073D2D | Échec du déploiement du package, car son éditeur n’est pas dans l’espace de noms signé. |
|
ERROR_PACKAGE_EXTERNAL_ LOCALISATION_NON_AUTORISÉE |
0x80073D2E | Échec du déploiement du package, car son éditeur n’est pas dans l’espace de noms signé. |
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ERROR_INSTALL_FULLTRUST_ HOSTRUNTIME_REQUIRES_MAIN_ PACKAGE_FULLTRUST_CAPABILITY |
0x80073D2F | Une dépendance d'exécution de l'hôte résolue par un package avec un contenu à pleine confiance requiert que le package principal possède la fonctionnalité runFullTrust. |
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ERROR_INSTALL_DRIVE_ NOT_FOUND |
0x80073D3F | Impossible de trouver le lecteur référencé pendant le déploiement du package. Si vous avez précédemment défini des applications à installer sur un lecteur externe ou secondaire, assurez-vous qu’elle est connectée et accessible. Vous pouvez modifier l’emplacement d’installation par défaut dans Paramètres>Système>Stockage>Modifier l'emplacement où le nouveau contenu est enregistré. |
| APPX_E_PACKAGING_INTERNAL | 0x80080200 | L’API d’empaquetage a rencontré une erreur interne. |
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APPX_E_INTERLEAVING_ NON_AUTORISÉ |
0x80080201 | Le package n’est pas valide, car son contenu est entrelacé. |
|
APPX_E_RELATIONSHIPS_ NON_AUTORISÉ |
0x80080202 | Le package n’est pas valide, car il contient des relations OPC. |
|
APPX_E_MISSING_ REQUIRED_FILE |
0x80080203 | Le package n’est pas valide, car il manque un manifeste ou un mappage de blocs, ou un fichier d’intégrité du code est présent, mais un fichier de signature est manquant. Vérifiez que le package ne manque pas un ou plusieurs de ces fichiers requis :
|
| APPX_E_INVALID_MANIFEST | 0x80080204 | Le fichier AppxManifest.xml du package n’est pas valide. |
| APPX_E_INVALID_BLOCKMAP | 0x80080205 | Le fichier AppxBlockMap.xml du package n’est pas valide. |
| APPX_E_CORRUPT_CONTENT | 0x80080206 | Le contenu du package ne peut pas être lu, car il est endommagé. |
|
APPX_E_BLOCK_ HASH_INVALID |
0x80080207 | La valeur de hachage calculée du bloc ne correspond pas à la valeur de hachage stockée dans la carte de blocs. |
|
APPX_E_REQUESTED_ RANGE_TOO_LARGE |
0x80080208 | La plage d’octets demandée est supérieure à 4 Go lorsqu'elle est convertie en une plage de blocs. |
| TRUST_E_NOSIGNATURE | 0x800B0100 | Aucune signature n’est présente dans le sujet. Vous pouvez obtenir cette erreur si le package n’est pas signé ou si la signature n’est pas valide. Le package doit être signé pour être déployé. |
| CERT_E_UNTRUSTEDROOT | 0x800B0109 | Une chaîne de certificats a été traitée, mais s'est terminée dans un certificat racine qui n’est pas approuvé par le fournisseur de confiance. Consultez Signature d’un package. |
| CERT_E_CHAINING | 0x800B010A | Impossible de créer une chaîne de certificats auprès d’une autorité de certification racine approuvée. Voir Signature d'un paquet. |
|
APPX_E_INVALID_ SIP_CLIENT_DATA |
0x80080209 | La structure SIP_SUBJECTINFOutilisée pour signer le package ne contenait pas les données requises |
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APPX_E_INVALID_ KEY_INFO |
0x8008020A | La structure APPX_KEY_INFO utilisée pour chiffrer ou déchiffrer le package contient des données non valides. |
|
APPX_E_INVALID_ CONTENTGROUPMAP |
0x8008020B | Le mappage de groupe de contenu du package .msix/.appx n’est pas valide. |
|
APPX_E_INVALID_ APPINSTALLER |
0x8008020C | Le fichier .appinstaller pour le package n’est pas valide. |
|
APPX_E_DELTA_BASELINE_ INCOMPATIBILITÉ_DE_VERSION |
0x8008020D | La version du package de référence dans le package delta ne correspond pas à la version du package de référence à mettre à jour. |
|
APPX_E_DELTA_PACKAGE_ FICHIER_MANQUANT |
0x8008020E | Le package delta est manquant dans un fichier du package mis à jour. |
|
APPX_E_INVALID_ DELTA_PACKAGE |
0x8008020F | Le package delta n’est pas valide. |
|
APPX_E_DELTA_APPENDED_ PACKAGE_NOT_ALLOWED |
0x80080210 | Le paquet delta ajouté n’est pas autorisé pour l’opération actuelle. |
|
APPX_E_INVALID_ PACKAGING_LAYOUT |
0x80080211 | Le fichier de disposition d’empaquetage n’est pas valide. |
|
APPX_E_INVALID_ PACKAGESIGNCONFIG |
0x80080212 | Le fichier packageSignConfig n’est pas valide. |
|
APPX_E_RESOURCESPRI_ NON_AUTORISÉ |
0x80080213 | Le fichier resources.pri n’est pas autorisé lorsqu’il n’existe aucun élément de ressource dans le manifeste du package. |
|
APPX_E_FILE_ COMPRESSION_MISMATCH |
0x80080214 | L’état de compression du fichier dans la ligne de base et le package mis à jour ne correspond pas. |
|
APPX_E_INVALID_ PAYLOAD_PACKAGE_EXTENSION |
0x80080215 | Les extensions non .appx ne sont pas autorisées pour les packages de charge utile ciblant des plateformes plus anciennes. |
|
APPX_E_INVALID_ ENCRYPTION_EXCLUSION_FILE_LIST |
0x80080216 | Le fichier encryptionExclusionFileList n’est pas valide. |
Les applications ne démarrent pas et leurs noms sont grisés
Sur un ordinateur exécutant Windows 10 ou version ultérieure, vous ne pouvez pas démarrer certaines applications, et les noms des applications apparaissent grisés.
Lorsque vous essayez d’ouvrir une application en sélectionnant le nom grisé, vous pouvez recevoir l’un des messages d’erreur suivants :
Il y a un problème avec <nom de l'application>. Contactez votre administrateur système pour la réparer ou la réinstaller
Erreur : cette application ne peut pas s’ouvrir
En outre, les entrées d’événement suivantes sont consignées dans le journal « Microsoft-Windows-TWinUI/Operational » sous Applications et services\Microsoft\Windows\Apps :
Nom du journal : Microsoft-Windows-TWinUI/Opérationnel
Source : Microsoft-Windows-Immersive-Shell
Date : <date>
ID d’événement : 5960
Catégorie de tâche : (5960)
Niveau : Erreur
Mots-clés:
Description :
Activation de l’application Microsoft.BingNews_8wekyb3d8bbwe!AppexNews pour Windows. Le contrat de lancement a été bloqué avec une erreur 0x80073CFC, car son paquet est dans l'état : Modifié.
Cause
Ce problème se produit parce que l’entrée de Registre pour la valeur d’état du package correspondant de l’application a été modifiée.
Résolution
Avertissement
Des problèmes sérieux pourraient survenir si vous modifiez le registre de manière incorrecte en utilisant l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent nécessiter la réinstallation du système d’exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l’ensemble des risques liés à la modification du Registre.
Pour résoudre ce problème :
- Démarrez l’Éditeur du Registre, puis recherchez la sous-clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModel\StateChange\PackageList.
- Pour sauvegarder les données de sous-clé, cliquez avec le bouton droit sur PackageList, sélectionnez Exporter, puis enregistrez les données sous forme de fichier de Registre.
- Pour chacune des applications répertoriées dans les entrées du journal ID d’événement 5960, procédez comme suit :
- Recherchez l’entrée PackageStatus .
- Définissez la valeur de PackageStatus sur zéro (0).
Note
S’il n’y a pas d’entrées pour l’application sous PackageList, le problème a une autre cause. Dans le cas de l’exemple d’événement de cet article, la sous-clé complète est HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModel\StateChange\PackageList\Microsoft.BingNews_8wekyb3d8bbwe!AppexNews\PackageStatus
- Redémarrez l'ordinateur.
Obtenez de l’aide supplémentaire
Si vous avez besoin d’aide supplémentaire pour résoudre un problème que vous rencontrez lors de l’empaquetage, du déploiement ou de l’interrogation d’un package d’application Windows (.msix/.appx) en tant que développeur, reportez-vous à ces ressources supplémentaires de support pour les développeurs.
Microsoft Q& A offre des réponses pertinentes et opportunes à vos problèmes techniques d’une communauté d’experts et d’ingénieurs Microsoft.- Pour obtenir de l’aide communautaire aux questions de développement, il existe nos forums et StackOverflow.
- Le site support pour les développeurs Windows explique d'autres options d'assistance.