Troubleshoot the "PublicIPCountLimitReached" error code
This article explains how to identify and resolve the "PublicIPCountLimitReached" error. This error occurs when you try to create, update, or upgrade an Azure Kubernetes Service (AKS) cluster. This error can also be caused by any other action that triggers the creation of a Public IP address, such as deploying a Kubernetes Service-type Public Load Balancer.
Symptoms
An AKS cluster creation, update, upgrade, or other operation that triggers the creation of a Public IP address, such as deploying a Kubernetes Service that has a Public Load Balancer, fails and returns a "PublicIPCountLimitReached" error message.
Cause
This error occurs if you've reached the maximum number of public IP addresses that are allowed for your subscription. The limit varies based on your subscription type. For more information about public IP address limits, refer to this detailed guide.
Solution
To increase the public IP limit or quota for your subscription, follow these steps:
Navigate to the Azure portal, and select the subscriptions for which you're performing the operation.
In the Settings section, select Usage + quotas. Set the Provider to Networking, and optionally filter by the region of your AKS cluster.
Locate the Public IP Addresses record. On the same line, select the Create a new support request button.
On the New support request page, specify the new limit that you require, and then follow the instructions to create the support request.
After the quota change takes effect, retry the operation that initially triggered the "PublicIPCountLimitReached" error.
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.