"Actualizar todo" no funciona después de exportar datos de la aplicación a una hoja de cálculo dinámica
Síntomas
Use el comando Exportar a Excel para exportar datos de la aplicación a una hoja de cálculo dinámica. A continuación, abra el archivo descargado y actualice los datos seleccionandoActualizar todos los datos>. En esta situación, verá que los datos desaparecen y el libro aparece en blanco. Es posible que reciba el siguiente mensaje de error:
Esta consulta web no devolvió datos. Para cambiar la consulta, haga clic en Aceptar, haga clic en la flecha del cuadro nombre de la barra de fórmulas, haga clic en el nombre del intervalo de datos externo de la consulta web, haga clic con el botón derecho en la selección y, a continuación, haga clic en Editar consulta.
Causa
Este problema se produce cuando los datos a los que tiene acceso están protegidos con contraseña y el archivo de Excel no puede enviar contraseñas a orígenes de datos externos.
Solución
Para resolver este problema, debe editar y guardar la consulta web.
En el archivo de Excel, seleccione Consultas de datos>& Connections.
El panel Consultas & Connections se abre a la derecha de la ventana. En la pestaña Connections, haga clic con el botón derecho en la consulta y, a continuación, seleccione Propiedades.
Se abre la ventana Propiedades de conexión . En la pestaña Definición , seleccione Editar consulta.
Si se le solicita, escriba el nombre de usuario y la contraseña. Escriba el mismo usuario y contraseña que usa para iniciar sesión en la aplicación.
En la ventana Editar consulta web , seleccione Ir. Se produce un mensaje de error:
No se puede completar esta acción
Cierre la ventana Editar consulta web .
Esto debería corregir el problema. Vuelva a actualizar los datos de la hoja de cálculo; para ello, seleccioneActualizar todos los datos>.
Si los pasos anteriores no resuelven el problema, siga estos pasos adicionales:
Escriba el siguiente vínculo en la barra de direcciones de la ventana Editar consulta web para acceder a la página Configuración avanzada de Microsoft Dynamics 365 Customer Engagement. No olvide reemplazar por
OrgURL
la dirección URL de la organización.https://OrgURL/main.aspx?settingsonly=true
Cierre la sesión con el vínculo de opción de perfil de la parte superior derecha y vuelva a iniciar sesión con la identidad correcta.
Una vez que haya iniciado sesión, cierre la ventana Editar consulta web y, después, en el archivo de Excel, seleccione Actualizar datos>todo. Los datos se actualizarán según lo previsto.
Vea también
Exportación de datos a una hoja de cálculo dinámica de Excel