Il proprietario non può creare cartelle pubbliche moderne usando Outlook in Exchange Server 2013 o Exchange Server 2016

Sintomi

Si supponga di essere il proprietario di una cassetta postale di cartelle pubbliche o di avere autorizzazioni di accesso sufficienti per creare una cartella pubblica in un ambiente Microsoft Exchange Server 2013 o Microsoft Exchange Server 2016. La cassetta postale usa la gerarchia secondaria come cassetta postale delle cartelle pubbliche predefinita. In questo caso, quando si tenta di creare una cartella pubblica usando Microsoft Outlook, viene visualizzato il messaggio di errore seguente:

Impossibile creare la cartella. Non si dispone di autorizzazioni sufficienti per eseguire questa operazione su questo oggetto. Vedere il contatto della cartella o l'amministratore di sistema.

Nota

Se la cassetta postale delle cartelle pubbliche predefinita viene modificata in una cassetta postale di cartelle pubbliche che contiene la gerarchia primaria, è possibile creare cartelle pubbliche usando Outlook.

Vedere Altre informazioni su come risolvere il problema in questo articolo.

Causa

Questo problema si verifica perché la LmCompatibilityLevel voce del Registro di sistema nel ruolo server cassette postali Exchange Server è configurata su un valore minore di 2.

Soluzione alternativa

Importante

Seguire attentamente i passaggi in questa sezione. L'errata modifica del Registro di sistema può causare seri problemi. Prima di apportare le modifiche, eseguire il backup del Registro di sistema per il ripristino nel caso si verifichino dei problemi.

Per risolvere questo problema, seguire questa procedura nel ruolo server cassette postali Exchange Server che ospita la cassetta postale della cartella pubblica della gerarchia secondaria:

  1. Modificare il valore della voce del LmCompatibilityLevel Registro di sistema su 2 o superiore.

    Nota

    La voce si trova nel percorso del Registro di sistema seguente:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  2. Riavviare i servizi seguenti:

    • Archivio informazioni di Microsoft Exchange
    • Accesso client RPC di Microsoft Exchange
    • Microsoft Exchange Health Manager

Ulteriori informazioni

Per altre informazioni sull'impostazione LmCompatibilityLevel, vedere gli articoli seguenti:

Informazioni generali sulla voce del Registro di sistema LmCompatibilityLevel

Controllo di sicurezza: l'impostazione di Sicurezza di Windows più fraintesa di tutti i tempi

Altre informazioni per risolvere questo problema

Quando si verifica questo problema, oltre al messaggio di errore, è anche possibile trovare le informazioni seguenti che consentono di risolvere il problema.

  • Il messaggio seguente viene registrato nel log "Accesso client RPC" in Visualizzatore eventi:

    Client=MSExchangeRPC,,,,-2147024891 (rop::AccessDenied),00:00:00.0310000,,"RopHandler:
    CreateFolder: [AccessDeniedException] Cannot open mailbox /o=Contoso/ou=Exchange Administrative Group
    (FYDIBOHF23SPDLT)/cn=Recipients/cn=9f049c7972fb4d8ebe9f5ece73e136fe-PFHierarchy. ->
    [MapiExceptionNoAccess] Unable to make connection to the server. (hr=0x80070005, ec=-2147024891)
    [diag::AAAGAgAA/wAAAAAAAAAAA/gBAACYMvAvAQAAACwQAsAAAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AEsEALAmCnwHw0AAACYOfAfLBACwJgl8B95BQAAmDXwHwAAAACYLfAfAAAAAOjyABBwORaQmD/wLwUAAABuL2EAcDkWkJgh8B/0NQAAmDHwL3A5FpAJNNABkQEAAJgp8B8NAAAAmDnwH5EBAACYJfAfiQUAAJg18B8AAAAAmC3wHwEAAACYIvA/AAAAAFVuYXV0aG9yaXplZAAAAADo8gAQcDkWkJg/8C8FAAAAbi9hAHA5FpCYIfAf9DUAAJgx8C9wORaQCTTQAQAAAACYKfAfDQAAAJg58B8AAAAAmCXwH+ELAACYNfAfAAAAAJgt8B8AAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AHhCwAAmCnwHw0AAACYOfAfAAAAAJgl8B/hCwAAmDXwHwAAAACYLfAfAAAAAHHoQBAFAAeAcMVAIQAPFIQZAPAvBQAAAHDLQBAFAAeA0McAEPQ1AADxzEAQBQAHgKHqABAFAAAA8YNAEAUAB4Cd6QAQBQAAAAfNQBAFAAeAQk0AEAAAAABCbUAQBQAHgEJFABAAAAAAQmVAEAUAB4A=] 
    at M.E.D.S.RPCPrimaryHierarchyProvider.GetHierarchyStore() 
    at M.E.D.S.RPCPrimaryHierarchyProvider.CreateFolder(String folderName, String folderDescription, StoreId parentFolderId, CreateMode mode, Guid& contentMailboxGuid) 
     at M.E.R.H.PublicFolderOperations.<>c__DisplayClass1.<CreateFolder>b__0(StoreId& folderIdToSync, Guid& contentMailboxGuid) 
    at M.E.R.H.PublicFolderOperations.InvokeOnPrimaryHierarchyAndSync[T](Boolean isCompleteSync, PublicLogon publicLogon, PrimaryHierarchy",,,admin@contoso.com,
    
  • Se si esegue il comando Get-ServerHealth -Identity ServerIdParameter -HealthSet 'Outlook.Protocol' in Exchange Management Shell (EMS), il set di integrità di Outlook.Protocol segnala unhealthy, in particolare per i monitoraggi seguenti correlati alla chiamata di routine remota di Outlook RPC:

    • OutlookRpcDeepTestMonitor
    • OutlookRpcSelfTestMonitor
  • L'errore del probe OutlookRpcDeepTestProbe registra il messaggio seguente:

    Microsoft.Exchange.Rpc.RpcException: Error 0x5 (Access is denied) from ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall