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Email Server Error Code Crm.80042f09.UserNotAssignedRoles dopo aver selezionato Test & Abilita cassetta postale in un record della cassetta postale

Questo articolo fornisce una risoluzione per il codice di errore Crm.80042f09.UserNotAssignedRoles che si verifica dopo aver selezionato il pulsante Test & Abilita cassetta postale in un record cassetta postale in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics CRM
Numero KB originale: 4014646

Sintomi

Quando si seleziona il pulsante Test & Abilita cassetta postale in un record della cassetta postale in Microsoft Dynamics 365, viene registrato l'avviso seguente e la sincronizzazione di appuntamenti, contatti e attività non riesce:

Gli appuntamenti, i contatti e le attività non possono essere sincronizzati per il nome> della cassetta postale <perché l'utente della cassetta postale non dispone di autorizzazioni sufficienti per questa cassetta postale.
codice di errore del server Email: Crm.80042f09.UserNotAssignedRoles

Se si sceglie di visualizzare i dettagli, vengono visualizzati i dettagli aggiuntivi seguenti:

T:1738ActivityId: <ID>>Exception : Unhandled Exception: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: Failed to retrieve the sync state : Unhandled Exception: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]: SecLib::RetrievePrivilegeForUser failed - nessun ruolo viene assegnato all'utente. Restituito hr = -2147209463, User: <GUID> Detail: <ID> -2147209463 SecLib::RetrievePrivilegeForUser failed - nessun ruolo viene assegnato all'utente. Hr restituito = -2147209463, Utente: <GUID>...

Causa

Un ruolo di sicurezza di Microsoft Dynamics 365 non è assegnato all'utente.

Risoluzione

Assegnare un ruolo di sicurezza microsoft Dynamics 365 all'utente. Per istruzioni dettagliate su come assegnare un ruolo di sicurezza, vedere Creare utenti e assegnare ruoli di sicurezza.