I messaggi di posta elettronica non vengono sincronizzati perché l'indirizzo di posta elettronica è configurato per un altro errore dell'organizzazione

Questo articolo fornisce una risoluzione per l'errore elencato in questo articolo quando si prova a testare e abilitare una cassetta postale in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics CRM
Numero KB originale: 4053618

Sintomi

Quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365, viene registrato uno degli avvisi seguenti:

I messaggi di posta elettronica in arrivo non vengono sincronizzati perché l'indirizzo di posta elettronica per la <cassetta postale Nome> cassetta postale è configurato per un'altra organizzazione Dynamics 365. Chiedere all'amministratore di testare e abilitare la cassetta postale per l'organizzazione corrente e di modificare il metodo di sincronizzazione per le organizzazioni non primarie in Nessuna.
codice di errore del server Email: IncomingIncorrectCrmOrgError

I messaggi di posta in uscita non vengono inviati perché l'indirizzo di posta elettronica dell'indirizzo <> di posta elettronica è configurato per un'altra organizzazione Dynamics 365. Chiedere all'amministratore di testare e abilitare la cassetta postale per l'organizzazione corrente e modificare il metodo di sincronizzazione per le organizzazioni non primati in Nessuna.
codice di errore del server Email: OutgoingIncorrectCrmOrgError

Gli appuntamenti, i contatti e le attività non possono essere sincronizzati perché l'indirizzo di posta elettronica della cassetta postale Nome> cassetta postale <è configurato con un'altra organizzazione di Microsoft Dynamics 365. La procedura consigliata consiste nel sovrascrivere la configurazione quando si testa e si abilita la cassetta postale nell'organizzazione primaria. Modificare anche il metodo di sincronizzazione per la cassetta postale nelle organizzazioni non primarie in Nessuno.
codice di errore del server Email: ExchangeSyncIncorrectCrmOrgError

Se si seleziona Visualizza dettagli nell'avviso, è possibile che vengano visualizzati anche i dettagli seguenti:

Eccezione: il controllo e l'aggiornamento della cartella di configurazione in Exchange non sono riusciti.

Causa

Una cassetta postale di Exchange può essere configurata solo per l'uso della sincronizzazione Server-Side con un'organizzazione di Microsoft Dynamics 365. Questi avvisi vengono registrati se sono presenti più organizzazioni microsoft Dynamics 365 e si tenta di configurare la cassetta postale per l'uso della sincronizzazione Server-Side con più organizzazioni.

Risoluzione

Testare e abilitare la cassetta postale nell'organizzazione principale di Microsoft Dynamics 365

  1. Accedere all'organizzazione microsoft Dynamics 365 che si vuole configurare per l'uso Server-Side Sincronizzazione con la cassetta postale di Exchange.

  2. Passare a Impostazioni e quindi selezionare Email Configurazione.

  3. Selezionare Cassette postali.

  4. Modificare la visualizzazione selezionata da Cassette postali attive personali a Cassette postali attive.

  5. Selezionare le cassette postali da abilitare per la sincronizzazione Server-Side e quindi selezionare il pulsante Test & Abilita cassette postali .

    Importante

    Assicurarsi di selezionare la casella di controllo nella finestra di dialogo visualizzata e quindi selezionare OK. Se la cassetta postale di Exchange è stata configurata in precedenza con un'altra organizzazione di Microsoft Dynamics 365, selezionando questa casella di controllo verrà aggiornata la cassetta postale di Exchange per la sincronizzazione con l'organizzazione microsoft Dynamics 365. Se non si seleziona questa casella di controllo e la cassetta postale di Exchange è già configurata con un'altra organizzazione di Microsoft Dynamics 365, i test avranno esito negativo e registreranno uno degli avvisi elencati nella sezione Sintomo di questo articolo.

  6. Attendere il completamento del processo Test & Enable. Se i risultati del test non sono riusciti, esaminare l'area Avvisi all'interno del record della cassetta postale.

Modificare il metodo di sincronizzazione per le organizzazioni Microsoft Dynamics 365 non primarie in Nessuno

Se si dispone di più di un'organizzazione microsoft Dynamics 365, configurare la cassetta postale dell'utente nelle organizzazioni non primarie in modo che sia impostata su Nessuno per il metodo di sincronizzazione. Ad esempio: se si dispone di un'organizzazione microsoft Dynamics 365 usata per la produzione e di un'altra usata per i test, è possibile abilitare un utente per l'uso della sincronizzazione Server-Side in una delle organizzazioni, ma non in entrambe.

  1. Accedere all'organizzazione Microsoft Dynamics 365 non primaria come utente con il ruolo Amministratore di sistema.
  2. Passare a Impostazioni e quindi selezionare Email Configurazione.
  3. Selezionare Cassette postali.
  4. Modificare la visualizzazione selezionata da Cassette postali attive personali a Cassette postali attive.
  5. Aprire la cassetta postale da disabilitare per la sincronizzazione Server-Side.
  6. Modificare le opzioni del metodo di sincronizzazione in Nessuno e quindi selezionare Salva & Chiudi.