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Una soluzione importata in una versione precedente (ad esempio, in Dynamics CRM) non viene completata durante la disinstallazione/aggiornamento con un messaggio di errore simile a «Role» con ID [RoleID] è richiesto dalla soluzione [SolutionName]. Questo articolo fornisce una risoluzione per questo problema.
Si applica a: Microsoft Dynamics CRM
Numero KB originale: 4025516
Sintomi
Prima di un aggiornamento all'aggiornamento di dicembre 2016 per Microsoft Dynamics 365, viene installata una soluzione contenente un ruolo personalizzato. Dopo l'aggiornamento dell'organizzazione, la soluzione non può più essere disinstallata/aggiornata a causa di una dipendenza tra il ruolo e un'altra soluzione, in genere la soluzione di sistema. Questo problema non è stato introdotto o causato dall'utente.
Causa
In Microsoft Dynamics 365, i processi aziendali (BPF) sono rappresentati da entità di prima classe che rispettano il modello di sicurezza di Microsoft Dynamics 365 esattamente come qualsiasi altra entità. Queste entità vengono generate durante l'aggiornamento di dicembre 2016 a Microsoft Dynamics 365. Per garantire che tutti i ruoli esistenti dispongano dell'accesso appropriato ai bpf, i privilegi BPF vengono assegnati automaticamente ai ruoli esistenti durante l'aggiornamento. In alcuni casi, queste assegnazioni di privilegi possono comportare dipendenze non corrette tra le soluzioni.
Risoluzione
In Microsoft Dynamics 365, passare a Impostazioni>Sicurezza>Ruoli di sicurezza. Selezionare quindi il ruolo di sicurezza visualizzato nell'errore e aprire la scheda Processi aziendali .
Prendere nota dei privilegi assegnati per i BPF. Uno screenshot è utile, poiché è una rappresentazione visiva.
Cancellare tutti i privilegi e quindi salvare le modifiche. In questo modo è necessario rimuovere le dipendenze problematiche.
Annotazioni
Potrebbe non essere possibile modificare i privilegi se il ruolo fa parte di una soluzione ed è contrassegnato come non personalizzabile. Se la soluzione non è gestita, è possibile aggiornarela proprietà gestita personalizzabile del ruolo e procedere. In caso di soluzione gestita, contattare supporto tecnico Microsoft per personalizzare il ruolo.
Riassegnare i privilegi assegnati in precedenza e quindi salvare e chiudere la finestra di dialogo. In questo modo si garantisce che venga mantenuto l'accesso necessario a ruoli diversi.
Potrebbero esserci dipendenze tra più ruoli e soluzioni. In questo caso, eseguire i passaggi precedenti per ognuno dei ruoli segnalati con problemi.