La chiave specificata non era presente nell'errore del dizionario si verifica quando si tiene traccia di un messaggio di posta elettronica in Microsoft Dynamics 365 per Outlook

Questo articolo fornisce una soluzione a un errore che si verifica quando si tiene traccia di un messaggio di posta elettronica in Microsoft Dynamics 365 per Outlook.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4010462

Sintomi

Quando si tenta di tenere traccia di un messaggio di posta elettronica in Dynamics 365 per Outlook, viene visualizzato l'errore seguente:

"La chiave specificata non era presente nel dizionario."

Se si selezionano i dettagli, vengono visualizzati gli altri dettagli seguenti:

"La chiave specificata non era presente nel dizionario.
at System.Collections.Generic.Dictionary2.get_item(Tkey key)
in Microsoft.Crm.AppIication.SMWrappers.AttachmentForOutIook.Get... clientOrganizationContext, IDynamicEntityCoIIectionForOutIook dynamicEntityCoIEctionAttachments)
atMicrosoft.Crm.AppIicationSMWrappers.EmaiIForOutIook.Microsoft.... messageld, String subject, String from, String to, String cc, String bcc, Double receivedon, String submitted8y, String importance, String body, IDynamicEntityCoIIectionForOutIook attachments, Int32 attachmentCount, IDynamicEntityForOutIook extraProperties, String entityXmI, String regardingld, Int64 regardingObjectType, String crmld, Int32& notification)"

Causa

Questo errore può verificarsi per una delle condizioni seguenti:

  1. Il messaggio di posta elettronica include un allegato più grande delle dimensioni consentite in Dynamics 365.
  2. Il messaggio di posta elettronica include un allegato con un'estensione di file bloccata da Dynamics 365.

Risoluzione

Risoluzione 1
Se il messaggio di posta elettronica include un allegato che supera il limite di dimensioni, rimuovere l'allegato o aumentare le dimensioni degli allegati consentite in Dynamics 365. La dimensione massima predefinita è 5 MB.

Se si ha il ruolo Amministratore di sistema in Dynamics 365, è possibile visualizzare e modificare questa impostazione passando a Impostazioni, Amministrazione e quindi selezionando Impostazioni di sistema. Selezionare la scheda Email e individuare l'impostazione Dimensioni massime file (in kilobyte) nell'intestazione Imposta limite dimensioni file per allegati.

Risoluzione 2
Se il messaggio di posta elettronica include un allegato con un'estensione bloccata da Dynamics 365, rimuovere l'allegato o modificare l'estensione di file bloccata da Dynamics 365.

Se si ha il ruolo Amministratore di sistema in Dynamics 365, è possibile visualizzare e modificare questa impostazione passando a Impostazioni, Amministrazione e quindi selezionando Impostazioni di sistema. Nella scheda Generale individuare l'impostazione Imposta estensioni di file bloccate per gli allegati.