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UnknownIncomingEmailIntegrationError -2147220891 errore di eccezione viene visualizzato all'interno degli avvisi delle cassette postali in Microsoft Dynamics 365

Questo articolo fornisce una soluzione a un errore che si verifica all'interno degli avvisi delle cassette postali in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4466423

Sintomi

Quando si visualizza la sezione avvisi all'interno di un record della cassetta postale in Dynamics 365, viene visualizzato uno dei messaggi seguenti:

  • "Si è verificato un errore sconosciuto durante la ricezione della posta elettronica tramite la cassetta postale "<Nome> cassetta postale". Il proprietario del profilo del server di posta elettronica associato Nome> profilo <è stato informato. Il sistema tenterà di ricevere di nuovo il messaggio di posta elettronica in un secondo momento.

    Email Codice di errore del server: il server exchange ha restituito UnknownIncomingEmailIntegrationError -2147220891 eccezione."

  • "Si è verificato un errore interno di Microsoft Dynamics 365 durante la sincronizzazione di appuntamenti, contatti e attività per la cassetta postale "<Nome> cassetta postale". Il proprietario del profilo del server di posta elettronica associato Nome> profilo <è stato informato. Il sistema proverà di nuovo in un secondo momento.

    Email codice di errore del server: il codice Crm.80040265.ISV ha interrotto l'operazione."

Causa

Il codice di errore 80040265 e -2147220891 indica un errore IsvAborted.

Se viene visualizzato il primo messaggio elencato nella sezione Sintomi , in genere è causato da un flusso di lavoro o da un plug-in personalizzato eseguito durante la creazione di un record di posta elettronica.

Se viene visualizzato il secondo messaggio elencato nella sezione Sintomi , in genere è causato da un flusso di lavoro o da un plug-in personalizzato eseguito durante la creazione di un appuntamento, un contatto o un record di attività.

Risoluzione

Verificare se sono presenti plug-in o flussi di lavoro personalizzati eseguiti in modo sincrono durante la creazione del tipo di record indicato nell'errore (ad esempio, posta elettronica, appuntamento, contatto o attività). Se un plug-in o un flusso di lavoro causa un errore durante la creazione del record, Server-Side La sincronizzazione non può creare correttamente il record. La procedura seguente consente di identificare se sono presenti flussi di lavoro o plug-in nell'organizzazione eseguiti durante la creazione di un messaggio di posta elettronica. Gli stessi passaggi possono essere usati per altre entità, ad esempio appointment, se non è possibile creare il tipo di record:

Flusso di lavoro

  1. Nell'applicazione Web Dynamics 365 passare a Impostazioni e quindi selezionare Processi.

  2. Modificare la visualizzazione in Processi attivati.

  3. Ordinare in base alla colonna Entità primaria e cercare eventuali righe con Email come entità primaria e Flusso di lavoro come categoria.

    È invece possibile usare le opzioni di filtro nella griglia per filtrare in base a Categoria = Flusso di lavoro ed Entità primaria = Email

  4. Aprire ogni flusso di lavoro trovato che soddisfa i criteri precedenti (se presenti).

  5. Se l'opzione Avvia quando è stata creata l'opzione Record è selezionata e l'opzione Esegui questo flusso di lavoro in background (scelta consigliata) non è selezionata, questo flusso di lavoro potrebbe essere potenzialmente la causa.

  6. Selezionare la sezione Sessioni di elaborazione sul lato sinistro della pagina e cercare eventuali errori correlati al messaggio di posta elettronica che non è stato creato correttamente.

Plug-in

  1. Nell'applicazione Web Dynamics 365 passare a Impostazioni, Personalizzazioni e quindi selezionare Personalizza sistema.
  2. Selezionare Passaggi di elaborazione dei messaggi sdk.
  3. Eseguire l'ordinamento sulla colonna Primary Object Type Code (SdkMessage Filter) e cercare eventuali righe per l'entità Email.
  4. Se si trovano righe e la modalità di esecuzione è sincrona, potrebbe interferire con la creazione del messaggio di posta elettronica.

Se il problema viene riprodotto in modo coerente ed è possibile disabilitare temporaneamente il flusso di lavoro o il plug-in come test, può consentire di determinare se il flusso di lavoro o il plug-in è la causa.