I report finanziari di Management Reporter non corrispondono ai report del saldo di valutazione della contabilità generale in Microsoft Dynamics GP

Si applica a: Microsoft Dynamics GP
Numero KB originale: 2910626

Sintomi

È possibile usare molti strumenti di report diversi per preparare i report finanziari usati per bilanciare il rapporto di valutazione gl in Microsoft Dynamics GP. È quindi necessario determinare se i report finanziari vengono letti solo dai dati di tipo GL o se vengono usati anche i dati AA. Se i dati AA vengono usati per preparare i report finanziari, potrebbero essere sfasati se i dati nelle tabelle AA non corrispondono ai dati nelle tabelle gl.

  • Management Reporter con Data Mart leggerà dalle tabelle AA se AA è stato attivato. Questo avviene in base alla progettazione nelle versioni fino a CU9.
  • Management Reporter con provider legacy consente di scegliere se eseguire il pull da una società AA o da una società gl.

Causa

La segnalazione finanziaria potrebbe non essere corretta, se sono stati usati dati AA per assemblare il report e i dati AA non corrispondono ai dati gl. I record potrebbero non essere presenti nelle tabelle AA o possono essere ignorati se differiscono dal record corrispondente in GL.

Esistono diversi motivi per cui i dati AA potrebbero non corrispondere ai dati gl o avere problemi, tra cui:

  • Il modulo Contabilità analitica non è stato installato in tutte le workstation, in cui gli utenti stanno inserendo/registrando transazioni. Pertanto, il record esiste in GL, ma non in AA.
  • Gli utenti disabilitano il modulo Contabilità analitica se hanno ricevuto un errore che fa riferimento a 'aa', quindi le tabelle AA non vengono aggiornate.
  • I record vengono importati direttamente nelle tabelle GL e non nelle tabelle AA. In alternativa, gli utenti disabilitano AA se ricevono errori "aa" durante il processo di importazione.
  • Gli utenti stanno chiudendo l'anno gl su una workstation in cui AA non è stato installato. Di conseguenza, i record AA non vengono spostati nella cronologia e nelle tabelle AA non viene creata alcuna voce del giornale di registrazione saldo anticipato.
  • Management Reporter potrebbe non leggere il record AA se l'ID valuta è diverso tra il record AA e il record corrispondente in GL, il che potrebbe essere causato dall'importazione di record, dall'attivazione della concorrenza multipla o da eventuali problemi di qualità con gli ID valuta che da allora sono stati corretti.
  • Il database Dynamics è stato ripristinato su se stesso, causando il ripristino del 'Numero disponibile successivo' (nella tabella AAG00102) su un valore già usato. Questo sistema incrementerà questo valore per il valore dell'ID intestazione successivo quando inserisce nuovi record nella tabella e quindi può duplicare se viene inserito in un valore ID sentito già usato.
  • Se si esegue l'aggiornamento a Microsoft Dynamics GP 2013 e si imposta un ID valuta funzionale, ma non si è registrati per la concorrenza multipla o non si eseguono i collegamenti di controllo come indicato dopo aver configurato la valuta funzionale.
  • Interruzioni della registrazione

Risoluzione

Se è necessaria assistenza per correggere uno dei risultati restituiti dagli script seguenti, aprire un evento imprevisto di supporto usando le categorie seguenti per raggiungere il team di tecnico del supporto corretto. Includere le informazioni come indicato in ogni passaggio.

  • Per aprire un evento imprevisto di supporto online, usare questo collegamento: https://serviceshub.microsoft.com/supportforbusiness.
  • Usare l'argomento supporto: Financial - Analytical Accounting e il sotto-argomento: Problemi di coerenza dei dati.
  • Per raggiungere il Centro messaggi per aprire un evento imprevisto di supporto, chiamare il numero 1-888-477-7877. E fornire quanti più dettagli possibile.
  • Si noti che l'evento imprevisto del supporto potrebbe richiedere molto tempo, pertanto è necessario attendere molto tempo per collaborare con il tecnico.
  • L'evento imprevisto del supporto sarà addebitabile a meno che l'unica causa non sia determinata da un problema di qualità noto in Microsoft Dynamics GP. Se vengono risolti più problemi, il caso rimarrà addebitabile.
  • L'ambito dell'evento imprevisto del supporto includerà la correzione di tutti i dati restituiti dagli script SQL riportati di seguito, nelle linee guida relative alle operazioni che è possibile eseguire in un caso di supporto regolare. Se è necessaria ulteriore assistenza per trovare la "causa radice", sarà necessario aprire un nuovo evento imprevisto di supporto. Alcune delle cause sono comuni, come illustrato nella sezione Cause precedente. Tuttavia, se ad esempio si determina una differenza di ID valuta nei record importati in Microsoft Dynamics GP, è necessario aprire un nuovo evento imprevisto del supporto per collaborare con il team di supporto di eConnect/Integration Manager. Il tecnico mantiene la discrezione di consigliare quando è necessario un nuovo evento imprevisto di supporto o quando può diventare un coinvolgimento di consulenza.
  • Un caso di supporto può essere aperto inizialmente, con i risultati di tutti gli script dai passaggi da 1 a 10 seguenti. Il tecnico lavorerà con l'utente in UNA società e ci si aspetta di correggere le altre aziende autonomamente, seguendo la stessa procedura del tecnico fornito per la prima azienda. L'assistenza aggiuntiva con più società può richiedere un nuovo caso ed è a discrezione dell'ingegnere.

Procedura

Nota

Per visualizzare i risultati di ogni script in Testo, è possibile premere ALT - T (o selezionare Query nella barra dei menu superiore, scegliere Risultati a e selezionare Risultati in testo) e quindi eseguire di nuovo lo script. Verranno forniti altri dettagli per ogni sezione dei risultati restituiti.

Il file KB_AllAAFindScripts.zip contiene tutti gli script per i passaggi 2,3,4,6 e 9, quindi è necessario scaricarlo una sola volta, ma lo stesso collegamento viene fornito in tutti questi passaggi.

Passaggio 1 - Anni distinti

Eseguire gli script seguenti per verificare che gli anni siano distinti in ogni tabella e non si sovrappongano tra loro e siano coerenti con gli anni nelle tabelle GL. Gli stessi anni devono essere nella AAG30000 della tabella GL20000 e nella tabella AAG40000 con la tabella GL30000. Non è necessario che gli anni si sovrappongano tra le tabelle AA o tra le tabelle gl. Se lo stesso anno è elencato sia nelle tabelle di cronologia che in quelle aperte o non è coerente con gli anni nelle tabelle GL, aprire un caso di supporto per ulteriore assistenza e includere i risultati di tutti gli script.

select distinct(YEAR1) from AAG30000 order by YEAR1
select distinct(YEAR1) from AAG40000 order by YEAR1
select distinct(OPENYEAR) from GL20000 order by OPENYEAR
select distinct(HSTYEAR) from GL30000 order by HSTYEAR

Passaggio 2 - Trovare le discrepanze di ID valuta

Scaricare il file KB_AllAAFindScripts.zip* e usare lo script di AA_FindCurrencyDiscrepancy.sql per il passaggio 2 per identificare le transazioni in cui l'ID valuta non corrisponde tra le tabelle GL e AA sia in apertura che nella cronologia:

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

*Il file ZIP contiene gli script per i passaggi 2, 3, 4, 6 e 9.

  • Se non si usa la concorrenza multipla o si usa solo un ID valuta, è possibile aggiornare i campi CURNCYID e CURRNIDX direttamente nelle tabelle AA (AAG30001/AAG40002) o GL (GL20000/GL30000). Verificare che l'ID valuta corrisponda alle transazioni con chiave di recente per assicurarsi che non si verifichi un problema in corso. Aprire un evento imprevisto di supporto se è necessaria assistenza per aggiornare curncyid direttamente nella tabella SQL o se si è in grado di ricrearlo in una transazione corrente.

  • Se viene usata la concorrenza multipla, aprire un evento imprevisto di supporto e includere quanto segue:

    • Specificare i risultati dello script in formato testo. È necessario sapere quale tabella ha l'ID valuta e quale tabella non l'ha fatto. E sono queste transazioni più vecchie o più recenti? Se le transazioni meno recenti e la gestione della concorrenza multipla sono appena state installate, è stato eseguito il controllo dei collegamenti nel programma di installazione della concorrenza multipla? Controllare i collegamenti dovrebbe tornare indietro e aggiornare l'ID valuta in tutte le transazioni esistenti.

    • Quale versione di Microsoft Dynamics GP viene usata?

    • Da dove provengono le transazioni? Verificare se si tratta di un problema in corso. Verificare se Gestione multi-concorrenza è contrassegnato nella finestra Registrazione (in Microsoft Dynamics GP passare a Registrazionesistema>configurazione>strumenti>).

    • Qual è la valuta funzionale? Quanti ID valuta si usano?

Passaggio 3: Trovare distribuzioni non corrispondenti

Scaricare il file KB_AllAAFindScripts.zip* e usare AA_FindUnmatchedDists.sql script per il passaggio 3 per identificare se i dati dettagliati non corrispondono tra le tabelle AA e GL. Se vengono restituiti risultati, aprire un caso di supporto per ulteriore assistenza. Allegare il file dei risultati in formato testo. Questi record di problemi sono in genere dovuti a problemi di importazione o utenti che lavorano su una workstation in cui AA è stato disabilitato o non installato.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

*Il file ZIP contiene gli script per i passaggi 2, 3, 4, 6 e 9.

Nota

Questo script non deve essere usato per le versioni inferiori a Microsoft Dynamics GP 10.0 SP2 o in cui non è ancora stata completata una chiusura di fine anno gl su una versione superiore a quella (ad esempio, dove i dati AA precedenti a SP2 non sono ancora stati spostati nella cronologia).

tenere presente che i "totali dei risultati" possono essere visualizzati tra le sezioni e sono fuorvianti. Questi totali dei risultati sono un fattore di scrittura dello script e possono essere ignorati. È sufficiente preoccuparsi dei "totali dei risultati" che seguono immediatamente una "sezione" e che hanno restituito i dati effettivi.

Passaggio 4 : Trovare ID di codice AA duplicati

Scaricare il file KB_AllAAFindScripts.zip* e trovare lo script AA_FindDupaaTrxDimCodeID_AAG00401.sql per il passaggio 4 per verificare se gli ID di codice AA sono duplicati (a causa dell'importazione). Se vengono restituiti risultati, aprire un caso di supporto per ulteriore assistenza. Allegare i risultati dello script in formato testo e anche il contenuto della tabella AAG00401. Microsoft può fornire i passaggi per risolvere il caso, ma chiedere a Microsoft di eseguire questa operazione potrebbe essere una spesa di consulenza. Questo problema è causato dall'importazione o dal ripristino di una copia precedente del database Dynamics su se stesso.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

*Il file ZIP contiene gli script per i passaggi 2, 3, 4, 6 e 9.

Passaggio 5 : Trovare ID di intestazione AA duplicati

Eseguire lo script seguente per determinare se sono presenti ID di intestazione duplicati tra le tabelle AA aperte e cronologica. Microsoft può fornire i passaggi per risolvere il caso, ma chiedere a Microsoft di eseguire questa operazione potrebbe essere una spesa di consulenza. Questo problema è causato dall'importazione o dal ripristino di una copia precedente del database Dynamics su se stesso o da un'interruzione della pubblicazione.

select aaGLHdrID from AAG30000 where aaGLHdrId in (select aagLHDrId from AAG40000)

oppure

select a.aaGLHdrID, a.JRNENTRY as OPEN_JE#,a.YEAR1 as 'OPEN_YEAR1',
b.JRNENTRY as 'HIST_JE#', b.YEAR1 as 'HIST_YEAR1' From AAG30000 a (nolock)
join AAG40000 b (nolock) on a.aaGLHdrID = b.aaGLHdrID
where a.JRNENTRY <> b.JRNENTRY

Se vengono restituiti risultati, aprire un caso di supporto e includere le informazioni seguenti:

  • Risultati dello script in formato testo.
  • Cercare i record e consigliare se sono esattamente lo stesso record o se sono record diversi, ma hanno solo lo stesso ID intestazione.

Passaggio 6 : Trovare numeri di sequenza non corrispondenti (per le voci P&L)

Scaricare il file KB_AllAAFindScripts.zip* ed eseguire lo script di AA_FindYEC_RetainedEarnings.sql per cercare i record in cui i numeri di sequenza non corrispondono tra AA e GL tra le tabelle di apertura e di cronologia per la voce del journal degli utili conservati (SOURCDOC ='P&L'). Se vengono restituiti risultati, aprire un caso di supporto e includere i risultati dello script in formato testo. Si noti che se sono stati ottenuti risultati nel passaggio 3 precedente per le sezioni 'GLSEQNMBR', sarà necessario correggerli per primi e quindi eseguire di nuovo questo script per il passaggio 6, quindi non sono necessari i risultati per il passaggio 6 se si hanno risultati nel passaggio 3.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

*Il file ZIP contiene gli script per i passaggi 2, 3, 4, 6 e 9.

Nota

È possibile ottenere risultati con questo script precedente se attualmente sono presenti voci P&L con più righe di distribuzione con lo stesso ACTINDX e i dati sono effettivamente validi. È consigliabile confrontare SEQNUMBR tra il AAG30001 e GL20000 (o AAG40001 e GL30000) per i risultati restituiti e, se il SEQNUMBR corrisponde, è possibile ignorare gli errori di convalida MR per SEQNUMBR e procedere.

Passaggio 7 - Trovare le voci BBF mancanti

Se i report finanziari sono disattivati in base all'importo dei saldi iniziali, le voci BBF (Balance Brought Forward) potrebbero non essere presenti nelle tabelle AA. Eseguire gli script seguenti per determinare se le voci BBF in GL non sono presenti nelle tabelle AA. Ciò è causato dalla chiusura dell'anno GL da parte dell'utente in una workstation in cui AA è stato disabilitato o non installato. Per Microsoft Dynamics GP 2013 SP2 e versioni precedenti, sarà necessario aprire un servizio di consulenza per riaprire l'anno gl. Se si è Microsoft Dynamics GP 2013 R2 o versioni successive, è possibile utilizzare la casella di controllo Anno cronologico inverso nella routine di chiusura di fine anno gl per riaprire l'anno e quindi chiuderlo nuovamente in un computer in cui è installato il codice AA, in modo che le voci del BBF vengano create sia nelle tabelle AA che GL.

PRINT 'OPEN year missing BBF'
Select distinct (JRNENTRY) from GL20000
where JRNENTRY not in (select JRNENTRY from AAG30000)
and SOURCDOC in ('BBF','P/L')
PRINT 'HISTORY year missing BBF'
Select distinct (JRNENTRY) from GL30000
where JRNENTRY not in (select JRNENTRY from AAG40000)
and SOURCDOC in ('BBF','P/L')

Passaggio 8 - Problema noto per i budget AA (solo in Microsoft Dynamics GP 2010 e Microsoft Dynamics GP2013)

In Microsoft Dynamics GP 2013 e Microsoft Dynamics GP 2010 si è verificato un problema di qualità noto (#69354 TFS/69692 PS) in cui il livello superiore dell'albero del budget avrà un valore errato nella tabella AAG00902 (aaLvlCodeString campo) se si procede alla modifica del budget. Management Reporter cerca un valore vuoto in questo campo per identificare il record principale per l'albero del budget e quindi questo valore non corretto causa l'esito negativo dei report mr e non vengono restituiti dati di budget AA. Questo problema è stato risolto in Microsoft Dynamics GP 2013 R2 (12.00.1745). Gli script SQL sono forniti di seguito per l'esecuzione nel database aziendale per cercare questo problema e anche per risolverlo.

Select * from AAG00902 where aaLvlCodeString <> '' and aaLevel = 0

Se lo script precedente restituisce risultati, è possibile risolvere il problema eseguendo questo script nel database aziendale:

update AAG00902 set aaLvlCodeString = '' where aaLevel = 0

Passaggio 9: i totali della somma AAG30002/AAG40002 non corrispondono AAG30001/AAG40001

La somma dei record allocati nelle tabelle AAG30002/AAG40002 deve corrispondere alla somma degli importi nelle tabelle di distribuzione AAG30001/AAG40001 per transazione. Se gli importi vengono allocati a più codici AA, è possibile avere un numero diverso di record tra queste tabelle, ma la parte importante è che corrispondono in "somma" totale per transazione. I report mr non leggono i record se i totali della somma non corrispondono tra queste tabelle per ogni transazione. Scaricare gli script "trova e confronta" per gli anni aperti e cronologici riportati di seguito ed eseguirli nel database aziendale.

Nota

Se sono stati ottenuti risultati nel passaggio 3 precedente per le sezioni "AAG30002/AAG40002", sarà necessario correggerli per primi e quindi eseguire di nuovo lo script per il passaggio 9, quindi non sono necessari i risultati per il passaggio 9 se si hanno risultati nel passaggio 3.

Scaricare il file KB_AllAAFindScripts.zip* dal collegamento seguente e usare la AA_CompareAAG30001AndAAG30002SummaryValues.sql per l'anno AA aperto corrente per il passaggio 9 e lo script AA_CompareAAG40001AndAAG40002SummaryValues.sql per l'anno cronologico per il passaggio 9.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

*Il file ZIP contiene gli script per i passaggi 2, 3, 4, 6 e 9.

Se vengono restituiti risultati da uno script, salvare i risultati in un .rpt file e aprire un caso di supporto per ulteriore assistenza. Allegare i risultati per la revisione.

Passaggio 10 - Addebiti/crediti nella stessa riga di distribuzione

MR non è in grado di leggere i record in cui sia i campi di debito che di credito vengono popolati nella stessa riga di distribuzione. Le cause note possono essere l'"importazione" nei record in tale condizione o l'uso dell'utilità di costo standard in Inventario con una sostituzione. Per identificare questi record, è possibile eseguire gli script di query SQL riportati di seguito nel database aziendale. Per correggere i record, è necessario aggiornare il record direttamente nelle tabelle SQL GL/AA per "net" l'importo nel campo di debito o di credito, in quanto solo uno di questi campi deve essere popolato. È consigliabile correggere manualmente ogni record uno per uno usando il Dex_Row_Id. Se sono necessari script per eseguire questa operazione in massa, consultare il partner Microsoft per assistenza. Usare gli script seguenti per trovare i record del problema:

select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL10001 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL20000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL30000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
--if using AA, also compare the AA tables:

select AAG0.JRNENTRY  from AAG30001 AAG1
join AAG30000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) and AAG1.SOURCDOC not in ('BBF','P/L')

select AAG0.JRNENTRY  from AAG40001 AAG1 join AAG40000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID 
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) 
or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) 
and AAG1.SOURCDOC not in ('BBF','P/L')

Passaggio 11 - Ricompilare il data mart

Dopo che tutti i risultati sono stati corretti in precedenza, eseguire di nuovo ogni script per assicurarsi che non vengano più restituiti risultati.

Ricompilare quindi Data Mart in Management Reporter e generare di nuovo i report finanziari. Con SQL Rilevamento modifiche, alcune modifiche possono essere aggiornate automaticamente, ma non tutte, pertanto è consigliabile ricompilare il data mart se sono state apportate modifiche direttamente in SQL per garantire il riconoscimento di tutte le modifiche. Ecco i passaggi per eseguire questa operazione (per precauzione, è possibile eseguire il backup del database DDM, perché verrà eliminato e ricreato):

  1. Aprire la Console di configurazione nel server dal menu Start .
  2. Nel riquadro di spostamento a sinistra selezionare Integrazioni ERP.
  3. Selezionare l'integrazione in uso (prendere nota del nome del server e dei nomi del database) e disabilitare l'integrazione con il pulsante "Disabilita integrazione".
  4. Selezionare Rimuovi per rimuovere l'integrazione ERP.
  5. Selezionare Management Reporter Services nel riquadro di spostamento a sinistra e arrestare entrambi i servizi Management Reporter.
  6. Eliminare il database DDM in SQL (è possibile eseguire prima un backup, se necessario).
  7. Avviare Management Reporter Services.
  8. Configurare di nuovo l'integrazione ERP passando aConfigurazionefile>.
  9. Al termine dell'installazione, abilitare le integrazioni ERP.

Con la correzione dei dati AA e l'aggiornamento di MR DDM dovrebbe eseguire il pull dei valori corretti.

Passaggio 12 - Verificare i saldi del report

Determinare se il report viene bilanciato o meno con il report gl trial balance. In caso contrario, vedere se è possibile determinare qual è la differenza. La differenza è ancora correlata alle voci di saldo anticipato non corrette? In tal caso, aprire un evento imprevisto di supporto per ottenere ulteriore assistenza.

Ulteriori informazioni

Per altre informazioni, vedere Procedure di chiusura di fine anno per La contabilità analitica in Microsoft Dynamics GP.