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Risolvere i problemi relativi alle risorse condivise

Questo articolo illustra i problemi che possono verificarsi quando si usano risorse condivise in Automazione di Azure.

Moduli

Scenario: un modulo si blocca durante l'importazione

Problema

Durante l'importazione o l'aggiornamento dei moduli in Automazione di Azure, un modulo rimane bloccato nello stato Importazione.

Causa

Poiché l'importazione dei moduli di PowerShell è un processo complesso e in più passaggi, un modulo potrebbe non essere importato correttamente e può rimanere bloccato in uno stato temporaneo. Per altre informazioni su questo processo, vedere Importazione di un modulo di PowerShell.

Risoluzione

Per risolvere questo problema è necessario rimuovere il modulo bloccato tramite il cmdlet Remove-AzAutomationModule. È quindi possibile ritentare l'importazione del modulo.

Remove-AzAutomationModule -Name ModuleName -ResourceGroupName ExampleResourceGroup -AutomationAccountName ExampleAutomationAccount -Force

Scenario: I moduli AzureRM rimangono bloccati durante l'importazione dopo un tentativo di aggiornamento

Problema

Un banner con il messaggio seguente rimane nell'account dopo aver tentato di aggiornare i moduli di AzureRM:

Azure modules are being updated

Causa

Si è verificato un problema noto relativo all'aggiornamento dei moduli AzureRM in un account di Automazione. In particolare, il problema si verifica se i moduli si trovano in un gruppo di risorse con un nome numerico che inizia con 0.

Risoluzione

Per aggiornare i moduli di AzureRM nell'account di Automazione, l'account deve trovarsi in un gruppo di risorse con un nome alfanumerico. I gruppi di risorse con nomi numerici che iniziano con 0 non sono in grado di aggiornare i moduli di AzureRM in questo momento.

Scenario: L'importazione del modulo non riesce o i cmdlet non possono essere eseguiti dopo l'importazione

Problema

L'importazione di un modulo ha esito negativo oppure riesce ma non viene estratto alcun cmdlet.

Causa

Di seguito sono elencati alcuni motivi comuni che possono causare un'importazione errata di un modulo in Automazione di Azure:

  • La struttura non corrisponde a quella necessaria per Automazione.
  • Il modulo dipende da un altro modulo che non è stato distribuito nel proprio account di automazione.
  • Le dipendenze del modulo non si trovano nella cartella.
  • Il cmdlet New-AzAutomationModule viene usato per caricare il modulo e non è stato specificato il percorso di archiviazione completo oppure il modulo non è stato caricato con un URL accessibile pubblicamente.

Risoluzione

Usare una di queste soluzioni per risolvere il problema:

  • Assicurarsi che il modulo segua il formato ModuleName.zip -> ModuleName o Version Number -> (ModuleName.psm1, ModuleName.psd1).
  • Aprire il file con estensione .psd1 e vedere se il modulo include dipendenze. In caso affermativo, caricare i moduli nell'account di automazione.
  • Assicurarsi che le eventuali file .dll a cui viene fatto riferimento siano presenti nella cartella del modulo.

Scenario: L'esecuzione di Update-AzureModule.ps1 viene sospesa durante l'aggiornamento dei moduli

Problema

Quando si usa il runbook Update-AzureModule.ps1 per aggiornare i moduli di Azure, il processo di aggiornamento dei moduli viene sospeso.

Causa

Per questo runbook, l'impostazione predefinita per determinare il numero di moduli aggiornati contemporaneamente è 10. Quando si aggiornano troppi moduli nello stesso momento, il processo di aggiornamento è soggetto a errori.

Risoluzione

Non è usuale che nello stesso account di automazione siano necessari tutti i moduli AzureRM o Az. È necessario importare solo i moduli specifici necessari.

Nota

Evitare di importare l'intero modulo Az.Automation o AzureRM.Automation, che importa tutti i moduli contenuti.

Se il processo di aggiornamento viene sospeso, è necessario aggiungere il parametro SimultaneousModuleImportJobCount allo script Update-AzureModules.ps1 e fornire un valore inferiore a quello predefinito, ossia 10. Se si implementa questa logica, provare a iniziare con un valore pari a 3 o 5. SimultaneousModuleImportJobCount è un parametro del runbook di sistema Update-AutomationAzureModulesForAccount usato per aggiornare i moduli di Azure. Se si effettua questa regolazione, il processo di aggiornamento viene eseguito più a lungo, ma ha una maggiore probabilità di completamento. L'esempio seguente mostra il parametro e la posizione in cui inserirlo nel runbook:

$Body = @"
   {
      "properties":{
      "runbook":{
            "name":"Update-AutomationAzureModulesForAccount"
      },
      "parameters":{
            ...
            "SimultaneousModuleImportJobCount":"3",
            ... 
      }
      }
   }
"@

Account RunAs

Nota

Automazione di Azure account Runas, inclusi gli account Runas classici sono stati ritirati il 30 settembre 2023 e sostituiti con identità gestite, non sarebbe più possibile creare o rinnovare gli account Runas tramite il portale di Azure. Per altre informazioni, vedere Eseguire la migrazione da un account RunAs esistente a Identità gestita.

Scenario: viene visualizzato l'errore "Impossibile trovare un punto di ingresso denominato 'GetPerAdapterInfo' nella DLL 'iplpapi.dll'" durante l'esecuzione di un runbook

Problema

Quando si esegue un runbook, si riceve l'eccezione seguente:

Unable to find an entry point named 'GetPerAdapterInfo' in DLL 'iplpapi.dll'

Causa

Questo errore è probabilmente causato da una configurazione non corretta dell'account RunAs.

Risoluzione

Verificare che l'account RunAs sia configurato correttamente. Quindi verificare di disporre del codice appropriato nel runbook per l'autenticazione con Azure. L'esempio seguente illustra un frammento di codice per l'autenticazione in Azure in un runbook usando un account RunAs.

$connection = Get-AutomationConnection -Name AzureRunAsConnection
Connect-AzAccount -ServicePrincipal -Tenant $connection.TenantID `
-ApplicationID $connection.ApplicationID -CertificateThumbprint $connection.CertificateThumbprint

Passaggi successivi

Se questo articolo non risolve il problema, usare uno dei canali seguenti per ottenere ulteriore assistenza:

  • Ottenere risposte dagli esperti di Azure tramite i forum di Azure.
  • Connessione con @AzureSupport. l'account Microsoft Azure ufficiale che mette in contatto la community di Azure con le risorse corrette: risposte, supporto ed esperti.
  • Archiviare un incidente del supporto tecnico di Azure. Accedere al sito del supporto tecnico di Azure e selezionare Supporto tecnico.