Condividi tramite


Non è possibile creare un Jupyter Notebook in Azure HDInsight

Questo articolo descrive le procedure di risoluzione dei problemi e le possibili soluzioni per i problemi che si verificano quando si interagisce con i cluster Azure HDInsight.

Problema

Quando si avvia Jupyter Notebook, viene visualizzato un messaggio di errore che contiene:

Cannot convert notebook to v5 because that version doesn't exist

Causa

Incompatibilità di versione.

Risoluzione

  1. Usare il comando ssh per connettersi al cluster. Modificare il comando seguente sostituendo CLUSTERNAME con il nome del cluster in uso e quindi immettere il comando:

    ssh sshuser@CLUSTERNAME-ssh.azurehdinsight.net
    
  2. Aprire _version.py eseguendo il comando seguente :

    sudo nano /usr/bin/anaconda/lib/python2.7/site-packages/nbformat/_version.py
    
  3. Modificare da 5 a 4 in modo che la riga modificata venga visualizzata come segue:

    version_info = (4, 0, 3)
    

    Salvare le modifiche immettendo Ctrl + X, Y, Invio.

  4. In un browser web, navigare a https://CLUSTERNAME.azurehdinsight.net/#/main/services/JUPYTER, dove CLUSTERNAME è il nome del tuo cluster.

  5. Riavviare il servizio Jupyter.

Passaggi successivi

Se il problema riscontrato non è presente in questo elenco o se non si riesce a risolverlo, visitare uno dei canali seguenti per ottenere ulteriore assistenza:

  • Ricevere risposte dagli esperti di Azure tramite la pagina Supporto della community per Azure.

  • Connettersi con @AzureSupport, l'account ufficiale Microsoft Azure per migliorare l'esperienza del cliente. Mette in contatto la community di Azure con le risorse giuste: risposte, supporto ed esperti.

  • Se serve ulteriore assistenza, è possibile inviare una richiesta di supporto dal portale di Azure. Selezionare Supporto nella barra dei menu o aprire l'hub Guida e supporto. Per informazioni più dettagliate, vedere Come creare una richiesta di supporto in Azure. L'accesso al supporto per la gestione delle sottoscrizioni e la fatturazione è incluso nella sottoscrizione di Microsoft Azure e il supporto tecnico viene fornito tramite uno dei piani di supporto di Azure.