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Risoluzione dei problemi di Windows SharePoint Services

Microsoft SharePoint Services viene utilizzato dall'adapter Windows SharePoint Services. In questo argomento vengono descritti alcuni problemi noti che potrebbero verificarsi con Windows SharePoint Services e le possibili soluzioni a questi problemi.

Problemi noti

Errore di accesso non riuscito per l'utente 'NT AUTHORITY\NETWORK SERVICE' quando si tenta di creare un database del contenuto

Problema

Quando si tenta di creare un database del contenuto utilizzando il sito Web Amministrazione centrale SharePoint, viene visualizzato un errore simile al seguente:

Accesso non riuscito per l'utente 'NT AUTHORITY\NETWORK SERVICE'

Motivo

Questo problema si verifica quando il proprietario del database a cui ci si connette è diverso dall'identità del pool di applicazioni in cui è in esecuzione Windows SharePoint Services.

Risoluzione

Per risolvere il problema, eseguire una delle operazioni seguenti:

  • Concedere i diritti di creazione del database all'account SERVIZIO DI RETE in SQL Server.

  • Modificare l'account di identità del pool di applicazioni in un account con diritti di creazione del database in SQL Server.

Errore "Servizio non disponibile" durante l'accesso al sito Web Amministrazione centrale SharePoint

Problema

Quando si tenta di aprire il sito Web Amministrazione centrale SharePoint, viene visualizzato un errore simile al seguente:

Servizio non disponibile

Motivo

La causa più comune di questo errore è che il pool di applicazioni (IIS 6.0 o IIS 7.0) o l'hosting dell'applicazione COM+ (IIS 5.x) per il sito Web Amministrazione centrale SharePoint è stato arrestato. Ciò si verifica in genere se il pool di applicazioni o l'applicazione COM+ è configurato con un'identità per cui il nome utente e/o la password specificati non sono validi.

Risoluzione

Seguire la procedura descritta nella sezione "Impostazione dell'identità del processo host dell'applicazione IIS" dell'argomento Linee guida per la risoluzione dei problemi relativi alle autorizzazioni IIS per impostare l'identità del processo host appropriata.

Errore "Impossibile connettersi al database di configurazione" quando si tenta di estendere e creare un database del contenuto

Problema

Quando si tenta di estendere e creare un database del contenuto utilizzando il sito Web Amministrazione centrale SharePoint, viene visualizzato un errore simile al seguente:

Impossibile connettersi al database di configurazione

Motivo

Questo problema si verifica quando l'account utilizzato dal pool di applicazioni che esegue il sito Web Amministrazione centrale SharePoint non dispone delle autorizzazioni necessarie per il database di SQL Server.

Risoluzione

Per risolvere il problema, eseguire una delle operazioni seguenti:

  • Concedere i diritti di "Creazione database" su SQL Server all'account utilizzato dal pool di applicazioni per il sito Web Amministrazione centrale di SharePoint.

  • Modificare l'account di identità del pool di applicazioni in un account con diritti di creazione del database in SQL Server.

L'errore "Il servizio Timer di SharePoint non è stato avviato" viene generato nel registro applicazioni dopo il riavvio del server

Problema

Dopo il riavvio del server, nei registri eventi viene visualizzato l'errore seguente:

Impossibile avviare il servizio Timer di SharePoint

È anche possibile che venga visualizzato l'errore seguente quando si apre il sito Amministrazione centrale SharePoint:

Impossibile connettersi al database di configurazione WSS STS_Config

Motivo

Questo errore si verifica quando il servizio Timer di SharePoint non riesce a contattare il database di SharePoint Services dopo il riavvio. Il servizio Timer di SharePoint viene usato per inviare notifiche ed eseguire attività pianificate per SharePoint Services. Il motivo più comune per cui il servizio Timer di SharePoint non viene avviato è che l'account usato per eseguire il servizio è configurato con un'identità per cui il nome utente e/o la password non sono più validi.

Risoluzione

Assicurarsi che il nome utente e la password specificati per l'account di accesso al servizio Timer di SharePoint siano corretti e che il servizio sia stato avviato.