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Impossibile accedere a Outlook sul Web o a EAC se il certificato OAuth di Exchange Server è scaduto

Numero originale della Knowledge Base: 2617816

Sintomi

Quando si tenta di accedere a Outlook sul Web o a EAC in Exchange Server, il browser Web si blocca o indica che è stato raggiunto il limite di reindirizzamento. Inoltre, nel visualizzatore eventi viene registrato l'evento 1003. Ad esempio, viene registrata la seguente voce:

ID evento: 1003
Fonte: Proxy HTTPS del front-end di MSExchange
[Owa] Si è verificato un errore interno al server. L'eccezione non gestita era: System.NullReferenceException: Riferimento a un oggetto non impostato su un'istanza di oggetto.
in Microsoft.Exchange.HttpProxy.FbaModule.ParseCadataCookies(HttpApplication httpApplication)

Nota

EAC è stato introdotto in Exchange Server 2013 e sostituisce Exchange Management Console (EMC) e Exchange Control Panel (ECP), che erano le due interfacce di gestione di Exchange Server 2010.

Causa

Questo problema si verifica se il certificato Open Authentication (OAuth) di Exchange Server è scaduto, non presente o non configurato correttamente.

Risoluzione

Per verificare lo stato del certificato OAuth esistente, eseguire il seguente comando in Exchange Management Shell:

(Get-AuthConfig).CurrentCertificateThumbprint | Get-ExchangeCertificate | Format-List

Se il comando restituisce un errore o se il certificato è scaduto, utilizzare i seguenti passaggi per creare e distribuire un nuovo certificato OAuth sul server Exchange:

  1. Creare un nuovo certificato OAuth eseguendo il seguente comando:

    New-ExchangeCertificate -KeySize 2048 -PrivateKeyExportable $true -SubjectName "cn=Microsoft Exchange Server Auth Certificate" -FriendlyName "Microsoft Exchange Server Auth Certificate" -DomainName @()
    
  2. Impostare il nuovo certificato per l'autenticazione server. A tale scopo, eseguire i seguenti comandi:

    Set-AuthConfig -NewCertificateThumbprint <ThumbprintFromStep1> -NewCertificateEffectiveDate (Get-Date)
    Set-AuthConfig -PublishCertificate
    Set-AuthConfig -ClearPreviousCertificate
    
  3. Riavviare il servizio Host servizio di Microsoft Exchange.

  4. Eseguire il comando IISReset per riavviare IIS oppure eseguire i seguenti comandi (con privilegi elevati) per riciclare i pool di applicazioni Outlook sul Web e EAC:

    Restart-WebAppPool MSExchangeOWAAppPool
    Restart-WebAppPool MSExchangeECPAppPool
    

    Nota

    In alcuni ambienti, la pubblicazione del certificato OAuth può richiedere un'ora. Se si utilizza una configurazione ibrida, è necessario eseguire nuovamente la Configurazione guidata ibrida per aggiornare le modifiche a Microsoft Entra ID.

Altre informazioni

Per verificare la data di scadenza del certificato, procedere come segue:

  1. Aprire Microsoft Management Console. A tale scopo, aprire la cassetta Esegui (tasto Windows + R), digitare MMC e premere INVIO.

    Nota

    Se viene richiesta una password amministratore o una conferma, digitare la password o selezionare .

  2. Selezionare File>Aggiungi/Rimuovi snap-in>Seleziona certificati>Aggiungi>Account del computer, quindi seleziona Fine per chiudere la finestra.

  3. Trovare la voce Certificato di autenticazione di Microsoft Exchange Server nella cartella Certificato>personale e verificare la data di scadenza.