Non è possibile ripristinare un singolo database usando Backup di Windows Server in Exchange Server

Numero KB originale: 2735099

Sintomi

Considerare lo scenario descritto di seguito:

  • È necessario ripristinare una cassetta postale in Exchange Server 2010 o Exchange Server 2007.
  • Il computer che esegue Exchange Server 2010 o Exchange Server 2007 ospita più database di cassette postali.
  • Si tenta di usare Windows Server Backup per ripristinare la singola cassetta postale. Questa cassetta postale si trova in un database specifico.

In questo scenario non è possibile ripristinare la singola cassetta postale o il singolo database. Quando si tenta di usare Windows Server Backup per ripristinare la cassetta postale, l'unica opzione disponibile consiste nel ripristinare tutti i database se si verifica una delle condizioni seguenti:

  • Il backup da ripristinare è un backup completo del volume e più database sono ospitati nello stesso volume.
  • Il backup da ripristinare è un backup completo del server e il server ospita più database.

Gli screenshot per questo problema sono elencati di seguito.

Screenshot dell'uso di Windows Server Backup per ripristinare la cassetta postale.

Screenshot della finestra dettagli - Exchange.

Causa

Questo problema si verifica perché Windows Server Backup consente solo di ripristinare tutti i database.

Nota

Si tratta di un comportamento legato alla progettazione.

Soluzione alternativa

Per risolvere questo problema, usare il Ripristino guidato in Backup di Windows Server per ripristinare file e cartelle da un backup. A tal fine, attenersi alla seguente procedura:

  1. Selezionare Avvia> strumenti >di amministrazioneWindows Server Backup.

  2. Nel riquadro Azioni della pagina predefinita dello snap-in selezionare Ripristina in Windows Server Backup.

    Nota

    Verrà visualizzata la Procedura guidata di ripristino.

  3. Nella pagina Introduzione selezionare l'opzione desiderata e quindi selezionare Avanti.

  4. Nella pagina Seleziona data backup selezionare la data dal calendario e l'ora nell'elenco a discesa del backup da cui si vuole eseguire il ripristino. Selezionare quindi Avanti.

  5. Nella pagina Seleziona tipo di ripristino selezionare File e cartelle e quindi selezionare Avanti (lo screenshot per questo passaggio è elencato di seguito).

    Screenshot della finestra Per selezionare il tipo di ripristino.

  6. Nella pagina Seleziona elementi da ripristinare , in Elementi disponibili, espandere l'elenco fino a quando la cartella desiderata non è visibile. selezionare una cartella per visualizzare il contenuto nel riquadro adiacente, selezionare ogni elemento da ripristinare e quindi selezionare Avanti (lo screenshot per questo passaggio è elencato di seguito).

    Screenshot della finestra Seleziona elementi da ripristinare.

  7. Nella pagina Specifica opzioni di ripristino selezionare Percorso originale e quindi avanti ( Lo screenshot per questo passaggio è elencato di seguito).

    Screenshot della finestra Per specificare le opzioni di ripristino.

  8. In Quando questa procedura guidata trova elementi nel backup già presenti nella destinazione di ripristino, selezionare l'opzione desiderata e quindi selezionare Avanti.

  9. In Impostazioni di sicurezza selezionare la casella di controllo Ripristina le autorizzazioni dell'elenco di controllo di accesso (ACL) per il file o la cartella ripristinata , se necessario, e quindi selezionare Avanti.

  10. Nella pagina Conferma esaminare i dettagli e quindi selezionare Ripristina per ripristinare gli elementi specificati.

  11. Nella pagina Stato ripristino verificare lo stato dell'operazione di ripristino.

  12. Al termine dell'operazione di ripristino, controllare l'integrità del database e verificare che i file di log esistano (lo screenshot per questo passaggio è elencato di seguito):

    Screenshot della verifica dell'esistenza dei file di log.

  13. Eseguire un'operazione di ripristino software. A tale scopo, eseguire l'utilità Eseutil.exe (lo screenshot per questo passaggio è elencato di seguito):

    Screenshot dell'esecuzione di un'operazione di ripristino software tramite prompt dei comandi.

  14. Verificare lo stato del database. A tale scopo, eseguire l'utilità Eseutil.exe (lo screenshot per questo passaggio è elencato di seguito):

    Screenshot della verifica dello stato del database tramite prompt dei comandi.

Ulteriori informazioni

Nota

Le informazioni seguenti si riferiscono alle informazioni contenute nel passaggio 7 del sito Web seguente. Queste informazioni verranno aggiornate:
Usare Windows Server Backup per ripristinare un backup di Exchange.

  1. Selezionare Ripristina nel percorso originale per ripristinare i dati di cui è stato eseguito il backup nella posizione originale. Se si usa questa opzione, non è possibile impostare un database singolo o più database. Tutti i database di cui è stato eseguito il backup vengono ripristinati nelle posizioni originali.

  2. Selezionare Ripristina in un altro percorso per ripristinare più database in una posizione personalizzata. A tale scopo, selezionare Sfoglia per specificare l'altro percorso. Se si usa questa opzione, è possibile ripristinare un singolo database o più database in un percorso personalizzato. Dopo il ripristino dei database, i file di dati possono quindi essere spostati in un database di ripristino e spostati manualmente nei percorsi originali. Quando si ripristinano i database in un'altra posizione, il database ripristinato si trova in uno stato di arresto dirty.