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Il servizio ResponderHealthMSExchangeReplForceReboot causa il riavvio di Exchange Server con errore di arresto

Numero KB originale: 2969070

Sintomi

Exchange Server 2016 o Exchange Server 2013 viene riavviato di frequente e viene visualizzato l'errore Stop seguente su una schermata blu.

controllo dei bug
Codice di controllo dei bug 000000EF
Argomenti fffffa801a5f9980 0000000000000000 0000000000000000000 00000000

I riavvii vengono avviati dal risponditore ServiceHealthMSExchangeReplForceRebootdi disponibilità gestita.

L'evento di azione di ripristino viene osservato in RecoveryActionResults:

Nome log: Microsoft-Exchange-ManagedAvailability/RecoveryActionResults
Origine: Microsoft-Exchange-ManagedAvailability
Data: DataOra
ID evento: 500
Categoria attività: Ripristino
Livello: Informazioni
Parole chiavi:
Utente: SISTEMA
Computer: Exch1.contoso.com
Descrizione:
Azione di ripristino avviata. (ActionId=ForceReboot, ResourceName=Exch1, Requester=ServiceHealthMSExchangeReplForceReboot, InstanceId=140428.105409.22538.004, ExpectedToFinishAt=2014-04-29T04:59:09.2253815Z

E messaggio di errore probe associato:

Nome log: Microsoft-Exchange-ActiveMonitoring/ProbeResult
Origine: Microsoft-Exchange-ActiveMonitoring
Data: DataOra
ID evento: 2
Categoria attività: risultato del probe
Livello: Errore
Parole chiavi:
Utente: SISTEMA
Computer: Exch1.contoso.com
Descrizione:
Risultato probe (Name=ServiceHealthMSExchangeReplEndpointProbe/TCP/MSExchangeRepl)
<Il controllo degli errori>'Microsoft.Exchange.Monitoring.TcpListenerCheck' ha generato un'eccezione. Eccezione: Microsoft.Exchange.Monitoring.ReplicationCheckHighPriorityFailedException: controllo con priorità elevata TcpListener non riuscito. Errore: il test di integrità del listener TCP per il servizio Replica di Microsoft Exchange nel server 'Exch1' non è riuscito. Questo server non può partecipare alla replica fino a quando l'errore non viene risolto. Errore: impossibile determinare l'indirizzo IP per il server 'Exch1' perché DNS non ha restituito alcuna informazione.
in Microsoft.Exchange.Monitoring.ReplicationCheck.FailInternal()
in Microsoft.Exchange.Monitoring.ReplicationCheck.Fail(LocalizedString error)
in Microsoft.Exchange.Monitoring.TcpListenerCheck.InternalRun()
in Microsoft.Exchange.Monitoring.ReplicationCheck.Run()
in Microsoft.Exchange.Monitoring.ActiveMonitoring.HighAvailability.Probes.ReplicationHealthChecksProbeBase.RunReplicationCheck(Type checkType)
Verificare che 'Microsoft.Exchange.Monitoring.TcpListenerCheck' non sia stato superato.
Messaggio di dettaglio: il test di integrità del listener TCP per il servizio Replica di Microsoft Exchange nel server 'Exch1' non è riuscito. Questo server non può partecipare alla replica fino a quando l'errore non viene risolto. Errore: impossibile determinare l'indirizzo IP per il server 'Exch1' perché DNS non ha restituito alcuna informazione.
</Errore>

Causa

La scheda di rete non configurata correttamente in Exchange Server causa un errore nella risoluzione dei nomi DNS (Domain Name System).

Risoluzione

Assicurarsi che nella scheda di rete sia selezionata la proprietà Registra gli indirizzi di questa connessione in DNS :

Screenshot che mostra che è selezionata l'opzione Registra gli indirizzi di questa connessione nella proprietà DNS.

Nota

Per il server Exchange che è membro di DAG e dispone di schede di rete MAPI e Replication separate, assicurarsi che questa proprietà sia selezionata nella scheda di rete che rappresenta la rete MAPI.

Esaminare le linee guida fornite nell'articolo seguente e verificare che la scheda di rete che rappresenta le reti MAPI e Replica sia configurata di conseguenza.

Pianificazione della disponibilità elevata e della resilienza del sito

Ulteriori informazioni

Usare il comando di PowerShell seguente nel server Exchange interessato per assicurarsi che i riavvii del server siano effettivamente causati dal ServiceHealthMSExchangeReplForceReboot risponditore.

Get-WinEvent -LogName Microsoft-Exchange-ManagedAvailability/* | where {$_.Message -like "*ServiceHealthMSExchangeReplForceReboot*"} | ft Message,TimeCreated

In alternativa, è possibile cercare nel log dei canali cremisi denominato Log azioni di ripristino e Log azioni remote la parola ForceReboot per trovare il risponditore che causa il riavvio.