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Numero KB originale: 4337973
Sintomi
Si consideri lo scenario seguente in un ambiente Microsoft Exchange ibrido:
Si esclude un account utente locale per impedire a Microsoft Entra Connect di sincronizzare l'account con Microsoft Entra ID.
Successivamente, si rimuove l'esclusione per consentire la ripresa della sincronizzazione.
Come previsto, l'utente ha perso l'accesso alla cassetta postale cloud quando la sincronizzazione è stata arrestata. Tuttavia, quando la sincronizzazione è ripresa, all'utente è stata assegnata una nuova cassetta postale cloud vuota anziché la cassetta postale cloud originale.
Motivo
Quando Microsoft Entra Connect interrompe la sincronizzazione di un account utente locale con Microsoft Entra ID, vengono eseguite le azioni seguenti:
Account utente in Microsoft Entra ID: Microsoft Entra ID elimina immediatamente l'account utente in modo soft e lo sposta nell'elenco degli utenti eliminati nel centro di amministrazione di "Microsoft 365" e nel centro di amministrazione di "Microsoft Entra". Se Microsoft Entra Connect non riprende la sincronizzazione entro 30 giorni, l'account utente viene eliminato definitivamente.
Cassetta postale cloud: Exchange Online elimina immediatamente la cassetta postale cloud associata all'account utente eliminato soft. Di conseguenza, la cassetta postale non è accessibile sia all'utente che ai delegati. Se Microsoft Entra Connect non riprende la sincronizzazione entro 30 giorni, si verifica una delle azioni seguenti:
Se la cassetta postale cloud associata ha un blocco applicato, la cassetta postale viene modificata in una cassetta postale inattiva. Per verificare la presenza di una cassetta postale inattiva, eseguire il cmdlet seguente in PowerShell per Exchange Online:
Get-Mailbox -IncludeInactiveMailbox -Identity <cloud mailbox identity> | FL IsInactiveMailbox
Se la cassetta postale cloud associata non ha alcun blocco applicato, viene eliminata definitivamente e il relativo contenuto non è irreversibile.
Quando Microsoft Entra Connect riprende la sincronizzazione di un account utente locale il cui account utente associato in Microsoft Entra ID viene eliminato definitivamente, vengono eseguite le azioni seguenti:
Microsoft Entra ID crea un nuovo account utente in Microsoft Entra ID.
Exchange Online effettua il provisioning di una nuova cassetta postale cloud per il nuovo account utente.
Questo comportamento è predefinito.
Annotazioni
Se la sincronizzazione dell'account utente locale riprende prima dell'eliminazione definitiva dell'account utente in Microsoft Entra ID, il sistema ripristina sia la cassetta postale cloud originale che l'account utente originale in Microsoft Entra ID.
Soluzione
Per risolvere il problema, se la cassetta postale cloud originale dell'utente è una cassetta postale inattiva, recuperare i dati dell'utente ripristinando il contenuto della cassetta postale inattiva nella nuova cassetta postale cloud dell'utente.
Suggerimento
In alternativa, è possibile ripristinare una cassetta postale inattiva se vengono soddisfatte entrambe le condizioni seguenti:
- L'account utente originale in Microsoft Entra ID viene eliminato definitivamente.
- La sincronizzazione dell'account utente locale non è stata ripresa. Di conseguenza, Microsoft Entra ID non ha creato un nuovo account utente e Exchange Online non ha effettuato il provisioning di una nuova cassetta postale cloud.
Se la cassetta postale cloud originale dell'utente non aveva alcun blocco applicato e viene eliminata in modo definitivo, il contenuto della cassetta postale non è irreversibile. Per evitare l'eliminazione accidentale o accidentale dei dati delle cassette postali, è consigliabile applicare un criterio di conservazione o posizionare un blocco su una cassetta postale cloud prima che l'account utente associato in Microsoft Entra ID venga eliminato definitivamente.