L'operazione Remove MailboxDatabase non riesce a pulire le cassette postali di integrità
Numero KB originale: 3046530
Sintomi
Quando si tenta di rimuovere un database delle cassette postali da Exchange Server 2016 o Exchange Server 2013, vengono visualizzati gli avvisi seguenti:
EMS:
EAC:
Causa
Questo tentativo di rimuovere il database delle cassette postali non riesce a rimuovere gli account utente di Active Directory delle cassette postali di integrità nel database e attiva i messaggi di avviso.
In questo caso non è possibile rimuovere gli account utente di Active Directory perché il gruppo di sicurezza Exchange Server eredita le autorizzazioni di negazione esplicite per l'eliminazione di oggetti nel contenitore Cassette postali di monitoraggio.
Soluzione alternativa
Per risolvere questo problema, seguire questa procedura per aggiungere un'autorizzazione esplicita consenti al gruppo Exchange Server nel contenitore Cassette postali di monitoraggio. A tal fine, attenersi alla seguente procedura:
Aprire Utenti e computer di Active Directory.
Selezionare Visualizza e quindi assicurarsi che sia selezionata l'opzione Funzionalità avanzate . In caso contrario, selezionarlo.
Passare al contenitore seguente:
Fare clic con il pulsante destro del mouse su Cassette postali di monitoraggio, selezionare Proprietà e quindi selezionare la scheda Sicurezza .
Selezionare Avanzate nella scheda Sicurezza . Verrà visualizzata questa finestra di dialogo:
Selezionare Aggiungi, digitare Exchange Server, selezionare Controlla nomi e quindi selezionare OK.
Selezionare la casella di controllo Consenti per l'autorizzazione Elimina sottoalbero .
Selezionare OK in tutte le finestre rimanenti.
Attendere la replica di Active Directory.
Se si dispone di una distribuzione di Exchange in un ambiente di dominio multi-AD, seguire i passaggi precedenti in tutti i domini in cui vengono distribuiti i server Exchange.