App Windows Mail non bloccata nonostante le impostazioni dell'organizzazione ActiveSync
Sintomi
Le impostazioni Exchange ActiveSync per l'organizzazione sono impostate per bloccare l'accesso a tutti i dispositivi. Tuttavia, è comunque possibile accedere alle cassette postali usando l'app Windows Mail. Ciò si verifica anche se i dettagli del dispositivo mobile indicano che le connessioni alle cassette postali effettuate tramite Windows Mail verranno bloccate.
Usare i metodi seguenti per verificare che Exchange ActiveSync sia configurato correttamente.
Per controllare le impostazioni di ActiveSync dell'organizzazione:
Get-ActiveSyncOrganizationSettings | ft DefaultAccessLevel
Se ActiveSync è impostato su blocca i dispositivi, questo comando restituisce l'output seguente:
DefaultAccessLevel : Block
Per controllare i dispositivi configurati per la sincronizzazione con una cassetta postale specifica:
Get-MobileDeviceStatistics -Mailbox <MailboxID> | fl DeviceUserAgent,DeviceType,deviceos,deviceaccessstate
Questo comando restituisce l'output seguente:
DeviceType : UniversalOutlook DeviceOS : WINDOWS DeviceAccessState : Unknown
Per controllare i dispositivi associati a una cassetta postale specifica:
Get-MobileDevice -Mailbox <MailboxID> | fl DeviceUserAgent,DeviceType,deviceos,deviceaccessstate
Questo comando restituisce l'output seguente:
DeviceUserAgent : microsoft.windowscommunicationsapps DeviceType : UniversalOutlook DeviceOS : WINDOWS DeviceAccessState : Blocked
Causa
L'app Windows Mail usa una tecnologia di sincronizzazione Microsoft nativa che non è bloccata dalle regole di accesso al dispositivo ActiveSync. Le impostazioni di ActiveSync e le regole di accesso ai dispositivi dell'organizzazione vengono usate solo per gestire Microsoft Outlook per le connessioni per dispositivi mobili e ActiveSync.
Risoluzione
Per impedire all'app Windows Mail di accedere alle cassette postali, usare le regole di accesso client o il parametro UniversalOutlookEnabled del cmdlet Set-CASMailbox .