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Numero KB originale: 3099532
Sintomi
È stato installato correttamente Microsoft Exchange Server 2016 o Exchange Server 2013. Il processo di installazione potrebbe non riuscire o essere stato interrotto in una fase e quindi ripreso e infine completato correttamente. Tuttavia, quando si tenta di accedere a Exchange Pannello di controllo (ECP) o Outlook Web App (OWA), viene visualizzato il messaggio di errore seguente:
si è verificato un errore
Le informazioni richieste non sono attualmente disponibili. Riprovare più tardi. Se il problema persiste, contattare il supporto tecnico.
Inoltre, nel log dell'applicazione potrebbe essere registrato l'evento seguente:
Log Name: Application
Source: ASP.NET 4.0.30319.0
Event ID: 1309
Task Category: Web Event
Level: Warning
Keywords: Classic
User: N/A
Computer: Exch2.contoso.com
Description:
Event code: 3005
Event message: An unhandled exception has occurred.
Event ID: f23d9d455f3145068c57286262ac517f
Event sequence: 1
Event occurrence: 1
Event detail code: 0
Application information:
Application domain: /LM/W3SVC/2/ROOT/owa-5-130879214460462920
Trust level: Full
Application Virtual Path: /owa
Application Path: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa\
Machine name: EXCH2
Process information:
Process ID: 4348
Process name: w3wp.exe
Account name: NT AUTHORITY\SYSTEM
Exception information:
Exception type: TargetInvocationException
Exception message: Exception has been thrown by the target of an invocation.
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck,
Boolean&canBeCached, RuntimeMethodHandleInternal&ctor, Boolean&bNeedSecurityCheck)
* SharedWebConfig.config is missing from either of these locations:
C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess
Causa
Questo problema si verifica se SharedWebConfig.config non è presente in una delle posizioni seguenti:
- C:\Programmi\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
- C:\Programmi\Microsoft\Exchange Server\V15\ClientAccess
Risoluzione
Per risolvere il problema, seguire la procedura seguente:
Nel server che si trova ad affrontare il problema, identificare il percorso da cui manca il file.
Generare il file mancante:
Eseguire
cd %ExchangeInstallPath%\bin
per modificare la directory corrente nella cartella bin nel percorso di installazione di Exchange.Usare lo strumento DependentAssemblyGenerator.exe per generare il file:
- Se il file non è presente in C:\Programmi\Microsoft\Exchange Server\V15\ClientAccess, eseguire il comando seguente:
DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
- Se il file non è presente in C:\Programmi\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy, eseguire il comando seguente:
DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
Eseguire IISRESET o riavviare il server.
Ulteriori informazioni
Il fileSharedWebConfig.config viene generato durante la fase di post-installazione del programma di installazione. Se il programma di installazione riprende dopo un'interruzione, non esegue i passaggi successivi all'installazione per i ruoli installati correttamente prima dell'interruzione.