Gli elementi nella cartella Problemi di sincronizzazione non vengono elaborati o eliminati da criteri gestione record di messaggistica in Outlook 2007 o Outlook 2010

Numero KB originale: 2686541

Sintomi

Quando si usa Microsoft Office Outlook 2007 o Microsoft Outlook 2010 in modalità Cached Exchange, i messaggi vengono creati nella cartella Problemi di sincronizzazione. Gli amministratori di Exchange possono creare un tag di criteri di conservazione (RPT) per la cartella Problemi di sincronizzazione e quindi aggiungere tale RPT a un criterio di conservazione esistente.

Quando si applicano criteri di Gestione record di messaggistica alla cassetta postale, gli elementi nella cartella Problemi di sincronizzazione potrebbero avere una data di scadenza contrassegnata per gli elementi. Tuttavia, MRM non elabora o elimina gli elementi.

Causa

MRM non elabora la cartella Problemi di sincronizzazione perché la cartella è solo una cartella sul lato client. Se si usa Microsoft Exchange Server Editor API di messaggistica (MAPI) per visualizzare la cartella Problemi di sincronizzazione, è possibile notare che per gli elementi in tale cartella non è presente un tag di criteri MRM contrassegnato per gli elementi. Quando Managed Folder Assistant elabora la cassetta postale, gli elementi in questa cartella non vengono gestiti.

Il motivo per cui gli elementi sono elencati come scaduti è che Outlook in modalità Cached Exchange esegue il pull delle informazioni sui tag dei criteri per la cartella e quindi esegue il calcolo per la scadenza stessa.

Soluzione alternativa

Per risolvere questo problema, non implementare un RPT per la cartella Problemi di sincronizzazione perché non verrà eseguita alcuna azione sul contenuto della cartella Problemi di sincronizzazione stessa. Questo tag di conservazione viene applicato automaticamente al contenuto delle sottocartelle nella cartella Problemi di sincronizzazione.

Inoltre, se si vuole svuotare automaticamente la cartella Problemi di sincronizzazione, è necessario usare la funzionalità di archiviazione automatica in Outlook.

Ulteriori informazioni

Cartelle degli errori di sincronizzazione

Di seguito è riportato un estratto della pagina Web Delle cartelle degli errori di sincronizzazione:

(The Sync Issues folder) contains all of the synchronization logs. In previous releases of Microsoft Outlook, these logs were stored in the Deleted Items folder. This folder is helpful if Outlook is having trouble synchronizing—for example, there is an item that you see in Outlook Web Access, but not in Outlook—or you are not getting new mail in some folders when using Cached Exchange Mode.

Le informazioni contenute in questa cartella possono aiutare il team di supporto dell'organizzazione o l'amministratore del server di Microsoft Exchange a determinare gli errori. Il contenuto della cartella Problemi di sincronizzazione non viene copiato nel server e non è possibile visualizzare gli elementi nella cartella Problemi di sincronizzazione da altri computer.

Importante

Anche se la cartella Problemi di sincronizzazione non viene eseguita in base al momento dell'applicazione del protocollo RPT, tenere presente che quando viene applicato il protocollo RPT, il tag verrà applicato automaticamente alle sottocartelle della cartella Problemi di sincronizzazione. Le sottocartelle includono conflitti, errori locali ed errori del server. Qualsiasi sottocartella che contiene contenuto archiviato nel Exchange Server verrà eseguita da MRM. Prestare attenzione quando si applica questo RPT perché potrebbero essere presenti elementi nelle sottocartelle che indicano problemi. L'eliminazione automatica di questo contenuto potrebbe causare la perdita di dati o mascherare problemi più gravi con client specifici.

Proprietà Data scadenza elemento posta

Per altre informazioni sulla proprietà Data di scadenza dell'elemento di posta elettronica, visitare il sito Web Microsoft Developer Network (MSDN) seguente:

MailItem.RetentionExpirationDate, proprietà

Microsoft Outlook calcola il valore di questa proprietà in base alla data di inizio della conservazione degli elementi e al periodo di conservazione, se Outlook è in modalità cache o offline. Se Outlook è in modalità online, il valore viene specificato dal server di Exchange.

Per altre informazioni sui criteri di conservazione e sui tag di conservazione, visitare il sito Web Microsoft Exchange Server seguente:

Informazioni sui tag di conservazione e sui criteri di conservazione