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I messaggi di posta elettronica in uscita non vengono inviati nel server Trasporto hub di Exchange o Edge

Numero KB originale: 4051498

Sintomi

Quando si esamina lo stato della coda, si nota il messaggio di errore seguente:

451 4.4.0 Indirizzo IP di destinazione primaria ha risposto con: "421 4.4.1 Timeout della connessione". Tentativo di failover in un host alternativo, ma non riuscito. Non sono presenti host alternativi o il recapito non è riuscito a tutti gli host alternativi.

Inoltre, la voce seguente viene registrata nei log del connettore di invio se la registrazione è abilitata:

Negoziazione TLS non riuscita con errore UnknownCredentials.

Causa

Questo problema si verifica se un certificato di terze parti installato nel server che esegue Exchange Server non è associato al servizio SMTP.

Risoluzione

Per risolvere questo problema, associare il certificato di terze parti al servizio SMTP. A tal fine, attenersi alla seguente procedura:

  1. Abilitare la registrazione nel connettore di invio. A tale scopo, utilizzare il seguente comando:

    Set-SendConnector "<SendConnectorName>" -ProtocolLoggingLevel Verbose
    
  2. Nei log del connettore di invio cercare l'identificazione personale del certificato TLS. Log di esempio:

    2017-10-07T04:42:56.804Z, in uscita per Office 365,08D50D3D9730A8D2,16,10.10.248.7:16547,216.32.181.234:25,*,"CN=*.domain.com, OU=Enterprise SSL Wildcard, OU=Contoso IT, O=Contoso Corporation",Soggetto certificato
    10-07T04:42:56.804Z 2017,in uscita per Office 365,08D50D3D9730A8D2,17,10.10.248.7:16547,216.32.181.234:25,*,"CN=Trusted Secure Certificate Authority 5, O=Corporation Service Company, L=Wilmington, S=DE, C=US",Nome autorità di certificazione
    2017-10-07T04:42:56.804Z, in uscita per Office 365,08D50D3D9730A8D2,18,10.10.248.7:16547,216.32.181.234:25,*,xxxxxxxxxxxx,Numero di serie del certificato
    2017-10-07T04:42:56.804Z, in uscita per Office 365,08D50D3D9730A8D2,19,10.10.248.7:16547,216.32.181.234:25,*,xxxxxxxxxxxxxxxx,Identificazione personale del certificato
    2017-10-07T04:42:56.804Z, in uscita per Office 365,08D50D3D9730A8D2,20,20,10.10.248.7:16547,216.32.181.234:25,*,*.domai.com;conotso.com,Nomi alternativi del certificato
    2017-10-07T04:42:56.804Z, in uscita per Office 365,08D50D3D9730A8D2,21,10.10.248.7:16547,216.32.181.234:25,*,,Negoziazione TLS non riuscita con errore UnknownCredentials

  3. Verificare i servizi associati al certificato TLS. A tale scopo, eseguire il comando seguente. I nomi dei servizi vengono usati nel passaggio successivo.

    Get-ExchangeCertificate -ThumbPrint "<TLSCertThumbprint>" | select-object services
    
  4. Associare il certificato al servizio SMTP. A tale scopo, utilizzare il seguente comando:

    Enable-ExchangeCertificate -ThumbPrint "<TLSCertThumbprint>" -services <ServicesNames>
    

    Esempio:

    Enable-ExchangeCertificate -ThumbPrint "xxxxxxxxxxxxxxxxxxxx" -services SMTP,IIS,POP
    
  5. Al prompt per sostituire il certificato esistente usando il nuovo certificato, digitare N e quindi premere INVIO.