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Numero KB originale: 4090814
Sintomi
In Microsoft Exchange Online alcuni dispositivi mobili non vengono messi in quarantena come previsto.
Si consideri, ad esempio, lo scenario seguente:
Nel tenant di Microsoft 365 le impostazioni di accesso Exchange ActiveSync sono configurate su Quarantena: è possibile decidere di bloccare o consentire in un secondo momento. Un dispositivo in quarantena è quindi Consentito. Quando il dispositivo è consentito, il
Get-CASMailbox
cmdlet mostra i dispositivi consentiti e bloccati neiActiveSyncAllowedDeviceIDs
parametri eActiveSyncBlockedDeviceIDs
.Successivamente, si vuole rimuovere il dispositivo. A tale scopo, è possibile usare uno dei metodi seguenti:
Metodo 1
- Individuare lecassette postalidei destinatari> di Exchange Amministrazione Center>.
- Sul lato destro in Dispositivi mobili selezionare Visualizza dettagli e quindi rimuovere il dispositivo dall'elenco di tutti i dispositivi mobili.
Metodo 2
Usare il
Remove-MobileDevice
cmdlet di PowerShell.Dopo aver rimosso il dispositivo, l'utente tenta di aggiungere o configurare lo stesso dispositivo.
In questo scenario, il dispositivo non è messo in quarantena e può connettersi. Nell'interfaccia di amministrazione di Microsoft 365 Exchange i dettagli del dispositivo mobile per l'utente mostrano lo stato Accesso concesso e il Get-MobileDevice
cmdlet mostra che il valore del DeviceAccessState
parametro è Consentito. Questo non è il risultato previsto. Si prevede invece che il dispositivo venga messo in quarantena.
Causa
Quando il dispositivo viene rimosso (da Microsoft 365 Exchange Amministrazione Center o tramite PowerShell usando il Remove-MobileDevice
cmdlet ), i ActiveSyncAllowedDeviceIDs
parametri e ActiveSyncBlockedDeviceIDs
non vengono cancellati. Pertanto, quando l'utente tenta di connettersi usando il dispositivo rimosso in precedenza, l'ID del dispositivo viene comunque popolato nel parametro , quindi il dispositivo non viene messo in ActiveSyncAllowedDeviceIDs
quarantena e può connettersi.
Soluzione alternativa
Per impedire la connessione del dispositivo, impostare i ActiveSyncAllowedDeviceIDs
parametri e ActiveSyncBlockedDeviceIDs
su $null dopo aver rimosso il dispositivo. Ad esempio, eseguire il cmdlet seguente:
Set-CASMailbox joe@contoso.com -ActiveSyncAllowedDeviceIDs $null
Quando questi parametri sono impostati su $null, il dispositivo viene messo in quarantena quando tenta di connettersi.
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