Errore MigrationPermanentException durante lo spostamento delle cassette postali da Exchange Online a Exchange Server 2010

Numero KB originale: 2932443

Nota

La configurazione guidata ibrida inclusa nel Exchange Management Console in Microsoft Exchange Server 2010 non è più supportata. Pertanto, non è più consigliabile usare la configurazione guidata ibrida precedente. Usare invece la configurazione guidata ibrida di Microsoft 365. Per altre informazioni, vedere Configurazione guidata ibrida di Microsoft 365 per Exchange 2010.

Sintomi

Si supponga di avere una distribuzione ibrida di Exchange che include server Exchange 2010 locali. Quando si tenta di eseguire l'offboarding o spostare una cassetta postale da Exchange Online a un server Exchange 2010 nell'ambiente locale, viene visualizzato il messaggio di errore seguente:

Errore: MigrationPermanentException:

Non è consigliabile eseguire la migrazione della cassetta postale "<username>" a Exchange 2010 o a una versione precedente mentre l'elenco di contatti di Messaggistica istantanea dell'utente è archiviato in Exchange. In tal caso, l'utente potrebbe perdere definitivamente l'accesso all'elenco di contatti di Messaggistica immediata, causando una grave perdita di dati. La copia di Exchange potrebbe essere l'unica copia dell'elenco contatti dell'utente. Per continuare, contattare l'amministratore di Messaggistica immediata e assicurarsi che l'elenco dei contatti dell'utente venga spostato di nuovo nel server messaggistica immediata. Al termine, sarà possibile completare la migrazione. Se è necessario eseguire la migrazione della cassetta postale nonostante la potenziale perdita di dati, è possibile eseguire "Set-UMMailbox mailboxID -ImListMigrationCompleted $false".

Tuttavia, quando si esegue il Set-UMMailbox mailboxID -ImListMigrationCompleted $false cmdlet come indicato nel messaggio di errore, viene visualizzato il messaggio di errore seguente:

Il nome utente> della cassetta postale<@contoso.com non è abilitato per la messaggistica unificata.

Causa

Ciò si verifica se i contatti di Lync 2013 dell'utente associato alla cassetta postale vengono archiviati nell'archivio contatti unificato in Exchange. Per impostazione predefinita, se l'utente ha eseguito l'accesso a Lync 2013, l'archivio contatti unificato è abilitato per tale utente. Inoltre, viene eseguita la migrazione dei contatti lync dell'utente dal server Lync a Exchange.

Risoluzione

Importante

Attualmente, il ImListMigrationCompleted parametro è disponibile solo in Exchange Server (locale). Per altre informazioni su come importare file PST nelle cassette postali Exchange Online, vedere panoramica dell'importazione dei file PST dell'organizzazione.

Usare il cmdlet Set-Mailbox insieme al ImListMigrationCompleted parametro anziché al Set-UMMailbox cmdlet . Ad esempio, eseguire il cmdlet seguente:

Set-Mailbox John@contoso.com -ImListMigrationCompleted $false

Dopo aver eseguito il cmdlet, eseguire la richiesta di spostamento della cassetta postale.

Nota

L'impostazione $false nel ImListMigrationCompleted parametro indica che non è stata eseguita la migrazione dei contatti dell'utente a Lync per mantenere l'elenco dei contatti. Tenere presente che la soluzione in questa sezione può causare la perdita di dati. Exchange Server 2010 non supporta la funzionalità dell'archivio contatti unificato in Lync 2013. Pertanto, se si sposta di nuovo una cassetta postale in Exchange Server 2010 mentre i contatti lync dell'utente vengono archiviati nell'archivio contatti unificato, l'utente potrebbe perdere l'accesso ai contatti di Lync. Prima di spostare la cassetta postale in Exchange Server 2010, è necessario assicurarsi che i contatti di Lync dell'utente vengano spostati di nuovo nel server Lync.

Ulteriori informazioni

Se si verificano problemi durante lo spostamento delle cassette postali in Exchange Online in Microsoft 365, è possibile eseguire lo strumento Risoluzione dei problemi relativi alla migrazione delle cassette postali di Microsoft 365. Questa diagnostica è uno strumento di risoluzione dei problemi automatizzato. Se si verifica un problema noto, viene visualizzato un messaggio che indica gli errori. Il messaggio include un collegamento a un articolo che contiene la soluzione. Attualmente, lo strumento è supportato solo in Internet Explorer.

Ulteriore assistenza Visitare la community Microsoft o Domande e risposte Microsoft.