Condividi tramite


Le cartelle Preferiti non sono presenti nel client Outlook dopo la migrazione a Exchange Online

Sintomi

Considerare lo scenario descritto di seguito:

  • Si esegue la migrazione di una cassetta postale utente locale a Microsoft Exchange Online.

  • Dopo la migrazione, l'utente della cassetta postale crea un nuovo profilo di Microsoft Outlook.

In questo scenario, le cartelle elencate come Preferiti prima della migrazione non sono più elencate come Preferiti nel client Outlook.

Outlook sul web non è interessato da questo problema.

Causa

Ogni cartella Preferiti ha un MailboxDN valore di campo all'interno del valore della PR_WLINK_STORE_ENTRYID proprietà che associa la cartella alla cassetta postale. Prima della migrazione della cassetta postale, il valore del MailboxDN campo riflette il LegacyExchangeDN valore della proprietà della cassetta postale locale.

Quando la cassetta postale viene migrata nel cloud, Exchange Online applica un nuovo LegacyExchangeDN valore alla cassetta postale cloud. Tuttavia, Exchange Online non aggiorna il MailboxDN valore del campo di ogni cartella Preferiti al nuovo LegacyExchangeDN valore. Se l'utente della cassetta postale continua a usare il profilo di Outlook esistente dopo la migrazione, le cartelle Preferiti vengono visualizzate come di consueto nel client outlook. Tuttavia, se l'utente crea e usa un nuovo profilo di Outlook, la mancata corrispondenza tra il MailboxDN valore di ogni cartella e il LegacyExchangeDN valore della cassetta postale Exchange Online fa sì che le cartelle Preferiti non vengano visualizzate nel client Outlook.

Soluzione alternativa

Per risolvere questo problema, gli utenti delle cassette postali possono usare una delle soluzioni alternative seguenti.

Aggiungere nuovamente manualmente le cartelle ai Preferiti nel client Outlook.

Soluzione alternativa 2

Usare lo strumento MFCMAPI per aggiornare manualmente il MailboxDN valore di ogni cartella da aggiungere ai Preferiti.

attenersi alla seguente procedura:

  1. Eseguire il comando seguente per connettersi a Exchange Online PowerShell:

    Connect-ExchangeOnline
    
  2. Eseguire il comando seguente per trovare il LegacyExchangeDN valore della cassetta postale Exchange Online:

    Get-Mailbox <mailbox SMTP address> | FL LegacyExchangeDN
    
  3. Determinare se l'installazione di Outlook è una versione a 32 bit o a 64 bit controllando l'account> file > diOfficeSu Outlook.

  4. Scaricare ed estrarre la versione MFCMAPI più recente a 32 bit o a 64 bit in base all'installazione di Outlook.

    Importante

    Anche se l'editor MFCMAPI è supportato, è consigliabile prestare attenzione quando si usa questo strumento per modificare le cassette postali. L'uso errato dell'editor MFCMAPI può causare danni permanenti a una cassetta postale.

  5. Assicurarsi che Outlook sia chiuso e quindi eseguire MFCMapi.exe. Se viene visualizzata la schermata di avvio MFCMAPI, chiuderla.

  6. Selezionare Accesso sessione> per aprire la finestra Scegli profilo.

  7. Selezionare il profilo di Outlook per la cassetta postale dell'utente e quindi selezionare OK.

  8. Fare doppio clic sull'indirizzo SMTP della cassetta postale nella colonna Nome visualizzato per aprire la finestra Cassetta postale radice per la cassetta postale.

  9. Nel riquadro sinistro selezionareVisualizzazioni comunicassetta postale> radice.

  10. Nel riquadro destro fare doppio clic su PR_FOLDER_ASSOCIATED_CONTENTS per aprire la tabella contenuto associata .

  11. Per ogni cartella che non viene visualizzata nell'elenco Preferiti, seguire questa procedura:

    1. Fare doppio clic sul nome della cartella nella colonna PR_SUBJECT per aprire la finestra Proprietà della cartella.

    2. Fare doppio clic sulla voce PR_WLINK_STORE_ENTRYID nella colonna Nome per aprire la finestra Proprietà Editor.

    3. Nella sezione Smart View selezionare il campo EntryID>MAPI Message Store Entry ID>MailboxDN . Il valore del campo corrisponde al LegacyExchangeDN valore della cassetta postale locale prima della migrazione.

    4. Nella sezione Testo aggiornare il valore MailboxDN in modo che corrisponda al valore corrente LegacyExchangeDN della cassetta postale ottenuta nel passaggio 2.

  12. Chiudere tutte le finestre MFCMAPI per uscire dall'applicazione.

  13. Avviare Outlook e verificare che la raccolta di cartelle Preferiti disponibile prima della migrazione venga ripristinata.