Condividi tramite


Errore "Memoria insufficiente o risorse di sistema" durante l'accesso all'elenco contatti dalla cartella pubblica

Sintomi

Si dispone di una cartella pubblica che contiene un elenco di contatti in Microsoft Exchange Server. Quando si tenta di accedere all'elenco contatti in Microsoft Outlook in modalità online, viene visualizzato il messaggio di errore seguente:

Ci sono problemi durante l'apertura dell'elemento. Questo potrebbe essere temporaneo, ma se lo vedi di nuovo potresti voler riavviare Outlook. Memoria insufficiente o risorse di sistema. Chiudere alcune finestre o programmi e riprovare.

Screenshot del messaggio di errore nella finestra di Microsoft Outlook.

Causa

Non esiste alcun limite specifico al numero di contatti per un elenco di contatti. Tuttavia, esiste un limite di memoria per il recupero delle proprietà dei membri dell'elenco contatti (ad esempio DisplayName o EmailAddresses) in Exchange Server. Se i membri dell'elenco di contatti hanno nomi lunghi o indirizzi di posta elettronica, è necessaria più memoria per recuperare le proprietà in Outlook in modalità online. Questo problema si verifica se viene superato il limite di memoria.

Soluzione alternativa

Per ovviare a questo problema, utilizzare uno dei seguenti metodi:

Metodo 1: Usare Outlook sul web per accedere all'elenco contatti

In Outlook sul web aggiungere la cartella pubblica a Preferiti e quindi accedere all'elenco contatti. Per accedere all'elenco dei contatti, selezionare l'icona Persone, espandere Cartelle pubbliche e quindi selezionare la cartella Contatti pubblica.

Metodo 2: Usare Outlook in modalità cache

Nota: Outlook recupererà le informazioni dal file di dati locale (con estensione ost) in modalità Cached Exchange.

  1. Scaricare le cartelle pubbliche in modalità Cached Exchange.
  2. Aggiungere cartelle pubbliche a Preferiti in Outlook e quindi accedere all'elenco contatti.

Metodo 3: usare lo strumento MFCMAPI per dividere l'elenco dei contatti

Usare lo strumento MFCMAPI per dividere l'elenco dei contatti. Riprovare quindi ad accedere all'elenco dei contatti.

  1. Avviare lo strumento MFCMAPI.

  2. Select Session>Accesso.

  3. Fare doppio clic su Cartelle pubbliche, espandere l'elenco IPM_SUBTREE e quindi fare doppio clic sulla cartella pubblica con l'elenco dei contatti.

  4. Selezionare l'elenco contatti e quindi selezionare Azioni>Esporta messaggio.

  5. Esportare l'elenco dei contatti nel formato FILE MSG (UNICODE), ad esempio Brokenlist.msg.

    Screenshot dell'esportazione dell'elenco contatti con il formato di file MSG.

  6. Fare doppio clic per aprire l'elemento esportato e modificare l'elenco dei contatti. Rimuovere alcuni membri dall'elenco contatti e modificare il nome dell'elenco , ad esempio Splitlist.msg.

  7. Fare doppio clic sulla cartella pubblica nell'elenco IPM_SUBTREE e quindi selezionareImportazione>cartelle>da MSG per importare l'elenco dei contatti aggiornati.

Per modificare i contatti rimanenti nell'elenco dei contatti, ripetere i passaggi da 4 a 7.