Errore "DestinationADNotUpToDatePermanentException" in una richiesta di migrazione della cassetta postale di cartelle pubbliche

Sintomi

In un batch di migrazione di cartelle pubbliche viene visualizzata una richiesta di migrazione della cassetta postale di cartelle pubbliche non riuscita con il tipo di errore "DestinationADNotUpToDatePermanentException".

Screenshot degli errori dettagliati.

Quando si tenta di rimuovere la richiesta di migrazione della cassetta postale della cartella pubblica non riuscita, viene visualizzato il messaggio di errore seguente:

Impossibile trovare una richiesta univoca con le informazioni fornite.

Causa

Questo problema si verifica se la richiesta di migrazione della cassetta postale delle cartelle pubbliche è orfana o duplicata.

Risoluzione

Per risolvere questo problema, identificare e rimuovere le richieste di migrazione delle cassette postali di cartelle pubbliche orfane o duplicate eseguendo questo script. Se lo script non funziona, seguire questa procedura:

  1. Connettersi a PowerShell per Exchange Online.

  2. Identificare le richieste di migrazione delle cassette postali di cartelle pubbliche duplicate eseguendo il cmdlet seguente:

    Get-PublicFolderMailboxMigrationRequest|Sort-Object targetmailbox|ft targetmailbox,requestguid,name,status
    

    Nota: Per altre informazioni su questo cmdlet, vedere Get-PublicFolderMailboxMigrationRequest.

    Ecco un esempio dell'output:

    Screenshot delle richieste di migrazione duplicate.

  3. Rimuovere la richiesta di migrazione della cassetta postale delle cartelle pubbliche non riuscita eseguendo il cmdlet seguente:

    Remove-PublicFolderMailboxMigrationRequest -Identity "<RequestGuid>" -Force
    

    Nota: Sostituire <RequestGuid> con il risultato effettivo ottenuto dal cmdlet nel passaggio 2. Per altre informazioni sul cmdlet, vedere Remove-PublicFolderMailboxMigrationRequest.

Ulteriori informazioni

Sia i processi integri che i processi duplicati hanno lo stesso nome che contiene il GUID della cassetta postale di destinazione. La formattazione del nome è PublicFolderMailboxMigration<TargetMailboxGuid>. Ad esempio, PublicFolderMailboxMigration058553ac-200f-4fba-91c4-300e4fa0e8e5. Sia i processi integri che i processi duplicati puntano alla stessa cassetta postale di destinazione e le relative identità sono le stesse.

Tuttavia, il completamento di un batch di migrazione non è correlato ai processi duplicati perché il batch non considera i processi duplicati come parte della migrazione. Solo i processi con gli utenti di migrazione attiva corrispondenti vengono considerati appartenenti a una migrazione. Sia un utente di migrazione attivo che una richiesta di migrazione sono connessi tramite il RequestGuid parametro . Pertanto, i processi duplicati non hanno utenti di migrazione attivi corrispondenti che fanno parte di una migrazione.

In questo caso, è consigliabile rimuovere i processi orpahned o duplicati usando il RequestGuid parametro .

Ecco un esempio per illustrare questo punto. Nell'output del cmdlet Get-PublicFolderMailboxMigrationRequest (come illustrato nello screenshot 1), viene visualizzato lo stato dei singoli processi in un batch di migrazione di cartelle pubbliche e vengono visualizzati processi duplicati che puntano alle stesse cassette postali di destinazione dei processi integri. Nell'output del cmdlet Get-MigrationUser (come illustrato nello screenshot 2) vengono visualizzate le informazioni degli utenti della migrazione, ma non viene visualizzato alcun stato di errore per le cassette postali di destinazione a cui puntano i processi duplicati.

Screenshot 1:

Screenshot dei processi di migrazione duplicati.

Screenshot 2:

Screenshot dello stato utente della migrazione.