Cassetta postale della cartella pubblica non trovata in un ambiente multi-geografico
Sintomi
In qualità di amministratore di Microsoft Exchange, quando si tenta di recuperare o modificare una cartella pubblica in un tenant multi-geografico di Exchange, viene visualizzato un messaggio di errore simile al seguente:
La cassetta postale '
<mailbox GUID>
' non viene trovata nella foresta locale. Connettersi alla foresta corretta usando ConnectionUri comehttps://outlook.office365.com/powershell-liveid?email=<mailbox email address>
durante l'esecuzione di New-PSSession.
Quando si tenta di creare una cartella pubblica, viene visualizzato un messaggio di errore simile al seguente:
Non esistono cartelle pubbliche nell'organizzazione. Prima di creare una cartella pubblica, assicurarsi di aver creato almeno una cassetta postale di cartelle pubbliche. Per creare una cartella pubblica, fare clic su 'Aggiungi' +. Dopo aver creato la cartella pubblica, sarà necessario assegnare le autorizzazioni in modo che gli utenti possano accedervi e creare sottocartelle.
Causa
La cassetta postale dell'account amministratore e la cassetta postale per la cartella pubblica con cui si sta tentando di lavorare si trovano in posizioni geografiche diverse. L'interfaccia di amministrazione di Exchange non supporta l'accesso alle cassette postali delle cartelle pubbliche che si trovano in una posizione geografica diversa da quella in cui si trova la cassetta postale dell'account amministratore. Se si usa Exchange Online PowerShell, potrebbe non essere stata connessa la sessione di PowerShell alla cassetta postale delle cartelle pubbliche.
Nota
Una posizione geografica può contenere più foreste. Le foreste sono specifiche di una posizione geografica. Il problema può verificarsi anche se la cassetta postale amministratore e la cassetta postale della cartella pubblica si trovano nella stessa posizione geografica, ma in foreste diverse.
Risoluzione
Per gestire una cassetta postale di cartelle pubbliche esistente in una posizione geografica diversa da quella in cui si trova la cassetta postale dell'account amministratore, seguire questa procedura:
Connettersi a Exchange Online PowerShell per ottenere l'indirizzo SMTP primario della cassetta postale della cartella pubblica. I passaggi di connessione funzionano indipendentemente dal fatto che l'autenticazione a più fattori (MFA) sia abilitata:
Caricare il modulo Exchange Online PowerShell eseguendo il comando seguente in una finestra di PowerShell:
Import-Module ExchangeOnlineManagement
Connettersi a Exchange Online PowerShell usando l'autenticazione moderna:
Connect-ExchangeOnline
Quando viene richiesto, immettere la password per l'account amministratore. Se l'account ha abilitato l'autenticazione a più fattori, è necessario immettere anche un codice di sicurezza.
Ottenere l'indirizzo SMTP primario della cassetta postale della cartella pubblica usando il cmdlet Get-Mailbox . Se il messaggio di errore specifica il GUID della cassetta postale, eseguire il comando seguente:
Get-Mailbox -PublicFolder '<mailbox GUID>' | fl PrimarySmtpAddress
Se il messaggio di errore non specifica il GUID della cassetta postale, eseguire i comandi seguenti per eseguire una query sulla cassetta postale della cartella pubblica radice:
$mailboxGuid = (Get-OrganizationConfig).RootPublicFolderMailbox.HierarchyMailboxGuid.Guid Get-Mailbox -PublicFolder $mailboxGuid | fl PrimarySmtpAddress
Aprire una sessione di PowerShell Exchange Online che si connette alla cassetta postale per la cartella pubblica con cui si sta tentando di usare:
Connettersi a Exchange Online PowerShell usando un stringa di connessione che specifica l'indirizzo SMTP primario della cassetta postale della cartella pubblica ottenuta nel passaggio 1:
Connect-ExchangeOnline -UserPrincipalName <admin mailbox> -ConnectionUri https://outlook.office365.com/powershell?email=<mailbox smtp address>
Ad esempio, se l'account amministratore è
admin@contoso.onmicrosoft.com
e l'indirizzo SMTP della cassetta postale della cartella pubblica èPFMBX1_3f15ace7@contoso.onmicrosoft.com
, eseguire il comando seguente:Connect-ExchangeOnline -UserPrincipalName admin@contoso.onmicrosoft.com -ConnectionUri https://outlook.office365.com/powershell?email=PFMBX1_3f15ace7@contoso.onmicrosoft.com
Quando viene richiesto, immettere la password per l'account amministratore. Se l'account ha abilitato l'autenticazione a più fattori, è necessario immettere anche un codice di sicurezza.
Ripetere il comando che crea, recupera o modifica una cartella pubblica.
Ulteriori informazioni
Per controllare la posizione geografica e la foresta della cassetta postale amministratore, eseguire il comando seguente:
Get-Mailbox <admin mailbox> | select MailboxLocations
Nell'output di esempio seguente identifica
eurprd07
la posizione geografica e la foresta della cassetta postale di amministrazione. La posizione geografica è l'Europa. La foresta all'interno di tale posizione geografica è indicata da07
.MailboxLocations: {1; 1bfe328f-3be7-4262-a19d-9b136f993e88; Primario; eurprd07.prod.outlook.com; 40169cc4-ad05-42a4-a9cb-c49427346652}
Per controllare la posizione geografica e la foresta della cassetta postale delle cartelle pubbliche, eseguire il comando seguente:
Get-Mailbox -PublicFolder '<mailbox GUID>' | select MailboxLocations
Nell'output di esempio seguente identifica
namprd07
la posizione geografica e la foresta. La posizione geografica è America del Nord. La foresta all'interno di tale posizione geografica è indicata da09
.MailboxLocations: {1; b97dc6ee-4f88-4ff1-ab66-df87fe274b79; Primario; namprd09.prod.outlook.com; 1dac0c0d-7de1-476e-a2f5-e080237a3091}
Per controllare la posizione geografica predefinita dell'organizzazione, eseguire il cmdlet Get-OrganizationConfig come indicato di seguito:
Get-OrganizationConfig | fl DefaultMailboxRegion
La cassetta postale dell'account amministratore e la cassetta postale della cartella pubblica potrebbero trovarsi in una diversa posizione geografica o foresta se:
Exchange Server Online ha eseguito uno spostamento della cassetta postale di cartelle pubbliche tra foreste per il bilanciamento del carico.
Un amministratore dell'organizzazione ha richiesto la migrazione dei dati a un'area geografica del data center locale.
Un amministratore dell'organizzazione ha eseguito una migrazione di cartelle pubbliche non supportata a una posizione geografica satellite.
Per altre informazioni su come gestire le cassette postali Exchange Online in un ambiente multi-geografico, vedere Connettersi a una posizione geografica in Exchange Online PowerShell.
Commenti e suggerimenti
https://aka.ms/ContentUserFeedback.
Presto disponibile: Nel corso del 2024 verranno gradualmente disattivati i problemi di GitHub come meccanismo di feedback per il contenuto e ciò verrà sostituito con un nuovo sistema di feedback. Per altre informazioni, vedereInvia e visualizza il feedback per