Condividi tramite


Errore "Impossibile trovare il database" quando si eseguono cmdlet per una cassetta postale ospitata in un'area di Exchange Online diversa

Sintomi

Si supponga di essere un amministratore dell'account. Quando si tenta di eseguire il New-MailboxSearchcmdlet , Search-MailboxAuditLog, New-MailboxImportRequesto New-MailboxRestoreRequest per una cassetta postale ospitata in un'area diversa dall'area dell'account, si riceve uno dei messaggi di errore seguenti:

Impossibile trovare il database "<database>". Assicurarsi di averlo digitato correttamente.

Non è possibile connettersi alla cassetta postale del GUID <> del database cassette postali dell'utente perché l'oggetto ExchangePrincipal contiene informazioni obsolete. La cassetta postale potrebbe essere stata spostata di recente.

Tuttavia, in questo scenario è possibile eseguire le azioni seguenti:

  • È possibile eseguire correttamente questi cmdlet per una cassetta postale ospitata nella stessa area dell'area dell'account.
  • È possibile eseguire correttamente altri cmdlet, ad Set-CalendarProcessing esempio o Get-Mailbox, per le cassette postali ospitate in un'area diversa.

Causa

Questi cmdlet hanno esito negativo per le cassette postali che si trovano in un'area diversa dall'area in cui si trova l'account amministratore. Un account amministratore può avere una cassetta postale in una determinata area oppure un account utente abilitato alla posta elettronica che può connettersi alle cassette postali di arbitrato nell'area predefinita.

Soluzione alternativa

Per risolvere questo problema, è possibile forzare una connessione a un'altra area modificando il valore del ConnectionUri parametro quando si usa il New-PSSession cmdlet . Ad esempio, è possibile eseguire il cmdlet seguente:

New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid?email=alias@contoso.com-Credential $UserCredential -Authentication Basic -AllowRedirection

L'indirizzo di posta elettronica aggiunto nel ConnectionUri parametro deve essere per una cassetta postale che si trovi nell'area per cui si vuole eseguire il New-MailboxSearchcmdlet , Search-MailboxAuditLog, New-MailboxImportRequesto New-MailboxRestoreRequest .

Ad esempio, se la cassetta postale si trova nell'area unione europea e si vuole eseguire il cmdlet su una cassetta postale nell'area Stati Uniti, è necessario individuare una cassetta postale nell'area Stati Uniti (può essere qualsiasi cassetta postale in tale area) e quindi aggiungere l'indirizzo di posta elettronica di tale cassetta postale al ConnectionUri parametro . Per poter eseguire questa operazione, non è necessario disporre di autorizzazioni speciali per la cassetta postale Stati Uniti. L'aggiunta dell'indirizzo di posta elettronica forza la connessione nell'area Stati Uniti. In questo modo i cmdlet possono essere eseguiti correttamente per una cassetta postale di Stati Uniti.