Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Numero KB originale: 4462988
Sintomi
Quando si usa l'account per inviare una richiesta api REST di Outlook, è possibile che venga visualizzato il messaggio di errore seguente:
Errore HTTP: 404
Codice errore: MailboxNotEnabledForRESTAPI o MailboxNotSupportedForRESTAPI
Messaggio di errore: "L'API REST non è ancora supportata per questa cassetta postale".
Causa
Questo errore può verificarsi se la cassetta postale si trova in un server Microsoft Exchange dedicato e non è una cassetta postale di Microsoft 365 valida.
Risoluzione
Per ottenere una cassetta postale di Microsoft 365 valida, inviare una richiesta all'amministratore di Exchange per eseguire la migrazione dell'account della cassetta postale. Gli utenti che non dispongono delle autorizzazioni di amministratore non possono eseguire la migrazione degli account. Per informazioni su come eseguire la migrazione dell'account della cassetta postale, vedere Come eseguire la migrazione dei dati delle cassette postali tramite l'interfaccia di amministrazione di Exchange in Microsoft 365.
Ulteriori informazioni
L'API REST di Outlook include i subset seguenti per abilitare l'accesso ai dati delle cassette postali in Microsoft 365, Hotmail.com, Live.com, MSN.com, Outlook.com e Passport.com.
- Invio in batch di più chiamate API
- API Calendario
- API Contatti
- API Estensioni dati
- API Delle proprietà estese
- API Di posta elettronica
- API Notifiche push
- API Notifiche di streaming (anteprima)
- People API
- API attività
- API Foto utente
Per altre informazioni, vedere Usare l'API REST di Outlook (versione 2.0).