Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Sintomi
L'autenticazione non riesce automaticamente in alcune applicazioni di Microsoft Office e Outlook può passare allo stato "Password necessaria" senza alcuna interazione. Inoltre, quando si effettua una chiamata API Gestione account Web a FindAllAccountsAsync, è possibile che venga visualizzato il codice di errore "-2147024809" nei registri Microsoft Entra o nei registri Client Office.
Importante
Questo problema si verifica solo sui computer che eseguono Windows 10, versione 1703 o successiva e Microsoft 365, versione 1807 o successiva.
Causa
Il problema di autenticazione si verifica a causa di informazioni mancanti nel pacchetto di Active Directory Authentication Library (ADAL) o di Live ID.
Risoluzione
Consiglio
Per diagnosticare e risolvere automaticamente diversi problemi comuni di accesso a Office, è possibile scaricare ed eseguire l'Assistente supporto e ripristino Microsoft.
Per risolvere questo problema, utilizzare PowerShell per reinstallare i pacchetti per il plugin WAM di Microsoft Entra (per gli account aziendali o degli istituti di istruzione) e Live ID (per gli account personali come @outlook.com, @hotmail.com e così via). A tal fine, attenersi alla seguente procedura:
Fare clic con il pulsante destro del mouse sull'icona di Windows nella barra delle applicazioni, quindi selezionare Windows PowerShell (Amministratore).
Se viene presentata una richiesta da una finestra Controllo dell'account utente (UAC), selezionare Sì per avviare PowerShell.
Se il problema riguarda un account aziendale, è necessario correggere il pacchetto del plugin WAM di Microsoft Entra. Eseguire il seguente comando nella console dei comandi:
if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
Se il problema riguarda un account personale, è necessario correggere il pacchetto Live ID. Eseguire il seguente comando nella console dei comandi:
if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
Dopo aver eseguito i comandi e se questi sono stati completati senza errori, è possibile che venga visualizzato un indicatore di avanzamento rapido o un risultato di stato contenente informazioni sull'installazione del pacchetto.