Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo risolve un problema nel codice VBA che impedisce la compilazione di un database o un progetto o un riferimento.
Numero KB originale: 283788
Note
Richiede competenze di base di macro, codifica e interoperabilità. Questo articolo si applica a un database Microsoft Access (.mdb/.accdb) e a un progetto di Microsoft Access (con estensione adp).
Symptoms
Quando si tenta di salvare un database Microsoft Access come file ACCDE o MDE, è possibile che venga visualizzato il messaggio di errore seguente e il file ACCDE non venga creato.
Microsoft Access non è stato in grado di creare il file .accde, .mde o .ade.
Quando si tenta di salvare un database Microsoft Access come file MDE, è possibile che venga visualizzato il messaggio di errore seguente e il file MDE non viene creato.
Microsoft Access non è stato possibile creare un database MDE.
Quando si tenta di salvare un progetto di Microsoft Access come file ADE, è possibile che venga visualizzato il messaggio di errore seguente e che il file DIE non venga creato.
Microsoft Access non è stato in grado di creare un database ADE.
Cause
È possibile che venga visualizzato questo messaggio di errore se una delle condizioni seguenti è vera:
- Si è verificato un errore nel codice Visual Basic, Applications Edition che impedisce la compilazione del database o del progetto.
- È presente un riferimento a un database di Access (.mdb/.accdb) o a un progetto di Access (con estensione adp).
Resolution
- Correggere eventuali problemi nel codice che impediscono di compilare il database o il progetto.
- Rimuovere tutti i riferimenti ai file .mdb, accdb e adp.
Se è necessario mantenere un riferimento a un file .mdb, accdb o adp, convertire il file in un file MDE, ACCDE o ADE e quindi creare un riferimento al nuovo file. È ora possibile convertire il database o il progetto in un file MDE, ACCDE o ADE.
Passaggi per riprodurre il comportamento
Creare un nuovo database .
Premere ALT+F11 per aprire l'editor Visual Basic.
Scegliere Modulo dal menu Inserisci.
Digitare il codice seguente:
Sub Generate_Compile_Error() MsgBoxx "This will cause an error" End SubScegliere Salva nomeprogetto dal menu File.
Premere ALT+F11 per tornare a Microsoft Access.
Scegliere Utilità database dal menu Strumenti e quindi fare clic su Crea file MDE.