Condividi tramite


I client di Outlook si disconnettono ripetutamente da e si riconnettono a Exchange Server 2013

Numero KB originale: 2962915

Sintomi

Si verificano uno o più dei sintomi seguenti in Exchange Server 2013.

Sintomo 1

Il client Outlook 2013, il client outlook 2010 o outlook 2007 si disconnette dal server che esegue Exchange Server 2013. Poco dopo la disconnessione, il client si riconnette al server Exchange. Questo comportamento continua ripetutamente.

Sintomo 2

L'oggetto MSExchangeRpcProxyAppPool viene riciclato continuamente. In Visualizzatore eventi in Registri applicazioni e servizi\Microsoft\Exchange\ActiveMonitoring nel log ProbeResult vengono visualizzati errori di risultati del probe per il servizio Outlook per database 2013 diversi che indicano il valore StoreError=UnknownUser.

Nella visualizzazione Dettagli nella voce del log viene visualizzata questa riga:

Microsoft.Exchange.Data.Storage.DatabaseNotFoundException: impossibile trovare il database con GUID> ID <

Le parti rilevanti dell'evento di errore sono le seguenti:

Nome log: Microsoft-Exchange-ActiveMonitoring/ProbeResult
Origine: Microsoft-Exchange-ActiveMonitoring
Date: DateTime
ID evento: 2
Categoria attività: risultato del probe
Livello: Errore
Parole chiavi:
Utente: SISTEMA
Computer: CAS.contoso.com
Descrizione:
Xml evento:
<ServiceName>Outlook</ServiceName>
<IsNotified>0</IsNotified>
<ResultName>OutlookMailboxCtpProbe/2013 Mailbox Database 1</ResultName>
<WorkItemId>121</WorkItemId>
<DeploymentId>0</DeploymentId>
<MachineName>CAS1</MachineName>
<Errore>restituito in ConnectCallResult. Codice di errore = UnknownUser (0x000003EB)</Error>
<Errore>restituito in ConnectCallResult. Codice di errore = UnknownUser (0x000003EB)</Error>
<Eccezione>Microsoft.Exchange.RpcClientAccess.RopExecutionException: errore restituito in ConnectCallResult. Codice di errore = UnknownUser (0x000003EB) ---> System.Exception: Microsoft.Exchange.RpcClientAccess.Server.UnknownUserException: Impossibile eseguire il mapping di userDn '/o=First Organization/ou=Monitoring Mailboxes/cn=Recipients/cn=HealthMailboxcaea01e2cff446d1b0645f01d11fb55f' a exchangePrincipal (StoreError=UnknownUser) --- Microsoft.Exchange.Data.Storage.DatabaseNotFoundException: impossibile trovare il database con ID <GUID> database sconosciuto.

Sintomo 3

Il MSExchangeRpcProxyAppPool pool di applicazioni viene riciclato continuamente come nel cas. Nel log di sistema potrebbero essere registrati anche gli eventi 7031 e 7032, come indicato di seguito:

Ora: DateTime
ID: 7031
Livello: Errore
Origine: Service Control Manager
Computer: <nome server MBX 2013>
Messaggio: il servizio Accesso client RPC di Microsoft Exchange è terminato in modo imprevisto. L'operazione è stata eseguita una o più volte. L'azione correttiva seguente verrà eseguita in 5000 millisecondi: Riavviare il servizio.
Ora: DateTime
ID: 7032
Livello: Errore
Origine: Service Control Manager
Computer: MachineName
Messaggio: Gestione controllo servizi ha tentato di eseguire un'azione correttiva (Riavviare il servizio) dopo la chiusura imprevista del servizio Accesso client RPC di Microsoft Exchange, ma questa azione non è riuscita con l'errore seguente:
%%1056

Nota

Questa voce di log indica che il servizio Accesso client RPC viene terminato in modo imprevisto.

Sintomo 4

Nel server MBX di Exchange 2013, in Visualizzatore eventi in Registri applicazioni e servizi\Microsoft\Exchange\ActiveMonitoring nel log ProbeResult, vengono visualizzati gli eventi di errore dei risultati del probe per il servizio Outlook.Protocol per i diversi database 2013 che indicano il valore StoreError=UnknownUser.

Nella visualizzazione Dettagli nella voce del log viene visualizzata la riga seguente:

Microsoft.Exchange.Data.Storage.DatabaseNotFoundException: impossibile trovare il database con GUID> ID <

Le parti rilevanti dell'evento di errore sono le seguenti:

Nome log: Microsoft-Exchange-ActiveMonitoring/ProbeResult
Origine: Microsoft-Exchange-ActiveMonitoring
Date: DateTime
ID evento: 2
Categoria attività: risultato del probe
Livello: Errore
Parole chiavi:
Utente: SISTEMA
Computer: mailbox1.contoso.com
Descrizione:
Risultato probe (Name=OutlookSelfTestProbe)
Xml evento:
<ServiceName>Outlook.Protocol</ServiceName>
<IsNotified>0</IsNotified>
<ResultName>OutlookSelfTestProbe</ResultName>
<WorkItemId>60</WorkItemId>
<DeploymentId>0</DeploymentId>
<MachineName>MAILBOX2</MachineName>
<Errore>restituito in ConnectCallResult. Codice di errore = UnknownUser (0x000003EB)</Eccezione>di errore><Microsoft.Exchange.RpcClientAccess.RopExecutionException: errore restituito in ConnectCallResult. Codice di errore = UnknownUser (0x000003EB) ---> System.Exception: Microsoft.Exchange.RpcClientAccess.Server.UnknownUserException: Impossibile eseguire il mapping di userDn '/o=First Organization/ou=Monitoring Mailboxes/cn=Recipients/cn=HealthMailbox147dc27242bb4da4acd5d94cf214934b' per exchangePrincipal (StoreError=UnknownUser) ---> Microsoft.Exchange.Data.Storage.DatabaseNotFoundException: impossibile trovare il database con ID <GUID> database sconosciuto.

Causa

Questo problema si verifica perché un database di cartelle pubbliche a cui una o più cassette postali di Exchange 2013 puntano come impostazione predefinita del database delle cartelle pubbliche è stata eliminata in Modifica ADSI. Il GUID del database sconosciuto indicato nei dettagli della voce di log è quello del database di cartelle pubbliche eliminato.

È possibile verificare questo problema eseguendo il comando seguente:

Get-MailboxDatabase | FL name,PublicFolderDatabase

L'output generato da questo comando è simile al seguente:

Name : 2013 Mailbox Database
PublicFolderDatabase : Contoso.com/Configuration/Deleted Objects/Public FolderDatabaseDEL:<GUID>

Nota

Questo output indica che uno o più database delle cassette postali di Exchange 2013 puntano a un oggetto cartella pubblica che si trova nel contenitore Oggetto eliminato in Active Directory Domain Services (AD DS).

Risoluzione - Metodo 1

Avviso

Se si usa lo snap-in Modifica ADSI, l'utilità LDP o qualsiasi altro client LDAP versione 3 e si modificano in modo errato gli attributi degli oggetti Active Directory, è possibile che si verifichino problemi seri. Per questi problemi potrebbe essere necessario reinstallare Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 o Windows ed Exchange. Microsoft non può garantire che i problemi che si verificano se si modificano in modo errato gli attributi dell'oggetto Active Directory possano essere risolti. Modificare questi attributi a proprio rischio.

Se non si usano database di cartelle pubbliche legacy o si lavora in un ambiente Exchange 2013 puro, rimuovere l'impostazione predefinita del database delle cartelle pubbliche in ogni database cassette postali di Exchange 2013 che punta all'oggetto di database delle cartelle pubbliche eliminato.

A tale scopo, connettersi a CN=Configuration in ADSI Edit e quindi passare a questo percorso:

Domain.com/Configuration/Services/Microsoft Exchange/Org/Administrative Groups/Exchange Administrative Group (FYDIBOHF23SPDLT)/Databases

Cancellare il valore msExchHomePublicMDB in modo che venga letto come <non impostato>.

Risoluzione - Metodo 2

Se si è in un ambiente di coesistenza di Exchange che include Exchange 2013 e si sta ancora connettendo a database di cartelle pubbliche legacy (che non usano cartelle pubbliche di Exchange 2013), è possibile impostare il database delle cartelle pubbliche predefinito su un database di cartelle pubbliche legacy di Exchange 2010 o Exchange 2007 valido. A tale scopo, eseguire il comando seguente in Exchange Management Shell:

Set-MailboxDatabase <Exchange MDB> -PublicFolderDatabase <Legacy Public Folder DB to use>