Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Numero KB originale: 4483878
Sintomi
Considerare lo scenario descritto di seguito:
- Si usa un componente aggiuntivo di Office.
- Il componente aggiuntivo esegue chiamate rest (Representational State Transfer) o servizi Web Exchange (EWS) rispetto all'ID elemento di un elemento di Outlook.
- Le chiamate possono essere effettuate dall'applicazione front-end di Office o dal back-end.
In questo scenario, le chiamate di trasferimento hanno esito negativo e Outlook genera un errore ErrorItemNotFound .
Causa
Quando Outlook è in modalità Cached Exchange, l'ID elemento fornito tramite l'API Office JavaScript Office.context.mailbox.item.itemId è obsoleto o non è ancora aggiornato nel server.
Ulteriori informazioni
Questo problema si verifica negli scenari seguenti:
Mentre un messaggio di posta elettronica è aperto in una finestra di Outlook desktop separata, si sposta il messaggio in una cartella diversa in un'altra applicazione Outlook. Ad esempio, si sposta il messaggio in Outlook Web Access (OWA) o Microsoft Outlook per iOS e Android. Tornare quindi all'applicazione desktop Outlook e usare un componente aggiuntivo di Office che usa un'API
ItemID
.In questo caso, l'ID elemento originale non è più valido. Pertanto, quando il componente aggiuntivo di Office tenta di accedere al messaggio di posta elettronica tramite servizi Web, viene visualizzato un messaggio di errore ErrorItemNotFound che indica che l'operazione non può essere completata perché il messaggio è stato spostato o eliminato.
Un messaggio di posta elettronica viene archiviato, eliminato o spostato in un'altra cartella. Poco tempo dopo si usa un componente aggiuntivo di Office che usa un'API
ItemID
in Outlook.In questo caso, Outlook fornisce l'ID elemento aggiornato. Tuttavia, il server potrebbe non avere l'ID fino a quando Outlook non si sincronizza con il server. Quando Outlook funziona online, la sincronizzazione è in genere rapida. In alcuni casi, tuttavia, il completamento del processo può richiedere più tempo.
Nota
Anche la creazione di regole di posta in arrivo in Outlook può contribuire a questo scenario.
Per altre informazioni sulle modifiche apportate all'ID elemento dei servizi Web quando viene spostato un messaggio di posta elettronica, vedere la sezione Utilizzo degli identificatori in Identificatori EWS in Exchange.