Panoramica sulle query in Power BI Desktop

Con Power BI Desktop è possibile connettersi a un mondo di dati, creare report efficaci e fondamentali e condividere il proprio impegno con altri utenti, che potranno quindi basarsi sul lavoro già svolto ed espandere le proprie attività di business intelligence.

Visualizzazioni di Power BI Desktop

Power BI Desktop offre tre visualizzazioni:

  • Visualizzazione report: è possibile utilizzare le query da te create per sviluppare visualizzazioni accattivanti, organizzate secondo le tue preferenze, e con più pagine, che si possono condividere con altri.
  • Visualizzazione tabella – Consente di visualizzare i dati nel report in formato modello di dati, dove è possibile aggiungere misure, creare nuove colonne e gestire le relazioni.
  • Visualizzazione modello: permette di ottenere una rappresentazione grafica delle relazioni stabilite nel modello di dati e gestirle o modificarle in base alle esigenze.

Per accedere a queste visualizzazioni, selezionare una delle tre icone lungo il lato sinistro di Power BI Desktop. Nella figura seguente è selezionata la visualizzazione Report, indicata dalla striscia di colore giallo accanto all'icona.

Screenshot di Power BI Desktop che mostra la vista Report selezionata.

Insieme a Power BI Desktop è disponibile anche l'editor di Power Query. Con questo editor è possibile connettersi a una o più origini dati, eseguire il data shaping e trasformare i dati in base alle esigenze, quindi caricare il modello in Power BI Desktop.

Questo articolo offre una panoramica dell'uso dei dati nell'editor di Power Query, ma sono disponibili altre informazioni. Alla fine di questo articolo sono disponibili collegamenti a indicazioni dettagliate sui tipi di dati supportati. Sono anche disponibili altre informazioni sulla connessione ai dati, sul data shaping, sulla creazione di relazioni e su come iniziare.

Prima di tutto, è possibile acquisire familiarità con l'editor di Power Query.

Editor di Power Query

Power BI Desktop offre due esperienze editor di Power Query:

  • Nuova esperienza di Power Query (anteprima): editor riprogettato con spostamento semplificato, accessibilità migliorata e un'esperienza di Power Query coerente in Power BI Desktop, modellazione Web e altri prodotti Fabric.
  • Esperienza precedente: la finestra originale dell'Editor di Power Query.

In entrambe le esperienze si usano editor di Power Query per connettersi a una o più origini dati, modellare e trasformare i dati in base alle proprie esigenze e quindi caricare il risultato in Power BI Desktop. Selezionare la scheda corrispondente all'esperienza in uso.

Per limitazioni note, soluzioni alternative e una posizione in cui condividere commenti e suggerimenti, vedere Nuove limitazioni e soluzioni alternative per l'esperienza di Power Query.

Note

La nuova esperienza Power Query è disponibile in anteprima.

Prerequisiti

Power BI Desktop con la funzionalità di anteprima Nuova esperienza di Power Query abilitata.

Per abilitare la nuova esperienza di Power Query:

  1. Avviare Power BI Desktop.
  2. Passare a File>Opzioni e impostazioni>Opzioni.
  3. Selezionare Preview features e quindi selezionare la casella di controllo New Power Query experience.
  4. Seleziona OK.

La stessa funzionalità di anteprima abilita sia la nuova esperienza Recupera dati che la nuova editor di Power Query. Per tornare all'editor legacy, deselezionare la casella di controllo. Non è necessario riavviare Power BI Desktop. Per altre informazioni sulla nuova esperienza Recupera dati, vedere Ottenere dati in Power BI Desktop.

Apri l'editor di Power Query

Per aprire editor di Power Query, selezionare Trasforma dati nella scheda Home di Power BI Desktop.

Senza connessioni dati, l'editor di Power Query appare come un riquadro vuoto, pronto per i dati. Dopo il caricamento di una query, l'editor presenta cinque componenti distinti. I numeri nella tabella seguente corrispondono ai callout numerati nello screenshot.

Screenshot del nuovo editor di Power Query in Power BI Desktop con ogni componente descritto e numerato.

# Componente Descrizione
1 Barra multifunzione Esperienza di navigazione tramite barra multifunzione, che offre diverse schede per aggiungere trasformazioni, selezionare le opzioni della query e accedere ai diversi pulsanti della barra multifunzione per completare varie attività.
2 Riquadro delle query Visualizzazione di tutte le query disponibili.
3 Visualizzazione corrente La visualizzazione di lavoro principale, che per impostazione predefinita mostra un'anteprima dei dati per la query. È anche possibile abilitare la visualizzazione diagramma insieme all'anteprima dei dati. È possibile passare dalla visualizzazione schema all'anteprima dei dati mantenendo la visualizzazione diagramma.
4 Impostazioni della query Visualizzazione della query attualmente selezionata con informazioni pertinenti, ad esempio nome della query, passaggi di query e vari indicatori.
5 Barra di stato Barra che mostra informazioni importanti sulla query, ad esempio il tempo di esecuzione, le colonne totali e le righe e lo stato di elaborazione. Questa barra contiene anche pulsanti per modificare la visualizzazione corrente.

Ognuno di questi componenti è descritto nelle sezioni seguenti. Per una procedura dettagliata completa dell'interfaccia utente Power Query, vedere Usare Power Query per trasformare i dati.

Barra multifunzione

La barra multifunzione è il componente in cui è possibile trovare la maggior parte delle trasformazioni e delle azioni che è possibile eseguire in editor di Power Query. I comandi vengono raggruppati nelle schede Home, Trasforma, Aggiungi colonna, Visualizza, Strumenti e Guida . Ogni scheda fornisce pulsanti e opzioni specifici che consentono di accedere facilmente alle trasformazioni e alle azioni necessarie.

La scheda Home contiene le attività di query comuni, inclusi i comandi Recupera dati usati per connettersi ai dati e avviare il processo di compilazione delle query. Per altre informazioni sulle origini dati disponibili, vedere Origini dati in Power BI Desktop. Per altre informazioni sull'uso dei connettori, vedere Panoramica del recupero dei dati.

La scheda Trasformazione consente di accedere alle attività comuni di trasformazione dei dati, ad esempio l'aggiunta o la rimozione di colonne, la modifica dei tipi di dati e la suddivisione delle colonne. La scheda Aggiungi colonna fornisce altre attività associate all'aggiunta di una colonna, alla formattazione dei dati delle colonne e all'aggiunta di colonne personalizzate. La scheda Visualizza controlla i riquadri e le visualizzazioni visualizzati e apre il Editor avanzato.

L'interfaccia Power Query è reattiva e si adatta alla risoluzione dello schermo. Se si desidera una versione compatta della barra multifunzione, selezionare il pulsante di compressione nell'angolo inferiore destro della barra multifunzione. Per tornare alla barra multifunzione standard, selezionare l'icona di espansione nello stesso angolo.

Molte delle attività disponibili dalla barra multifunzione sono disponibili anche facendo clic con il pulsante destro del mouse su una colonna o su altri dati nella visualizzazione corrente. Le trasformazioni possono spesso essere raggiunte da più posizioni, in modo da poter usare l'esperienza preferita.

Per altre informazioni sulla trasformazione dei dati, inclusi alcuni esempi, vedere Esercitazione: Modellare e combinare dati in Power BI Desktop.

Il riquadro Query

Nel riquadro Query vengono visualizzate tutte le query disponibili. Quando si seleziona una query, i relativi dati vengono visualizzati nella visualizzazione corrente, in cui è possibile modellare e trasformare i dati in base alle proprie esigenze.

Selezionare l'icona nell'angolo superiore destro del riquadro Query per comprimere il riquadro e selezionarlo di nuovo per espandere il riquadro. Icone simili nell'interfaccia consentono di comprimere o espandere altre visualizzazioni e sezioni, in modo da poter concentrarsi sulla visualizzazione più importante per te.

Per altre informazioni, vedere Riquadro Query.

Visualizzazione corrente

La visualizzazione corrente è la visualizzazione di lavoro principale. Per impostazione predefinita, mostra l'anteprima dei dati per la query selezionata. In questa area si svolge gran parte delle operazioni relative alla query. Selezionare un'intestazione di colonna oppure fare clic con il pulsante destro del mouse per visualizzare le trasformazioni disponibili per tale colonna. Molti di questi elementi sono gli stessi dei pulsanti nelle schede della barra multifunzione.

Quando si seleziona una trasformazione, la query applica il passaggio ai dati. Inoltre, salva il passaggio come parte della query stessa. Il riquadro Impostazioni query registra i passaggi in ordine sequenziale, come descritto più avanti in questo articolo.

È anche possibile abilitare gli strumenti di profilatura dei dati per comprendere meglio i dati, inclusa la distribuzione dei valori e la qualità delle colonne. Abilitare e disabilitare questi strumenti dalla scheda Visualizza per comodità. Per altre informazioni, vedere Uso degli strumenti di profilatura dei dati.

Passare da una visualizzazione all'altra

Oltre a comprimere i riquadri e le sezioni, è anche possibile scegliere quali visualizzazioni mostrare. Passare alla scheda Visualizza sulla barra multifunzione, in cui sono disponibili i gruppi Anteprima e Layout che controllano l'aspetto dell'interfaccia.

Schermata della scheda Visualizza nel nuovo Editor di Power Query, che mostra i gruppi Anteprima e Layout.

Il lato destro della barra di stato contiene anche icone per le visualizzazioni diagramma, dati e schema. Usare queste icone per passare da una visualizzazione all'altra o per abilitare e disabilitare la visualizzazione desiderata.

Provare queste opzioni per trovare la visualizzazione e il layout con cui si ha più familiarità.

Visualizzazione schema

La visualizzazione schema offre un modo rapido e semplice per interagire solo con i componenti dello schema per la tabella, ad esempio i nomi delle colonne e i tipi di dati. Usare la visualizzazione schema quando si desidera eseguire azioni correlate allo schema, ad esempio la rimozione di colonne, la ridenominazione delle colonne, la modifica dei tipi di dati delle colonne, il riordinamento delle colonne o la duplicazione di colonne.

Screenshot della visualizzazione dello schema nella nuova editor di Power Query, che mostra le colonne Nome, Tipo e Chiave per la query selezionata.

Quando la visualizzazione schema è attiva, la scheda Strumenti schema viene visualizzata nella barra multifunzione con le azioni che si applicano alle colonne.

Per altre informazioni, vedere Uso della visualizzazione Schema.

Visualizzazione diagramma

La visualizzazione diagramma consente di visualizzare il modo in cui la query è strutturata e come potrebbe interagire con altre query nel progetto. Ogni passaggio della query ha un'icona distinta per riconoscere la trasformazione usata e le righe connettono i passaggi per illustrare le dipendenze.

Quando sono abilitate sia l'anteprima dei dati che la visualizzazione diagramma, la visualizzazione diagramma viene visualizzata sopra l'anteprima dei dati. Con la visualizzazione diagramma abilitata, selezionare il segno più per cercare una nuova trasformazione da aggiungere alla query.

Schermata della vista diagramma mostrata sopra l'anteprima dei dati nel nuovo Editor di Power Query.

Per altre informazioni, vedere Visualizzazione diagramma.

Il riquadro delle impostazioni di query

Il riquadro Impostazioni query mostra informazioni sulla query attualmente selezionata, ad esempio il nome della query, i relativi passaggi e vari indicatori. Ogni trasformazione applicata alla query viene salvata come passaggio nella sezione Passaggi applicati .

Se è necessario verificare la modalità di trasformazione della query dal passaggio al passaggio, selezionare un passaggio per visualizzare in anteprima il modo in cui la query viene risolta in quel punto specifico.

È importante sapere che i dati sottostanti non vengono modificati. L'editor di Power Query regola e modella la visualizzazione dei dati.

È possibile rinominare i passaggi, eliminare i passaggi o riordinare i passaggi in base alle esigenze. A tale scopo, fare clic con il pulsante destro del mouse sul passaggio nella sezione Passaggi applicati e scegliere dal menu visualizzato. Selezionare Proprietà per modificare il nome di un passaggio o aggiungervi una descrizione. Tutti i passaggi della query vengono eseguiti nell'ordine in cui vengono visualizzati.

Per altre informazioni, vedi Uso dell'elenco dei passaggi applicati.

Barra di stato

La barra di stato viene visualizzata nella parte inferiore dell'editor e mostra informazioni importanti sulla query, ad esempio il tempo di esecuzione, le colonne totali e le righe e lo stato di elaborazione. Il lato destro della barra di stato contiene anche icone che è possibile usare per modificare la visualizzazione corrente.

Screenshot della barra di stato nella nuova editor di Power Query, che mostra lo stato di elaborazione, il conteggio delle colonne e delle righe e le icone di visualizzazione.

Barra della formula

La barra della formula mostra l'espressione di linguaggio della formula M Power Query per il passaggio selezionato. È possibile modificare l'espressione direttamente nella barra della formula per regolare un singolo passaggio oppure usare il Editor avanzato per usare lo script di query completo.

Come ottenere assistenza

La scheda Guida in editor di Power Query fornisce collegamenti alle informazioni di Power BI. È possibile accedere alle stesse opzioni di guida selezionando File>.

Editor avanzato

L'Editor avanzato consente di visualizzare il codice che l'editor di Power Query sta creando con ogni passaggio Consente anche di creare codice personalizzato nel linguaggio di formula M di Power Query. Per avviare l'editor avanzato, selezionare Visualizza dalla barra multifunzione, quindi selezionare Editor avanzato. Viene visualizzata una finestra che mostra il codice generato per la query selezionata.
Screenshot di Power BI Desktop che mostra la finestra di dialogo Editor avanzato.

È possibile modificare direttamente il codice nella finestra Editor avanzato . Per chiudere la finestra, selezionare il pulsante Fatto o Annulla .

Il Editor avanzato è disponibile sia nella nuova che nell'esperienza legacy. La schermata precedente mostra la versione precedente dell'esperienza. Alcuni controlli e opzioni di visualizzazione di Editor avanzato sono diversi nella nuova esperienza. Per altre informazioni, vedere Limitazioni note e soluzioni alternative della nuova esperienza di Power Query.

Salvare il lavoro

Quando la query è definita nel modo desiderato, selezionare Chiudi e applica dal menu File dell'editor di Power Query. Questa azione ha l'effetto di applicare le modifiche e chiudere l'editor.
Screenshot di Power BI Desktop che mostra l'opzione Chiudi e applica nella scheda File.

Durante l'avanzamento, una finestra di dialogo di Power BI Desktop ne mostra lo stato.
Screenshot di Power BI Desktop che mostra la finestra di dialogo di conferma delle modifiche applicate alla query.

Quando sei pronto, Power BI Desktop può salvare il tuo lavoro in un file con estensione .pbix.

Per salvare il lavoro, selezionare File>Salva (o File>Salva con nome), come illustrato nell'immagine seguente. Screenshot di Power BI Desktop che mostra la scheda File dell'editor di Power Query. Le opzioni *salva* e *salva con nome* evidenziate.

Power BI Desktop offre infinite possibilità. Per altre informazioni sulle capacità disponibili, vedere le risorse seguenti: