Share via


Chiusura del servizio Calendar Connector e registrazione dell'ID evento 5005

 

Ultima modifica dell'argomento: 2009-04-24

In questo argomento vengono fornite informazioni sulla risoluzione dei problemi che possono verificarsi quando si utilizza Microsoft Transporter Suite per garantire l'interoperabilità tra Microsoft Exchange Server 2007 e Lotus Notes.

Dopo avere installato e configurato Microsoft Transporter Suite su un computer su cui è in esecuzione Exchange 2007, possono manifestarsi i seguenti sintomi:

  • Il servizio Calendar Connector viene avviato e quindi subito chiuso.

  • Si riceve il seguente messaggio di errore:

    Il servizio Connettore disponibilità di Microsoft Exchange per Lotus Domino su <NomeServer> è stato avviato e quindi interrotto. Alcuni servizi vengono interrotti automaticamente se sono in uso da altri servizi o programmi.

  • Gli eventi descritti di seguito vengono registrati nel registro applicazioni:

    Origine evento: MSExchangeCalCon

    Categoria evento: Connessione

    ID evento: 5005

    Descrizione: il servizio Calendar Connector non è riuscito a connettersi all'Archivio informazioni pubblico a causa dell'errore MAPI 80004005 e verrà chiuso. Assicurarsi che il servizio Archivio informazioni sia in esecuzione e che il servizio Calendar Connector sia configurato per l'utilizzo dell'account di servizi e della password di Exchange in Gestione controllo servizi prima di riavviare Calendar Connector.

    Origine evento: MSExchangeCalCon

    Categoria evento: Connessione

    ID evento: 5006

    Descrizione: Calendar Connector verrà chiuso a causa di un errore irreversibile.

Causa

Questo problema si verifica se è vera una delle condizioni seguenti:

  • Microsoft Office Outlook 2007 è installato sul server Exchange 2007 sul quale è in esecuzione Microsoft Transporter Suite.

  • L'archivio di informazioni pubblico verrà eliminato o spostato su un altro server Exchange.

Outlook 2007 è supportato su un computer su cui è in esecuzione Exchange 2007. Tuttavia Microsoft Transporter Suite non funziona correttamente quando è installato Outlook 2007. Inoltre, sebbene sia possibile reindirizzare i client MAPI a un archivio di informazioni pubblico alternativo, il servizio Calendar Connector richiede l'accesso all'archivio sul server Exchange locale per eseguire l'inizializzazione.

Soluzione

Per risolvere il problema, utilizzare uno dei seguenti metodi a seconda della situazione.

Metodo 1

Rimuovere Outlook 2007 e installare il client MAPI di Microsoft Exchange Server e il programma Collaboration Data Objects 1.2.1. A questo scopo seguire la procedura descritta:

  1. Utilizzare la funzione Installazione applicazioni nel Pannello di controllo per rimuovere Outlook 2007.

  2. Installare il client MAPI di Microsoft Exchange Server e Collaboration Data Objects 1.2.1 (informazioni in lingua inglese) dall'Area download di Microsoft.

  3. Avviare il servizio Calendar Connector. A questo scopo fare clic su Start, scegliere Esegui, digitare services.msc, quindi scegliere OK. Nello snap-in Servizi fare clic con il pulsante destro del mouse su Calendar Connector, quindi scegliere Avvia.

Metodo 2

Modificare il server Cassette postali per costringere il servizio Calendar Connector a utilizzare l'archivio di informazioni pubblico locale. A questo scopo seguire la procedura descritta:

  1. Avviare Exchange Management Console.

  2. Espandere Configurazione server, quindi selezionare Cassetta postale.

  3. Nel riquadro centrale selezionare la scheda Gestione del database, espandere il gruppo di archiviazione, fare clic con il pulsante destro del mouse su Database delle cassette postali, quindi fare clic su Proprietà.

  4. Selezionare la scheda Impostazioni client, quindi esaminare la voce visualizzata nella casella Database delle cartelle pubbliche predefinito.

  5. Se il database delle cartelle pubbliche predefinito non è situato sul server locale, fare clic su Sfoglia, individuare il database delle cartelle pubbliche sul computer locale, quindi fare clic su OK.

  6. Fare clic su OK.

  7. Avviare il servizio Calendar Connector. A questo scopo fare clic su Start, scegliere Esegui, digitare services.msc, quindi scegliere OK. Nello snap-in Servizi fare clic con il pulsante destro del mouse su Calendar Connector, quindi scegliere Avvia.

Ulteriori informazioni

Per ulteriori informazioni, vedere Risorse per l'interoperabilità e la migrazione da Lotus Domino.