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Si è verificato un problema durante la comunicazione con il server Microsoft Dynamics CRM durante la configurazione di Microsoft Dynamics CRM per Outlook

Questo articolo fornisce una soluzione per assicurarsi che Microsoft Dynamics CRM per Outlook possa essere installato senza errori durante la fase inizializzazione dell'organizzazione del processo di configurazione.

Si applica a: Microsoft Dynamics CRM 2011, Microsoft Dynamics CRM Mobile, Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2015
Numero KB originale: 2714083

Sintomi

Quando si tenta di configurare l'Microsoft Dynamics CRM per Microsoft Office Outlook, un utente riceve l'errore seguente durante la fase inizializzazione dell'organizzazione del processo di configurazione:

Si è verificato un problema durante la comunicazione con il server Microsoft Dynamics CRM. È possibile che il server non sia disponibile. Se il problema persiste, contattare l'amministratore di sistema

o

Impossibile configurare l'organizzazione per Microsoft Dynamics CRM per Outlook. Provare a configurare nuovamente l'organizzazione. Se il problema persiste, contattare l'amministratore di sistema

Quando si seleziona Dettagli, vengono visualizzati i dettagli aggiuntivi seguenti:

È stato già aggiunto un elemento con la stessa chiave.
in Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()
in Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
in Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)

Causa

Questo problema è causato da voci duplicate della mappa del sito nel file XML della mappa del sito relative al <tag Id SubArea>. Una voce duplicata del sitemap a volte conterrà un carattere finale (1) alla fine del titolo, come illustrato nello screenshot seguente.

Screenshot mostra una voce duplicata nella mappa del sito che a volte contiene

Tuttavia, è anche possibile riscontrare questo errore senza visualizzare un nome di entità duplicato nell'interfaccia utente del client Web. Al contrario, il problema può verificarsi anche quando il <tag SubArea Id> fa riferimento allo stesso nome, mentre il parametro Entity è diverso, come evidenziato di seguito:

<SubArea Id="new_entity" Entity="new_entity"/>

<SubArea Id="new_entity" Entity="new_otherentity"/>

Risoluzione

Per risolvere il problema, seguire questa procedura:

  1. In Microsoft Dynamics CRM selezionare Impostazioni e quindi Soluzioni.

  2. Selezionare Nuovo. Immettere un nome visualizzato appropriato, un nome, un editore e una versione. Selezionare Salva.

  3. Selezionare Aggiungi esistente e selezionare Mappa del sito.

  4. Seleziona Salva e quindi seleziona Esporta soluzione.

  5. Seguire la finestra di dialogo Esporta soluzione e verificare che la soluzione venga esportata come non gestita.

  6. Dopo l'esportazione della soluzione, decomprimere il contenuto del file della soluzione.

  7. Nella cartella decompressa fare clic con il pulsante destro del mouse, customizations.xml, scegliere Apri con e selezionare Blocco note.

  8. In base alla posizione in cui si trova la voce duplicata nell'interfaccia utente del client Web, individuare e rimuovere la voce duplicata della mappa del sito. Ad esempio, se la voce duplicata della mappa del sito era Accounts(1) e questa viene visualizzata nel riquadro Vendite, la voce duplicata verrà visualizzata come indicato di seguito:

    <Area Id="SFA" ResourceId="Area_Sales" Icon="/_imgs/sales_24x24.gif" DescriptionResourceId="Sales_Description">
    <ID del gruppo="SFA">
    <SubArea Id="nav_leads" Entity="lead" DescriptionResourceId="Lead_SubArea_Description"
    GetStartedPanePath="Leads_Web_User_Visor.html" GetStartedPanePathAdmin="Leads_Web_Admin_Visor.html"
    GetStartedPanePathOutlook="Leads_Outlook_User_Visor.html"
    GetStartedPanePathAdminOutlook="Leads_Outlook_Admin_Visor.html" />
    <SubArea Id="nav_oppts" Entity="opportunity" DescriptionResourceId="Opportunity_SubArea_Description"
    GetStartedPanePath="Opportunities_Web_User_Visor.html" GetStartedPanePathAdmin="Opportunities_Web_Admin_Visor.html"
    GetStartedPanePathOutlook="Opportunities_Outlook_User_Visor.html" GetStartedPanePathAdminOutlook="Opportunities_Outlook_Admin_Visor.html" />
    <SubArea Id="nav_accts" Entity="account" DescriptionResourceId="Account_SubArea_Description"
    GetStartedPanePath="Accounts_Web_User_Visor.html" GetStartedPanePathAdmin="Accounts_Web_Admin_Visor.html"
    GetStartedPanePathOutlook="Accounts_Outlook_User_Visor.html"
    GetStartedPanePathAdminOutlook="Accounts_Outlook_Admin_Visor.html" />
    <SubArea Id="nav_accts" Entity="account" DescriptionResourceId="Account_SubArea_Description" GetStartedPanePath="Accounts_Web_User_Visor.html"
    GetStartedPanePathAdmin="Accounts_Web_Admin_Visor.html"
    GetStartedPanePathOutlook="Accounts_Outlook_User_Visor.html"
    GetStartedPanePathAdminOutlook="Accounts_Outlook_Admin_Visor.html" />

    Come illustrato in precedenza, l'Id risorsa area è Area_Sales, mentre nell'elemento di Mappa del sito originale e duplicato per gli Account è elencato nei tag ID SubArea in grassetto.

  9. Dopo aver rimosso la voce duplicata, salva il file customizations.xml.

  10. Reimpacchettare i file customizations.xml, [Content_Types].xml e solution.xml in un nuovo file compresso. Selezionare questi file, fare clic con il pulsante destro del mouse, selezionare Invia a e selezionare Cartella compressa compressa.

  11. In Microsoft Dynamics CRM selezionare Impostazioni e quindi Soluzioni.

  12. Selezionare Importa.

  13. Selezionare il file ZIP della soluzione mappa del sito modificato, selezionare Avanti.

  14. Selezionare Avanti nella finestra di dialogo Importa soluzione . Seleziona Pubblica tutte le personalizzazioni. Selezionare Chiudi.

Ulteriori informazioni

Se si verificano ancora problemi durante la connessione di Microsoft Dynamics CRM per Outlook all'organizzazione di Microsoft Dynamics CRM Online, è disponibile uno strumento di diagnostica per diagnosticare il problema:

Supporto tecnico Microsoft e Assistente ripristino