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Questo articolo consente di risolvere un problema in cui viene visualizzato l'errore "Cassetta postale non ha un indirizzo di posta elettronica valido" quando si usa la sincronizzazione lato server in Microsoft Dynamics 365.
Si applica a: Microsoft Dynamics CRM 2016
Numero KB originale: 3214684
Sintomi
Quando si testa e si abilita una cassetta postale in Dynamics 365, si verifica uno degli errori seguenti nell'area Avvisi:
Gli appuntamenti, i contatti e le attività non possono essere sincronizzati perché il nome< della cassetta postale >non ha un indirizzo di posta elettronica valido. Specificare un indirizzo di posta elettronica valido nel record della cassetta postale e quindi abilitare la cassetta postale per la sincronizzazione di appuntamenti, contatti e attività.
Codice errore del server di posta elettronica: Exchange.server ha restituito l'errore ErrorNonExistentMailbox.
Si è verificato un errore di accesso alla cassetta postale generale durante l'invio del messaggio di posta elettronica "La cassetta postale è ora connessa a Dynamics 365". Cassetta postale [Nome cassetta postale] non sincronizzata. Il proprietario del profilo del server di posta elettronica associato Microsoft Exchange Online è stato informato.
Codice errore del server di posta elettronica: il server exchange ha restituito l'eccezione ErrorInvalidOperation.
Non è possibile ricevere messaggi di posta elettronica per la cassetta postale [Nome cassetta postale] perché il record della cassetta postale non ha un indirizzo di posta elettronica valido. La cassetta postale non è stata sincronizzata. Una notifica su questo viene registrata nella bachea degli avvisi per il proprietario del profilo del server di posta elettronica Microsoft Exchange Online.
Codice errore del server di posta elettronica: Exchange.server ha restituito l'errore ErrorNonExistentMailbox.
Causa
Questo errore può verificarsi per uno dei seguenti motivi:
- Impossibile trovare la cassetta postale per l'utente perché l'indirizzo di posta elettronica non è corretto.
- L'indirizzo di posta elettronica è relativo a un gruppo di distribuzione, che non è una cassetta postale.
- La cassetta postale è configurata per l'uso di un profilo di Exchange Online, ma la cassetta postale dell'utente si trova in Exchange locale
Risoluzione
Per risolvere questo problema, seguire questa procedura:
- Verificare che l'indirizzo di posta elettronica del record della cassetta postale in Dynamics 365 corrisponda all'indirizzo di posta elettronica in Exchange. L'errore include un collegamento al record della cassetta postale in Dynamics 365. È possibile usare questo collegamento per verificare rapidamente il campo Indirizzo di posta elettronica.
- Verificare che l'indirizzo di posta elettronica sia relativo a una cassetta postale effettiva e non a un gruppo di distribuzione. I gruppi di distribuzione non sono cassette postali che archiviano la posta elettronica. I gruppi di distribuzione vengono usati per distribuire messaggi di posta elettronica alle cassette postali membri del gruppo.
- Se la cassetta postale dell'utente si trova in Exchange locale, assicurarsi di usare un profilo Exchange Server (ibrido) in Dynamics 365 anziché un profilo di Exchange Online.
Ulteriori informazioni
Quando si fa clic su Visualizza dettagli, vengono visualizzati dettagli di errore simili ai seguenti:
>Errore: <ResponseMessageType xmlns:q1="
https://schemas.microsoft.com/exchange/services/2006/messages
" p2:type="q1:FindItemResponseMessageType" ResponseClass="Error" xmlns:p2="https://www.w3.org/2001/XMLSchema-instance
"><q1:MessageText>La casella di posta non esiste.</q1:MessageText><q1:ResponseCode>ErrorNonExistentMailbox</q1:ResponseCode><q1:DescriptiveLinkKey>0</q1:DescriptiveLinkKey></ResponseMessageType>
>Errore: <ResponseMessageType xmlns:q1="
https://schemas.microsoft.com/exchange/services/2006/messages
https://www.w3.org/2001/XMLSchema-instance
" p2:type="q1:ItemInfoResponseMessageType" ResponseClass="Error" xmlns:p2="><" q1:MessageText>SendOnly non può essere utilizzato da un utente senza una cassetta postale. Utilizzare SendAndSaveCopy e specificare un ID della cartella in una cassetta postale per inviare un elemento da un account che non dispone di una cassetta postale.</q1:MessageText><q1:ResponseCode>ErrorInvalidOperation</q1:ResponseCode><q1:DescriptiveLinkKey>0</q1:DescriptiveLinkKey><q1:Items /></ResponseMessageType>