Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una risoluzione del problema che la sincronizzazione offline ha esito negativo quando si modificano i filtri di sincronizzazione offline per il processo di sincronizzazione offline nel client Microsoft Dynamics CRM per Microsoft Office Outlook.
Si applica a: Microsoft Dynamics CRM 2011
Numero KB originale: 2715857
Sintomi
Quando si modificano i filtri di sincronizzazione offline per il processo di sincronizzazione offline nel client Microsoft Dynamics CRM per Outlook con accesso offline, potrebbero verificarsi errori simili al seguente:
La dimensione del file BCP è errata. Actual:1151232800. Previsto:1151232478"
"Eccezione crm: messaggio: il client non è riuscito a scaricare il file BCP. ErrorCode: -2147204572"
"La dimensione del file BCP non è corretta." Actual:516357050. Previsto: 516356728
"La dimensione del file BCP non è corretta." Actual:293877994. Valore previsto: 293877672"
"Scaricato 0 byte per l'entità Annotation, batchSize= 146"
"CRM eccezione: messaggio: dati non spostati correttamente per l'entità 'nota' durante l'azione di inserimento, countRows=584, ErrorCode: -2147204571"
Annotazioni
I valori effettivi e previsti vengono misurati in byte. Anche l'entità elencata potrebbe essere diversa.
Causa
Le dimensioni dei file BCP potrebbero essere troppo grandi o richiedono troppo tempo per il download dal server Microsoft Dynamics CRM perché contengono troppi dati.
Risoluzione
Modificare il Registro di sistema per il client Microsoft Dynamics CRM per Outlook con accesso offline per ottimizzare i valori usati per sincronizzare i dati da Microsoft Dynamics CRM al database SQL Express usato durante la modalità offline nel client Microsoft Dynamics CRM per Outlook con accesso offline.
Tutte le voci del Registro di sistema elencate di seguito sono presenti nel percorso seguente:
HKCU\Software\Microsoft\MSCRMClient
Nome: OfflineRowsBatchSize
Tipo: DWORD
Valore valido: valore intero positivo maggiore o uguale a 1
Valore predefinito: 10000
Scopo: dimensioni per ogni batch iniziale di dati scaricati dal server CRM.
Nome: OfflineMaxRetryCount
Tipo: DWORD
Valore valido: valore intero positivo maggiore o uguale a 1
Valore predefinito: 3
Scopo: numero di tentativi di ripetizione di un batch prima dell'esito negativo. Ogni errore può tentare nuovamente con dimensioni batch inferiori a seconda della velocità di diminuzione.
Nome: OfflineIncreaseRate
Tipo: DWORD
Valore valido: valore intero positivo maggiore o uguale a 1
Valore predefinito: 2
Scopo: determinare quanto le dimensioni del lotto successivo aumentino (dimensioni del lotto precedente * OfflineIncreaseRate) se il lotto precedente è stato completato correttamente nell'intervallo di tempo consentito.
Nome: OfflineDecreaseRate
Tipo: DWORD
Valore valido: valore intero positivo maggiore o uguale a 1
Valore predefinito: 2
Scopo: quanto il batch successivo viene ridotto in dimensioni (dimensione del batch precedente / OfflineDecreaseRate) se il batch precedente non è riuscito a completare correttamente o non è stato completato nell'intervallo di tempo consentito.
Nome: OfflineMaxBatchTimeMillSec
Tipo: DWORD
Valore valido: valore intero positivo maggiore o uguale a 1 misurato in millisecondi
Valore predefinito: 60000
Scopo: tempo massimo in millisecondi accettabile per scaricare un batch prima che le dimensioni del batch vengano ridotte.
Nome: OfflineMinBatchTimeMilliSec
Tipo: DWORD
Valore valido: valore intero positivo maggiore o uguale a 1 misurato in millisecondi
Valore predefinito: 10000
Scopo: tempo minimo in millisecondi accettabile per scaricare un batch prima che le dimensioni del batch vengano aumentate.
Annotazioni
OfflineMinBatchTimeMilliSec
deve essere minore o uguale a OfflineMaxBatchTimeMilliSec
.
Importante
Se si imposta OfflineMinBatchTimeMilliSec
uguale a OfflineMaxBatchTimeMilliSec
, le dimensioni del batch rimarranno invariate e non aumentano o diminuiscono mai. Ciò può causare la durata del processo di sincronizzazione molto più lungo del normale, ma può consentire il completamento del processo se gli errori ricevuti sono dovuti a un numero eccessivo di file che tentano di essere scaricati dal server CRM.